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Restrictions 
 
 
The CSPN-CSPL GUI is provided solely to Frederick T. Sheldon (hereafter referred to as the “customer”) 

and may not be used for commercial gain by any party other than the customer.  This document is provided 

as a part of the CSPN-CSPL GUI product and is subject to the same restrictions as that product. 

 

 

 

Warranties 

 
Mellow Yellow makes no warranty on the CSPN-CSPL GUI.  The GUI is delivered as-is and Mellow 

Yellow is not responsible for any loss of data, revenue, property or life incurred by the use of this software 

or user’s manual. 
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1. Introduction 
 
1.1 Intended Audience 

 
This manual is intended for users of the CSPN-CSPL port program.  This manual does not exp lain what 

Petri nets are or how to use them, so it is assumed that the user is already familiar with these.  It is also 

assumed that the reader knows the CSPN language and will not need an explanation of it. 

 

1.2  Applicability 
 

This manual documents Version 1.0 of the Win32 port of the CSPN-CSPL GUI.  The GUI will run on a 

minimum of aWin9x or WinNT operating system, with a Pentium or later processor with a VGA or better 

card.   

 

1.3  Purpose 

 
This software user’s manual will explain the various features offered in the CSPN-CSPL GUI.  It will cover 

the following areas: 

 

• The layout and components of the GUI 

• Invoking and using the text editor 

• Invoking and using the image viewer 

• Setting command options to send to the CSPN-CSPL port 

• Invoking the port and receiving messages from the port 

 

1.4 Document Usage Description 

 

(description of what each section contains, and the relationships between sections) 

 

1.5 Related Documents 

 

This software user’s manual stands alone and is the only document required to learn how to use the CSPN-

CSPL GUI.  Those who are interested in the design rationale and development process that went into the 

GUI will be interested in reading the following documents: 
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• Team 6:  Mellow Yellow CSPN-CSPL GUI Software Requirements Specification 

• Team 6:  Mellow Yellow Preliminary Design Review 

• Team 6:  Mellow Yellow Critical Design Review 

• Team 6:  Mellow Yellow CSPN-CSPL GUI Design Notebook 

 

1.6 Conventions 

 

 

1.7 Reporting Problems 

 
If a problem is encountered with this software or the user’s manual, please report it by sending an e-mail to 

khammil@eecs.wsu.edu. 
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2. The CSPN-CSPL GUI Interface 
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3. The Text Editor 
 

This section documents the use of the text editor that is provided with the CSPN-CSPL GUI. 

 

3.1       Editing a Document 
 

This section describes how to manipulate documents in the text editor 

 

3.1.1 Adding Text to a Document 

 

To add text to a document that you have already opened, simply click the mouse inside the open document 

window and begin typing.  Your typing will appear in the document.  In figure 3.1, the window titled 

“Text1” is an open text document.  If you were to click within it, you would be able to edit it. 

 

 

Figure 3.1:  An open text document that is ready to be edited 

 

3.1.2 Context Sensitive Highlighting 

 



 9

If you are editing a CSPN file, CSPN keywords will automatically be highlighted for you.  This allows you 

to enter and edit your code more accurately. 

 

Figure 3.2: CSPN keywords are automatically highlighted in CSPN documents 

 

3.1.3 The Status Bar 

 

The text editor window contains a status bar, shown in Figure 3.3, that indicates the current line number of 

the cursor within the currently selected document.  It also shows whether the Caps Lock or Num Lock keys 

are currently selected.  The left half of the status bar contains status messages and context sensitive help for 

menu items. 

 

Figure 3.3:  The text editor status bar  

 

3.2 File Management and Printing Operations 

 
This section describes how to open, close and save files in the text editor using the options in the File 

menu.  The file menu contains the operations pictured in Figure 3.4. 

 

 

 

Figure 3.4:  The text editor’s File menu 

 
3.2.1 Creating a New File 

 

To create a new file, select the New option from the File menu, or press the Control and N keys at the same 

time.  You will be presented with the dialog box shown in Figure 3.5.  This dialog box allows you to select 

from four different file formats:  ASCII text, CSPN text, Postscript and Dot.  Highlight one of the 
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selections and click OK to create a new file.  Alternatively, you may press the Cancel button to abort the 

creation of a new file. 

 

 

Figure 3.5: This dialog box allows you to select which type of new file you want to create 

 

3.2.2 Opening an Existing File 

 

In order to open a new file, select the Open option from the File menu, or press the Control and O keys at 

the same time.  The Open File dialog box should appear as shown in Figure 3.6.   

 

 

 

Figure 3.6:  The Open file dialog box 

 

You may type the name of the file you want to open into the “File name” field, or you may choose which 

types of file are shown in the file listing pane by selecting one of the options from the “Files of type” 



 11 

dropdown.  You may also use the mouse to select a file from the pane.  Once you have selected the file you 

want to open, double click its name in the listing pane or click the Open button to open it.  If at any point 

you wish to cancel the process of opening a new file, click the Cancel button. 

 

3.2.3 Closing an Open File 

 

You may close a document by selecting the Close option from the File menu, or by clicking the button with 

the X that is located in the upper right corner of the document window.  If you have not made any unsaved 

changes to the document then it will close immediately.  If you have made unsaved changes, then you will 

be presented with a confirmation dialog box like the one in Figure 3.7. 

 

 

 

Figure 3.7:  This dialog box asks whether you want to save your changes before you close your document. 

 

If you wish to save your changes, press the “Yes” button and they will be saved for you.  If you wish to 

discard your changes, press the “No” button.  If no longer wish to close your document window, press the 

“Cancel” button. 

 

3.2.4 Saving an Open File 

 

To save the changes you have made to a file, select the “Save” option from the File menu, or press Ctrl-S.  

If you have already given this file a name by saving it, you will not need to perform any further actions – 

your file will be saved for you.  If you have not yet given this file a name, then you will be presented with 

the “Save As” dialog box, shown in Figure 3.8. 
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Figure 3.8: The Save As dialog box 

 

This dialog box works in much the same way as the Open dialog box.  You may use the keyboard interface 

to type a filename into the “File name” field, or you may use the mouse to navigate through files in the 

display pane located above the “File name” field.  When you have given your file the name you want it to 

have, click the Save button, or click the Cancel button at any time to return to the editor without saving. 

 

If you have selected the name of a file that already exists, the editor will ask you to confirm that you want 

to save over the previous file by showing you the dialog box depicted in Figure 3.9.   

 

 

 

Figure 3.9:  You must confirm that you want to save over a file that already exists 

 

Saving over a file that already exists erases the contents of the old file and replaces them with your new 

file.  If you are sure that you want to save over the old file, press the “Yes” button.  If you want to go back 

and give your file a different name, click the “No” button. 

 

3.2.5 Saving an Open File Under a New Name 
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If you wish to change the name of a file you are working on, select the “Save As” option from the File 

menu.  You will be presented with the Save As dialog box, as described in section 3.2.4. 

 

3.2.6 Printing a File 

 

In order to print a file, select the “Print” option from the File menu or press Ctrl-P.  This brings up the Print 

dialog that is shown in Figure 3.10. 

 

 

Figure 3.10:  The Print dialog box 

 

From this dialog box, you can select which printer you want to use to print your file by choosing it from the 

“Name” dropdown.  You can bring up your printer’s specific configuration information by pressing the 

“Properties” button.  The text below the printer name gives status information about the printer.  In the 

“Print Range’ area you can choose to print a portion of the pages of your document, although the default 

selection is to print the entire document.  In the “Copies” area you can specify that you want to print more 

than one copy.  By default, only one copy will be printed.  When you are satisfied with your option 

selections, press the “OK” button to commence printing.  You may return to the text editor at any time by 

pressing the “Cancel” button. 

 

3.2.7 Previewing a File 
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If you wish to see how your file will look when it is printed out, select the “Print Preview” option from the 

File menu.  The Print Preview screen will appear, as shown in figure 3.11. 

 

 

 

Figure 3.11:  The Print Preview screen 

 

The Print Preview screen shows how your file will look when printed out.  You may use the scroll bars to 

navigate around the document, or you may use the buttons at the top of the screen.  The “Print” button will 

take you to the Print dialog box that is described in section 3.2.6.  The “Next Page” and “Prev Page” 

buttons allow you to navigate to the next and previous pages of your document, respectively.  The “Two 

Page” button causes the print preview to show you two pages of your document at once.  The “Zoom In” 

and “Zoom Out” buttons give you a more detailed and less detailed look at your document, respectively.  

Finally, the “Close” button returns you to the main text editor screen. 

 

3.2.8 Setting Up a Printer 

 

If you want to set the orientation or size of your printed page, you should select the “Print Setup” option 

from the File menu, which will produce a dialog box like the one in Figure 3.12. 
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Figure 3.12:  The Print Setup dialog box 

 

The Print Setup dialog box allows you to select a printer in the same manner as the Print dialog box 

described in section 3.2.6.  After you have selected the printer you want to use, the Paper area lets you 

specify the size and source of the paper you are using.  The Orientation area gives you the choice of 

printing in portrait orientation (the default) or in landsacpe orientation. 

 

3.3 Editing Operations  

 
This section describes how to use the editing features of the text editor using options in the Edit menu.  

Figure 3.13 shows how the Edit menu looks. 
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Figure 3.13:  The Edit menu 
 

3.3.1 Undoing an Operation 

 

You may undo your most recent editing or typing operation by selecting the Undo option from the Edit 

menu or by pressing Ctrl-Z at any time.  The document will revert to its previous state. 

 

3.3.2 Cutting Text 

 

You may cut text from the document by highlighting the text you want to cut with the mouse or with the 

keyboard and selecting the “Cut” option from the Edit menu or pressing Ctrl-X.  The text you have cut will 

be placed onto the clipboard for you. 

 

3.3.3 Copying Text 

 

You may copy text from the document onto the clipboard by highlighting it and selecting the “Copy” 

option from the Edit menu.  You may also press Ctrl-C to copy text. 

 

3.3.4 Pasting Text 

 

You may paste text from the system clipboard into the document by positioning the cursor where you want 

the text to go and selecting the “Paste” option from the Edit menu.  You may also press Ctrl-V to paste text. 

 

3.3.5 Clearing Text 

 



 17 

You may delete text from a document by selecting the portion of the text that is to be removed and 

selecting the “Clear” option from the Edit menu. 

 

3.3.6 Selecting an Entire Document 

 

You may highlight the entire text of a document by choosing the “Select All” option from the Edit menu. 

 

3.3.7 Finding Text Within a Document 

 

The text editor has the capability to search for strings of text within a document.  In order to use this 

capability, select “Find” from the Edit menu.  This will bring up the “Find” dialog box that is illustrated in 

Figure 3.14. 

 

 

Figure 3.14:  The Find dialog box allows you to search for text within a document. 

 

Type the string that you want to search for into the “Find what” field.  The search will begin from the 

current cursor position; if you want the search to proceed downward in the document from that position, 

then leave the “Down” radio button selected in the “Direction” area.  If you want to search upward from the 

cursor posit ion then select the “Up” button instead.  Choose whether you want your search to be case 

sensitive – if so, you must check the “Match case” box in the lower left corner.  Finally, click “Find Next” 

to perform the search.  The first instance of your string that the search finds will be highlighted.  If no 

instances are found in the entire document, then the search will inform you of this fact. 

 

If you wish to abort the search, you may press the “Cancel” button at any time. 

 

3.3.8 Replacing Text Within a Document 

 

The text editor also contains a feature which lets you search for occurrences of a string and replace them 

with different text.  The replacement process proceeds in much the same way as the process of finding text, 
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described in section 3.3.7.  First, activate the “Replace” dialog box by selecting “Replace” from the Edit 

menu.  Figure 3.15 shows you what the Replace dialog looks like. 

 

 

 

Figure 3.15:  The Replace Dialog 

 

To replace one string with another one, first enter the string that you want to search for into the “Find what” 

field. Then enter the string you want to replace it with in the “Replace with” field.  If you wish your search 

to be case sensitive, then check the “Match case” box in the lower left corner of the Replace dialog.   

 

Now you may click the “Find Next” button to find the first instance of your search string.  If no strings 

matching your search criteria are found then the search will tell you this.  Once an instance has been found, 

it is highlighted and you have the option of replacing it with your designated replacement string.  If you 

wish to replace this occurrence, click the “Replace” button.  Otherwise, click the “Find Next” button to skip 

this instance and continue on to the next one. 

 

If you are sure that you want to replace all occurrences of your search string, then you may just click the 

“Replace All” button to accomplish this without being prompted at every replacement.  As always, you 

may click the “Cancel” button at any time to abort the search and replace procedure. 

 

3.3.9 Repeating a Find or Replace Search 

 

If you have already conducted a search on a document and wish to repeat the same search again, select the 

“Repeat” option from the Edit menu.  The search will be automatically started for you. 

 

3.4 Viewing Options 
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This section describes how to configure the display of the text editor using options in the View menu.  The 

View menu is shown in Figure 3.16 

 

 
Figure 3.16:  The View menu 

 

3.4.1 Showing and Hiding the Toolbar 

 

You may toggle the visibility of the toolbar by selecting the “Toolbar” option from the View menu.  If the 

toolbar is currently visible, then choosing the “Toolbar” option hides it, and vice versa. 

 

3.4.2 Showing and Hiding the Status Bar 

 

You may toggle the visibility of the status bar by selecting the “Status Bar” option from the View menu.  If 

the status bar is currently visible, then choosing the “Status Bar” option hides it, and vice versa. 

 

3.5 Window Management Options 

 

This section describes how to control the way windows are displayed using options in the Window menu.  

The Window menu is shown in Figure 3.17. 

 

 

 

Figure 3.17:  The Window menu 

 

3.5.1 Creating a New Window 



 20 

 

You may create a new window within the text editor by selecting the “New Window” option from the 

Window menu.  This creates a new document with the same name as the currently selected window.  See 

Figure 3.18 for an example. 

 

 

 

Figure 3.18:  Text1:2 is a new window created using the option from the Window menu 

 

3.5.2 Selecting the Window Display Mode 

 

If you have several windows open, it can quickly become tedious to manage them.  The text editor will take 

care of this task for you.  If you select the “Cascade” option from the Window menu, your windows will be 

arranged as in Figure 3.19. 
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Figure 3.19:  The three windows are displayed in cascade mode 

 

If you select the “Tile” option from the Window menu, your windows will be arranged in a different mode, 

demonstrated in Figure 3.20. 
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Figure 3.20:  The windows are tiled on the screen 

 

Finally, if you have some of your windows minimized, you can arrange their icons at the bottom of the text 

editor by selecting “Arrange Icons” from the Window menu.  This is shown in Figure 3.21. 
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Figure 3.21:  The icons at the bottom of the window were placed using the “Arrange Icons” option. 

 

3.5.3 Changing Between Active Windows 

 

The Window menu contains a listing of all of the open windows.  You may switch between windows by 

selecting the desired window’s name from the Window menu.  

 

3.6 Displaying Information About the Text Editor 

 
This section describes how to display the text editor’s version information using an option in the Help 

menu.  The Help menu is shown in Figure 3.22. 

 

 
Figure 3.22:  The Help Menu 
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If you select the “About Text Editor” option then you will see the About dialog box, pictured in Figure 

3.23. 

 

 
Figure 3.23:  The About dialog box displays information about the text editor 

 

You may dismiss the informational dialog box by pressing the “OK” button. 

 

3.7 The Toolbar 

 

The toolbar provides one click access to some of the commonly used menu items.  It is shown in Figure 

3.24. 

 

 

Figure 3.24:  The toolbar 

 

The first three options correspond to the “New”, “Open” and “Save” options from the file menu.  The next 

three options correspond to “Cut”, “Copy” and “Paste” from the Edit menu.  The last pair of options 

represents  “Print” from the File menu and “About Text Editor” from the Help menu. 
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4. The Image Viewer 
This section documents the use of the image viewer that accompanies the text editor. 

4.1 File Management Operations 

 
4.1.1 Opening a file 

In order to get into the image viewer, start up the text editor, and hit “Cancel” when the “New File” 

menu pops up (see Figure 3.5 in the Text Editor section).  Then, to open a new file, go to the 

“File” menu and select ‘Open” (see Figure 4.1 below).   

                       Figure 4.1 – the Image Viewer file menu 

 

Once you click on “Open” a standard Windows open file menu will open up (see figure 4.2 below). 

   Figure 4.2 – the Image Viewer open file menu 

 

Navigate to the directory you want through the Windows directory tree.  To view only the .BMP 

files in that directory, click on the pull-down menu at the bottom of the window and select “BMP 

File(*.bmp)” (see figure 4.2).  Then, double-click on the file you want, and watch it appear in the 

Image Viewer window, as seen below in Figure 4.3. 
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    Figure 4.3 – an opened BMP file 

 

4.1.2 Closing a file 

To close an opened file, go to the “File” menu and select “Close” (see Figure 4.1).  The opened 

file window will close immediately, leaving you free to open another window or exit the program. 

 

4.2 Help Commands 
4.2.1 Viewing the help topics 

To see an alphabetical listing of all the help topics available, go to the “Help” menu and select 

“Help Topics,” as in Figure 4.3 below. 

    Figure 4.4 – Image Viewer help menu 

4.2.2 Viewing information about the Text Editor and Image Viewer 

To find out more about the program and its designers, go to the “Help” menu and click on “About 

Image Viewer” (see figure 3.23).   
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4.3 Image Viewer Toolbars 
4.3.1 Menu shortcut toolbar 

    Figure 4.5 – menu shortcut toolbar 

 

The menu shortcut toolbar is very similar to that in the Text Editor.  The leftmost button is for 

creating a new document.  The one following opens an existing file.  The next button saves a file, 

and the three buttons to the right of it are cut, copy, and paste.  Following that is the print button, 

then “About”, and finally the help button.  To use any of the buttons, simply click on one of them. 

 

4.3.2 Drawing Toolbar 

    Figure 4.6 – drawing toolbar 

 

The drawing toolbar is for drawing different shapes.  The two buttons on the left are for drawing 

circles, and filled circles.  The next two draw ellipses and filled ellipses.  The next button draws 

straight lines.  Following it are the buttons to draw rectangles and filled rectangles, and then 

squares and filled squares.  The last button is the object selector.  To draw any shape, just click 

on the appropriate button, then click on the screen at the spot where you want the shape to 

appear, then drag in any direction until the needed shape has been drawn. 
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5. Error Conditions 
None at current press time. 
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Appendix A:  Data Formats and File Structures 

 

A.1 ASCII Text 
ASCII is a universally recognized format for text files.  The file created will be a simple, no-frills text file 

without the extensive formatting options usually associated with MS Word or other complex word 

processing programs.  The file thus created will be readable on any other system through any text viewer.  

A.2 CSPN Highlighted Keywords 
This type of file will be written in CSPL (CSP to Stochastic Petri Net Language), and will be the “meat and 

potatoes” of this project.  The reserved CSPL/CSPN keywords in the file will be highlighted for the user’s 

convenience.   

A.3 Postscript 
Postscript is  a special  file format that can hold both text and graphical data using a minimum of 

storage space.  The format is popular, but far from universally readable, and requires a special 

kind of program to view it.  However, it is very convenient, which is why our program includes the 

ability to read postscript files. 

A.4 GIF 

 
The GIF file format is commonly associated with the .gif extension.  GIF (Graphics Interchange File) 

images commonly have a color depth of 8 bits and are suitable for line drawings, diagrams and other 

images that have relatively uniform fields of color.  The GIF algorithm does not usually look accurate when 

applied to photographic images or other images with a large number of colors. 

 

A.5 JPEG 

 
The JPEG file format is commonly associated with the .jpg and .jpeg extensions.  JPEG (Joint Photographic 

Experts Group) images can have a color depth up to 24 bits, allowing for fully realistic color representation.  

The JPEG algorithm is more efficient than the GIF algorithm on photographic pictures and also yields more 

accurate results. 

 

A.6 BMP 

 
The BMP file format is commonly associated with the .bmp file extension.  It is a very simple compression 

algorithm that can have color depths up to 24 bit, although 8-bit bitmaps are also commonly found.  The 

BMP compression algorithm quite inefficient in comparison with the GIF and JPEG algorithms.  BMP files 
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have the advantage that they are standardly accepted by many Windows programs, though.
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Appendix B:  Sample Files 

1.  Crossing: 

Crossing = 
 
 PROCESS A = {SKIP}; 
 PROCESS B = {SKIP}; 
 PROCESS C = {SKIP}; 
 PROCESS D = {SKIP}; 
 PROCESS E = {SKIP}; 
 PROCESS F = {SKIP}; 
 
Mu.X { PAR { { SEQ { A(), C(), E() } -> X }, 
   INH { C(), |D()|, E() }, 
  { SEQ { B(), D(), F() } -> X }, 
   INH { D(), |C()|, F() } 
 } 
}. 
 
2. Arbiter: 

-- arbiter 
-- Model of 2 processors and 1 arbiter using a common bus. 
-- Each processor requests use of the bus, when the arbiter returns 
-- a grant signal to a processor, the processor then begins to access 
the bus 
-- non-deterministically choosing read or write access. 
-- When the processor has completed it's access it returns a release  
-- message to the arbiter to release the bus for use. The processor 
then 
-- updates its own private memory before requesting bus access again. 
-- The processors are message synchronized with the arbiter for bus 
control, 
-- all three processes are parallel in operation. 
-- Request - request access channel uses messages uniquely identified 
to  
--           each processor 
-- Grant - access granted channel uses messages uniquely identified to  
--         each processor 
-- Read - read operation each operation is uniquely identified to  
--        each processor 
-- Write - write operation each operation is uniquely identified to  
--         each processor 
-- Realease_Bus - return bus control to arbiter signal channel uses  
--                messages uniquely identified to each processor 
-- Update_PM -- Update private memory operation each operation is  
--              uniquely identified to each processor 
 
Arbiter =  
 
 
  PROCESS P1 = 
     Mu.Z1{ 
        SEQ{ 
-- request bus access 
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           {Request ! req1}, 
-- wait for access granted message 
           {Grant ? grant1}, 
-- perform read/write operation 
           NDC{ 
              Read1(), 
              Write1() 
           }, 
-- send message indicating access operation complete 
           {Rel_Bus ^ rel1}, 
-- update private processor memory 
           Update_PM1() 
        } 
     }; 
 
PROCESS P2 = 
     Mu.Z2{ 
        SEQ{ 
-- request bus access 
           {Request ! req2}, 
-- wait for access granted message 
           {Grant ? grant2}, 
-- perform read/write operation 
           NDC{ 
              Read2(), 
              Write2() 
           }, 
-- send message indicating access operation complete 
           {Rel_Bus ^ rel2}, 
-- update private processor memory 
           Update_PM2() 
        } 
     }; 
 
 
 
  PROCESS bus = 
     Mu.Y{ 
         DC{ 
-- wait for request for bus access from processor 1 
-- grant access 
-- wait for processor done 
              Request ? req1 { 
                 {Grant ^ grant1}, 
                 {Rel_Bus ? rel1} 
              }, -- end receive request 1 
 
-- wait for request for bus access from processor 2 
-- grant access 
-- wait for processor done, 
              Request ? req2 { 
                 {Grant ^ grant2}, 
                 {Rel_Bus ? rel2} 
              }  -- end receive request 2 
            }-- end DC, 
     }; 
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Mu.X { 
     PAR{ 
        P1(), 
        P2(), 
        bus() 
 
        (req1, grant1, rel1, 
         req2, grant2, rel2) 
     } 
}. 
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Glossary 

 
ASCII – American Standard Code for Information Interchange.  It defines a standard way for representing 

characters on computers. 

BMP - .bmp file extension. Bitmap graphic file format 

CSP – Communicating Sequential Processes (process algebra) 

CSPN – CSP-to-Stochastic Petri Nets 

CSPL – C-like Stochastic Petri Net Language 

GIF (Graphics Interchange Format) – .gif file extension.  A special file format developed by CompuServe 

to store graphics that all computers can use.  Up to 256 colors. 

GUI – Graphical User Interface 

JPEG (Joint Photographic Experts Group) – .jpg file extension.  Up to 16 million colors.  For storing 

digitized photographs, the JPEG standard offers sharper resolution, but the older .GIF standard works better 

for plain line drawings or clip art. 

PostScript – A page description language developed by Adobe Systems. 

SPNP – the product generated by our associated Port team, which carries out the actual work of parsing 

CSPL files. 

 


