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Preface

UltraSAN is a software tool for model-based performance, dependability and performability evalu-

ation of computer, communication and other systems. The tool provides high-level modeling con-

structs in the form of stochastic activity networks (SANs), and offers hierarchical modeling by means

of composed models. To specify performance and dependability measures for these models, reward

variables are used. Given the SAN, composed model and reward variables, the tool either generates

an executable discrete-event simulation or an underlying stochastic process, which then is solved by

analytic methods. UltraSAN Version 3.0 provides six analytic solvers and three discrete-event sim-

ulators, one based on importance sampling. Furthermore, the report generator facilitates the gener-

ation of graphs and tables from the obtained performance results. UltraSAN Version 3.0 runs under

Unix, and is available for HPs, SUN OS 4.1.3, DECstations and IBM RS6000s.

The UltraSAN software has evolved over the last six years, and the UltraSAN team is now lo-

cated at the Center for Reliable and High-Performance Computing, within the Coordinated Sci-

ence Laboratory, at the University of Illinois at Urbana-Champaign. In addition to tool develop-

ment, the main research in the UltraSAN group is carried out in theory and application of model-

based quantitative evaluation. To obtain further information about our group, inspect the world-

wide web pages at the http address http://www.crhc.uiuc.edu/ UltraSAN. The research pa-

pers of our group are also obtainable by anonymous ftp at ftp.crhc.uiuc.edu in the directory

pub/UltraSAN/USAN papers. Of course, you can also reach us via e-mail, at usan-info@crhc.

uiuc.edu, and we are happy to provide you with further information.

If you are interested in using UltraSAN, and do not possess a license yet, please send an e-mail to

usan-request@crhc.uiuc.edu. When used for research and educational purposes, UltraSAN is

provided free. Use the address on the next page to contact us by regular mail, phone or fax, regarding

software or documentation.
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UltraSAN, c/o W. H. Sanders
Coordinated Science Laboratory

University of Illinois at Urbana-Champaign
1308 W. Main St., Urbana, IL 61801

phone: (217) 333-0345, fax: (217) 244-5686
e-mail: usan@crhc.uiuc.edu

ftp: ftp.crhc.uiuc.edu
world wide web: http://www.crhc.uiuc.edu/UltraSAN

Finally, if you like to stay informed about research and tool development in the UltraSAN group,

send us an e-mail at usan@crhc.uiuc.edu. We then add you to a mailing list of tool users and other

interested parties, and will keep you informed about developments in our group.



How To Use This Manual

The user’s manual for UltraSAN Version 3.0 discusses all features of the UltraSAN tool, how to in-

stall UltraSAN on your system, and how to set up your account in order to use the tool. As this manual

will be used by different people for different purposes, we have listed the parts of the manual which

will be of interest to different readers.

Installation If you plan to install UltraSAN on your computer, see Appendix A for an explanation

of how to do this.

New User If you will be using UltraSAN for the first time, read Appendix A which explains how

to set up the environment of your computer account. Furthermore, Chapter 2 provides a tutorial that

step-by step illustrates the use of UltraSAN for an example model.

Inexperienced with SANs If you want to model with UltraSAN but do not have a detailed knowl-

edge of how SANs work, first read through the theory described in Chapter 1, and consult the refer-

ences therein.

Experienced User If you understand the basic use of UltraSAN but want to look up how specific

aspects of the tool function, Chapter 3 provides a reference guide that explains the operation of the

individual parts of the tool.

Solving a Model If you want to get an indication of which solver to choose for your model, read

Chapter 4. This chapter discusses the use of the solvers in detail, and provides hints for the use of

the different solvers.

Report Writing If you have successfully used the tool and want to document the results you have

obtained, take a look at the documentation options of the report generator, described in Chapter 5,

and the LATEX generator described in Section 3.2.

Advanced Simulation If your simulation has “rare events,” and if you are knowledgeable in the

area of discrete-event simulation, you might be interested in investigating the use of the importance

sampling simulator, described in Chapter 6.

Throughout the different chapters a running example of a faulty multi-processor illustrates the
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use of the tool. The running example is introduced in Chapter 1. Often, a surrounding box is used

to highlight text referring to the running example.

At the end of the different chapters a short bibliography is included which contains the references

used in that chapter. A full list of papers that are of interest for users of UltraSAN can be found in

Appendix D.

To emphasize terminology or text, we alternately use typed text or italics. The typed text is

especially reserved to denote menu buttons which the user can select. In particular, the A->B notation

is used to denote that menu item B can be selected in the window that appears after selecting item A.

Finally, we would like to encourage users of the manual to let us know about their experiences.

Please, give us your feedback about how we might improve the manual or UltraSAN itself. We can

be reached at the address given in the Preface.



Chapter 1

Modeling with Stochastic Activity
Networks

This chapter discusses the theoretical background necessary to successfully use UltraSAN. The fol-

lowing topics will be discussed:

� stochastic activity networks,

� composed models,

� performability measures,

� underlying stochastic processes and state space generation.

The discussion will be kept concise and tailored to aspects that are relevant for UltraSAN users. For

an extensive discussion consult the references in Appendix D under the section entitled “Theory and

Algorithm Development.” In particular, the paper entitled “Specification and Construction of Per-

formability Models,” by Meyer and Sanders [1] provides a more detailed discussion of many of the

topics considered in this chapter.

1.1 Stochastic Activity Networks

Stochastic activity networks (SANs) [2, 3, 4], conceived in the early 1980’s, are a stochastic ex-

tension to Petri nets1. Using graphical primitives, SANs provide a high-level modeling formalism

with which detailed performance, dependability and performability models can be specified rela-

tively easy. This section provides a description of the modeling primitives used in SANs and of the

dynamics (i.e., the behavior in time or “execution”) of a SAN model.

1Petri nets are a model type, developed in the early 1960’s, that are used to prove logical properties about systems.

1-1
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queue num_tasks
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correct
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two fail
processing I_O

done
one fail
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check_done
arrival

capacity

Initial Marking = 1

Figure 1.1: SAN model of a faulty microprocessor.

1.1.1 SAN Primitives

SANs consist of four primitive objects: places, activities, input gates, and output gates. Activi-

ties represent actions of the modeled system. Places represent the state of the modeled system. Input

gates are used to control the “enabling” of activities, and output gates are used to change the state of

the system when an activity “completes.” Figure 1.1 is an example of a SAN model, representing

a faulty microprocessor system. This section will explain each of the SAN model primitives, using

Figure 1.1 as an example. The workings of this SAN will then be explained.

Places Places represent the state of the modeled system. They are represented graphically as cir-

cles. In Figure 1.1, size, queue, num tasks, ready, and done are places. Each place contains a certain

number of tokens, which represents the marking of the place. The set of all place markings rep-

resents the marking of the network. Note that tokens in a place are homogeneous, in that only the

number of tokens in a place is known; there is no delineation of specific tokens within a place.

The meaning of the marking of a place is arbitrary. For example, the number of tokens in a place

could represent a number of objects, such as a number of tasks awaiting service. Also, the number

of tokens in a place could represent an object of a certain type, such as a task with a certain priority

level. This dual nature of a place marking provides a great amount of flexibility in modeling the

dynamics of a system.

Activities Activities represent actions in the modeled system that take some specified amount of

time to complete. They are of two types: timed and instantaneous. Timed activities have durations

which impact the performance of the modeled system. Examples would be a packet transmission

time or the time associated with a retransmission timer. Timed activities are represented graphically

as hollow ovals. In Figure 1.1, arrival, access, processing, and I O are timed activities. Each timed

activity has an activity time distribution function associated with its duration. Activity time distri-
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bution function can be generally distributed random variables. Each distribution can depend on the

marking of the network. For example, one distribution parameter could be a constant multiplied by

the marking of a certain place. Instantaneous activities represent actions that complete in a negligi-

ble amount of time compared to the other activities in the system. They are represented graphically

as vertical lines; however, there are no instantaneous activities represented in Figure 1.1.

Case probabilities, represented graphically as circles on the right side of an activity, model un-

certainty associated with the completion of an activity. Each case stands for a possible outcome. Ex-

amples would be a routing choice in a network, or a failure mode in a faulty system. In Figure 1.1,

activity processing has three cases. Each activity has a probability distribution, called the case dis-

tribution associated with its cases. This distribution can depend on the marking of the network at

the moment of completion of an activity. If no circles are shown on an activity, one case is assumed

with a probability of one.

Also associated with each activity is a reactivation function. This function gives marking depen-

dent conditions under which an activity is reactivated. Reactivation of an activated activity means

that the activity is aborted and that immediately a new activity time is obtained from the activity time

distribution. The reactivation function consists of an activation predicate and a reactivation predi-

cate. An activity will be reactivated at the moment of a marking change if (1) the activity remains

enabled, (2) the reactivation predicate holds for the new marking, and (3) the activation predicate

holds for the marking in which the activity was originally activated.

Input gates Input gates control the enabling of activities and define the marking changes that will

occur when an activity completes. They are represented graphically as triangles with their point con-

nected to the activity they control. In Figure 1.1, capacity and available are input gates. On the

other side of the triangle are a set of arcs to the places upon which the gate depends, also called input

places. Input gates are defined with an enabling predicate and a function. The enabling predicate

is a Boolean function that controls whether the connected activity is enabled or not. It can be any

function of the markings of the input places. The input gate function defines the marking changes

that occur when the activity completes.

There is one short hand notation scenario for input gates. If a place is directly connected to an

activity, this is the same as an input gate with a predicate that enables the activity if there is at least

one token in the place, and a function that decrements the marking of the place (thus behaving as

an input arc in normal Petri nets). In Figure 1.1, this is shown by the connection of place queue to

activity access.

Output gates Like input gates, output gates define the marking changes that will occur when ac-

tivities complete. The only difference is that output gates are associated with a single case. They

are represented graphically as triangles with their flat side connected to an activity or a case. In Fig-
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Figure 1.2: Sample activity configuration.

ure 1.1, correct and check done are output gates. On the other side of the triangle are a set of arcs

to the places affected by the marking changes. Output gates are defined only with a function. The

function defines the marking changes that occur when the activity completes.

There is also a default scenario for output gates. If an activity is directly connected to a place, this

is the same as an output gate with a function that increments the marking of the place. In Figure 1.1,

this is shown by the connection of activity access to place num tasks.

1.1.2 Marking Change Algorithms

As a SAN executes, it goes through a sequence of markings. A stable marking is one in which

no instantaneous activities are enabled; an unstable marking is one in which one or more instanta-

neous activities are enabled. Since unstable markings do not contribute to performability variables

(which will be discussed later in this chapter), we need not preserve information pertaining to them.

Therefore, the marking change algorithm descriptions will concentrate on obtaining sequences of

timed activity completions and reached stable markings. These algorithms will now be explained.

Enabling and completion rules for activities Figure 1.2 shows a rather complicated configuration

of gates and places around an instantaneous activity, although the following is true for either timed or

instantaneous activities. For this activity to be enabled, the predicates of the two input gates would

have to be true, and there would have to be at least one token in both of the two directly connected

places. For a timed activity, these conditions have to be true throughout the duration of the activity

time for the activity to complete. Marking dependent case probabilities are evaluated with respect to

the marking of the SAN at the moment of completion of the activity. When the activity completes,

one of the three cases is chosen, based upon the case probability distribution. Then, the following

steps are taken:

1. all of the directly connected input places have their marking decremented;
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Figure 1.3: Execution of a timed activity.

2. all of the input gate functions are executed;

3. all of the places directly connected to the selected case have their marking incremented;

4. the functions of all of the output gates connected to the selected case are executed.

The above order is the order UltraSAN follows upon completion of an activity. Note that input gate

functions will be executed before output gate functions, but that there is no specified ordering within

each type of gate. Therefore, it should be ensured that the order in which input gate functions (and

output gate functions) are executed does not matter.

The activity that is chosen to complete in a certain marking is based upon the activity time dis-

tribution functions of each activity that is currently enabled, and the fact that instantaneous activities

have priority over timed activities. Figure 1.3 shows the four possible time lines for the execution

of a timed activity. The shaded areas represent time during which the activity is enabled. Each time



1-6 CHAPTER 1. MODELING WITH STOCHASTIC ACTIVITY NETWORKS

line shows the activity being enabled initially and an activity time scheduled. After the activity time

in (a), the activity completes, and the new marking is such that the activity is not enabled. After the

activity time in (b), the activity completes, and the new marking is such that the activity is still en-

abled. Before the activity can complete in (c), the enabling conditions become false, and the activity

is aborted. Finally, before the activity can complete in (d), the activity is reactivated and therefore

does not complete until its new activity time has elapsed.

Stabilizing and well specified SANs For each stable marking, we need to determine the set of

activities which may complete in that marking, the cases that may be chosen, and the probability

distribution on possible next stable markings. Given a choice of an activity and a case, the execution

of the appropriate gates may result in another stable marking, or it may not. If it does result in another

stable marking, the probability associated with this marking is merely the probability associated with

the chosen case. If it does not result in another stable marking, then we must recursively evaluate

every possible outcome of all the enabled instantaneous activities and all unstable markings resulting

from their completion.

Two important issues relate to the use of instantaneous activities. First, is there a reachable stable

marking, such that an activity which may complete in that marking, and a case that may be chosen

would cause an infinite sequence of instantaneous activity completions and unstable markings? If

not, then the SAN is stabilizing. It is not decidable whether a SAN is stabilizing [4]. The Ultra-

SAN implementation assumes a SAN is not stabilizing if a maximum number of intervening unsta-

ble markings is exceeded. The second issue relates to whether or not a model is well specified [4]. If

there is more than one instantaneous activity enabled in a certain marking, and the probability dis-

tribution on the next stable markings depends on which instantaneous activity is chosen to complete

first, the model is not well specified. Since the ordering of instantaneous activity completions is not

specified, this order must not matter if the SAN is to be solved. UltraSAN checks that models are

well specified each time an unstable marking is reached by checking that the probability of reaching

each possible next stable does not depend on choices among instantaneous activities that are made.

1.1.3 Faulty Microprocessor Example

As an example, consider a model of a faulty microprocessor system (similar to the model con-

sidered in [1]). Tasks for the processor arrive as a Poisson process with parameter �. Arriving tasks

are put in a queue of capacity L. If the queue is full, the task is rejected. The processor removes

tasks from the queue on a FIFO basis, which takes an exponentially distributed amount of time with

mean value 1=
. The processor can process a task in an exponentially distributed time with mean

value 1=�. It can also process a second task simultaneously, thereby completing both tasks at the

single-task rate �. Therefore, the processor can accept a new task if it is processing one or zero tasks
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Activity Distribution Parameter values

I O exponential
rate GLOBAL D(io rate)

access exponential
rate GLOBAL D(access rate)

arrival exponential
rate GLOBAL D(arr rate)

processing exponential
rate GLOBAL D(proc rate)

Table 1.1: Activity time distributions for the faulty microprocessor model.

Activity Case Probability

processing 1 if (MARK(num tasks) == 1)
return(1.0);

else return(GLOBAL D(ok prob));
2 if (MARK(num tasks) == 1)

return(ZERO);a

else return(GLOBAL D(one error prob));
3 if (MARK(num tasks) == 1)

return(ZERO);
else return(1.0�GLOBAL D(ok prob)-GLOBAL D(one error prob));

aThe value ZERO is a macro used by UltraSAN for distinguishing exactly zero from an arbitrarily small number.

Table 1.2: Activity case probabilities for the faulty microprocessor model.

currently.

If only one task is processed at a time, correct processing is guaranteed. If two tasks are pro-

cessed at a time, there is a chance of a processing error. With probability p1, both tasks are processed

correctly, and with probability p2 one task was processed incorrectly. When a task is processed cor-

rectly, it is sent to output. This I/O time is exponentially distributed with rate �. The processor may

not resume processing until all I/O is complete. A task that is processed incorrectly remains in the

processor for processing.

The SAN in Figure 1.1 represents the faulty microprocessor system just described. Tables 1.1,

1.2, 1.3, and 1.4 give the component definitions for the SAN. The model has been parameterized

via the use of “global variables”. Global variables are variables that are introduced while specifying

the model and are assigned specific values later while defining studies and experiments. They are of

two types: (a) double and (b) short represented by GLOBAL D and GLOBAL S, respectively. The

specific values assigned to these global variables represent the different values the input parameters
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Gate Definition

available Predicate
MARK(num tasks) < 2

Function
/� do nothing �/
;

capacity Predicate
/� has the buffer capacity been reached? �/
MARK(queue) < GLOBAL S(size)

Function
/� do nothing �/
;

Table 1.3: Input gate definitions for the faulty microprocessor model.

Gate Definition

check done /� when I/O done, reset ready �/
if (MARK(done) == 0)
MARK(ready) = 1;

correct /� put one or two tasks in done, clear num tasks �/
MARK(done) = MARK(num tasks) + 1;
MARK(num tasks) = 0;

Table 1.4: Output gate definitions for the faulty microprocessor model.
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to the model can take, and the studies and experiments constructed with these global variables can

be used to study the effect of changes in these parameters on the model. Thus, for example, the ar-

rival parameter � is represented by the global variable GLOBAL D(arr rate), the service parameter

� is represented by the global variable GLOBAL D(proc rate) and so on, as shown in Table 1.1. The

effect of different arrival and service times, for example, on the model performance can now be stud-

ied by assigning different values to these parameters. The assignment of different values is in turn

is done by defining different studies and experiments. All definitions in UltraSAN are given in ‘C’

syntax with the added notation of MARK(place) denoting the marking of the specified place.

The model behaves as follows. Activity arrival represents the time between arrivals of tasks to

the system. Its activity time is exponentially distributed with rate GLOBAL D(arr rate). Each time

it completes, it puts a token in place queue. Input gate capacity models the finite nature of the arrival

queue. Its enabling predicate indicates that activity arrival is only enabled as long as the marking of

place queue is less the global variable GLOBAL S(size), which represents the queue size of the multi

processor.

Activity access represents the time to assign a task to the processor. Its activity time is exponen-

tially distributed with rate GLOBAL D(access rate). It is enabled when there is at least one task in

place queue and there are less than two tasks in place num tasks (per the enabling predicate of input

gate available). When activity access completes, a token is put in place num tasks. Activity pro-

cessing is enabled when there is one or more tokens in place num tasks and there is a token in place

ready, which indicates that the processor is ready for processing. Activity processing represents the

time to process a task. Its activity time is exponentially distributed with rate GLOBAL D(proc rate).

When activity processing completes, the outcome depends on the number of tasks that were being

processed. This is seen in the activity’s case probabilities in Table 1.2. If only one task was being

processed (MARK(num tasks) == 1), then the first case is chosen with probability one. Output gate

correct is then executed, which puts one token in place done. Place done represents a queue of tasks

awaiting I/O. If two tasks were being processed, then the following may occur:

� With probability GLOBAL D(ok prob) (p1), case one is chosen, meaning both tasks were pro-
cessed correctly. Output gate correct puts two tokens in place done and removes all tasks from
place num tasks.

� With probability GLOBAL D(one prob error) (p2), case two is chosen, meaning one task was
processed incorrectly. The directed arc from place num tasks to activity processing causes one
token to be removed upon completion. The other token remains, representing the task that was
processed in error. One token is also put in place done.

� With probability 1:0�GLOBAL D(ok prob)�GLOBAL D(one error prob) (1� p1�
p2), case three is chosen, meaning both tasks were processed incorrectly. The directed arc from
place num tasks to activity processing causes one token to be removed upon completion, but
the arc from case three back to the place causes it to be put back, thereby leaving two tasks for
processing. Since no tasks are queued for I/O, the token in place ready is replaced.
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arrival

capacity

queue

Figure 1.4: SAN model buffer.

Activity I O represents the time to send a task to I/O. Its activity time is exponentially distributed with

rate GLOBAL D(io rate). When I/O is complete (MARK(done) == 0), the token in place ready is

replaced, indicating that the processor is ready for processing again. Tasks continue to arrive and

be processed according to these rules. The performance measures of interest for this model will be

explained later in this chapter.

1.2 Composed Model Specification

It can be cumbersome to specify large systems in terms of a single SAN. Composed models are

a hierarchical specification of SAN models and their corresponding performability variable speci-

fications (discussed later in this chapter). SAN models and their performability variable specifica-

tions are combined with replicate and join operations to form a composed SAN-based reward model

[4, 5, 6].

The replicate operation replicates a SAN and its performability variables a certain number of

times. A subset of its places, called its common places, are made common among all the replicated

submodels. This provides a means of communication between the submodels. Places that are not

common may have different markings in the different submodels. The join operation combines dif-

ferent types of submodels. Here again, common places are used for communication.

Example As an example, consider the extension of the faulty microprocessor model to an N -

processor system. Tasks arrive to the N -processor system just as before, but now there are N pro-

cessors removing tasks from the queue. Rather than building one SAN with N copies of the pro-

cessing part of the SAN, we can use the replicate operation and specify the number of copies N via

the global variable GLOBAL S(num processors). Figures 1.4 and 1.5 are the workload and process-

ing parts of Figure 1.1 respectively. All the components have the same definitions as before. Fig-

ure 1.6 represents the composed model of the GLOBAL S(num processors)-system. The pro-

cessor node represents the SAN of Figure 1.5. The Rep node represents the replication operation,

indicating that the processor SAN is to be replicated. Table 1.5 shows which places are common
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queue num_tasks
access

correct

available

two fail
processing I_O

done
one fail

ready

Initial marking = 1

check_done

Figure 1.5: SAN model processor.

processor buffer

Rep

Join

Figure 1.6: Faulty microprocessor composed model.

Node Reps Common Places
Rep GLOBAL S(num processors) queue

Table 1.5: Composed model replicate node definitions for project faulty proc.
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Node Common Places
Join Subtree 1 2

queue
p p

Table 1.6: Composed model join node definitions for project faulty proc.

places in the Rep node. Place queue is specified as common, since all processors are retrieving tasks

from the same queue. The buffer node represents the SAN of Figure 1.4. The Join node combines

the N copies of the processor to the SAN of the workload model. In Table 1.6 it is shown that place

queue is specified as common. As a consequence, tasks generated in the buffer SAN can be removed

by the processor SANs.

Besides simplicity of specification, composed SAN-based reward models also offer advantages

in the area of model solution. For analytic solution, composed models exploit symmetries in the

model to reduce the number of reachable states [5]. This is done by representing state as the number

of submodels in a particular state, rather than a vector of the state of each submodel. For simulation,

composed models reduce the overhead of event list manipulation by grouping events of the same

type [6].

1.3 Performability Variable Specification

Performability measures are used to gain information about the object system. So far, we have

been describing the specification of the composed model, which defines the stochastic process on

which this evaluation is based. Performability variable specification is a way of relating the stochastic

process to the performability measures of interest. There are two types of performability variables.

Reward variables are specified in terms of a common, uninterpreted unit of measure, called a unit

of reward. Reward variables can represent any aspect of system performance by giving ‘reward’ a

more specific interpretation. Activity variables represent the time between completions of a certain

activity. Each variable type will now be explained.

1.3.1 Reward Variables

A reward structure consists of two types of rewards: impulse rewards associated with state

changes, and rate rewards associated with the time spent in a state. The reward structure is defined

by associating impulse rewards with activity completions and rate rewards with times in particular

markings. The reward specification itself does not define the performability variable completely. In

particular, the following three aspects have to be further specified to complete the measure definition:
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� interval-of-time or instant-of-time measures,

� results for transient times or in steady-state,

� mean, variance, or the complete distribution of reward variable obtained.

Interval-of-time or instant-of-time. The reward accumulated over an interval of time [t0; t1]

is called an interval-of-time reward variable. Examples of interval-of-time measures are the number

of service completions in a time interval or the amount of time a system is functioning correctly in

the interval (“interval availability”). For rate rewards, which are assigned to a marking, the reward

is accumulated over the time the model spends in that marking. In case of impulse rewards, which

are assigned to an activity, the reward is counted every time the activity completes in the interval.

An often encountered variant of the interval-of-time measure is the time-averaged interval-of-time

measure for which the accumulated reward is divided by the length t1 � t0 of the interval.

Instant-of-time measures give the performability at a particular instant of time t. An example of

an instant-of-time measure is the number of elements in a buffer at moment t or the fact whether the

system is functioning or not at moment t (the “instantaneous availability”). For a rate reward, the

instant-of-time measure takes the value of the rate reward associated with the marking at moment t.

For an impulse reward, the measure takes the value of the impulse reward of to the activity that last

completed before time t.

Transient or Steady-State. The time instant t of an instant-of-time measure can be taken to

go to infinity, i.e., t!1. In this case the performability measure is called a steady-state measure,

while if t < 1 it is a transient measure. For an interval-of-time measure the steady-state measure

obtainable in UltraSAN results if the time-averaged measure is considered for t1 !1 in [t0; t1].

Mean, Variance or Distribution. Reward variables are random variables, which implies that

they can take different values with different probabilities. In other words, one can speak of the dis-

tribution of the variable, and consequently of its mean and variance. For instance, a reward variable

denoting the number of jobs in a buffer has a probability distribution over all possible values it can

take, and its mean corresponds to the expected or average buffer occupancy. Sometimes there will be

interest in the complete distribution, sometimes only its mean and/or variance. Note that the knowl-

edge of the full distribution implies that percentiles can be derived, i.e., the probability the reward

exceeds some value x is known for any x.

1.3.2 Activity Variables

A second type of variable supported in UltraSAN is the activity variable. Activity variables repre-

sent the time between successive completions of activities. We will call the time between completion

n� 1 and n the n-th inter-completion time. Clearly, this time has a distribution for which the mean

and the variance can be defined.
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Variable Definition

probability non�blocking
Rate rewards

Subnet = buffer
Predicate:

MARK(queue)< GLOBAL S(size)
Function:

1
Impulse rewards

none
Simulator statistics

Estimate mean and variance
Confidence Level = 0.95
Relative Confidence Interval = 0.10
Initial Transient = 1000
Batch Size = 1000
Variable type = Instant of Time
Start of Interval = 100.0
Length of Interval = 100.0

Table 1.7: Reward variable definitions for the faulty microprocessor model.

The notion of instant and interval-of-time measures as for reward variables does not exist for

activity variables. Instead, single inter-completion times or series of inter-completion times can be

considered. An example of a series is the distribution of the sum of the inter-completion times be-

tween the 11-th and 100-th completion. Notions similar to transient and steady-state reward variables

can be defined as follows. For a single inter-completion time, the value of n is finite in the transient

case while n!1 for the steady-state case.

Example Consider the reward variable specifications for the multiprocesor system described ear-

lier, given in Tables 1.7 and 1.8.

The convention used here and in UltraSAN is as follows. Rate rewards are given as a set of pred-

icate/function pairs. When the predicate is true, reward is earned at the rate specified by the function

and zero otherwise. The total rate is the sum of the reward contributed by each predicate/function

pair. Also, since the replicate operation replicates the reward structure as well as the SAN, the total

reward associated with a SAN is the sum of the rewards across all of its replications. Impulse rewards

are specified as a number associated with each activity. The simulator statistics apply to simulation

only and will be explained fully in Chapter 3.

Each variable will now be described. We display simulator statistics only for the variable proba-

bility non-blocking since the others are similar. Consider the variable in Table 1.7, which represents
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Variable Definition

utilization
Rate rewards

Subnet = processor
Predicate:

MARK(num tasks) > 0 && MARK(ready) == 1
Function:

1.0 / GLOBAL S(num proc)

number of tasks in queue
Rate rewards

Subnet = buffer
Predicate:

1
Function:

MARK(queue)

number of tasks in system
Rate rewards

Subnet = buffer
Predicate:

1
Function:

MARK(queue)
Subnet = processor
Predicate:

1
Function:

MARK(num tasks) + MARK(done)

fraction of time in I O
Rate rewards

Subnet = processor
Predicate:

MARK(ready) == 0
Function:

1.0 / GLOBAL S(num proc)

number of tasks processed
Impulse rewards

Subnet = processor
activity = I O, value = 1

Table 1.8: Reward variable definitions for the faulty microprocessor model.
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the probability that the queue is not full. The random variable for this reward variable is an indica-

tor random variable defined on the buffer subnet, taking a value of one when the queue is not full

(MARK(queue) < GLOBAL S(size)) and zero otherwise. The expected value of this variable is the

probability that the queue is not full. The utilization variable represents the utilization of the sys-

tem. It is defined on the processor subnet, which is replicated GLOBAL S(num processors) times.

Each replica adds a reward of 1:0=GLOBAL S(num processors), when it is currently processing

(MARK(num tasks) > 0 && MARK(ready) == 1) and zero otherwise, so this variable ranges from

zero to one.

The number of tasks in queue variable has a predicate of one (“true”), and therefore reward is

always accumulated. The reward is the marking of place queue, so this variable represents the num-

ber of tasks in the queue. The next variable uses a predicate/function pair defined on each sub-

net. The number of tasks in system variable represents the total number of tasks in the system, by

adding up the tokens in each num tasks place, the tokens in each done place, and the tokens in place

queue. The fraction of time in I O variable is also an indicator random variable, taking a value of

1:0=GLOBAL S(num processors) when the processor is doing I/O (MARK(ready) == 0) and

zero otherwise.

The number of tasks processed variable is an interval-of-time variable. It has no rate rewards,

and an impulse reward of one on activity I O. This means that a reward of one will be added to the

variable each time activity I O completes, representing the number of tasks that are processed in the

interval of interest.

Consider the activity variable specifications for the multiprocessor system described earlier,

given in Table 1.9. Activity variables are named by the variable’s subnet name and activity name.

Activity variable processor I O represents the time between the zeroth and 100th task completion,

and activity variable processor processing represents the time between the zeroth and 100th process-

ing completions.

1.4 Underlying Stochastic Processes and State Space Generation

To solve for the specified performability variable, either a simulation executable is generated

[6], or the state space and state transition matrix to be used for analytic evaluation is generated [5].

Simulation can be applied to any underlying stochastic process (and hence can be applied for any

specified SAN model), but to apply the analytic solvers the stochastic process must be of either of

the following two process types:

1. All activities are exponentially distributed (Markov processes)

Models where:

� all timed activities are exponentially distributed, and
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Variable Definition

processor I O
Simulator statistics

Estimate mean and variance
Confidence Level = 0.95
Relative Confidence Interval = 0.10
Initial Transient = 1000
Batch Size = 1000
First Completion = 0
Last Completion = 100

processor processing
Simulator statistics

Estimate mean and variance
Confidence Level = 0.95
Relative Confidence Interval = 0.10
Initial Transient = 1000
Batch Size = 1000
First Completion = 0
Last Completion = 100

Table 1.9: Activity variable definitions for the faulty microprocessor model.

� the reactivation function is such that the timed acitivities are reactivated often enough so

that the activity time distribution only depends on the current marking (see below).

2. Deterministic and exponentially distributed activities

Models where:

� all timed activities are either exponentially distributed or deterministic,

� at most 1 deterministic activity is enabled at the same time,

� the time of the deterministic activities may not depend on the marking of the SAN,

� for the activation and reactivation predicates for the exponential activities the same re-

striction as above holds.

Note that there are no restrictions on the definition of the instantaneous activities, as long as the re-

sulting SAN is stabilizing and well-specified (see Section 1.1.2).

For the above model types, the condition on the reactivation function of the exponential activ-

ities is necessary to preserve the Markov property2 , because there are SANs with all exponentially

distributed activities which are not Markov. This important fact follows from the execution rules for

2The Markov property says, very informally, that the future behavior of the stochastic process only depends on the past
through its present state, not through past states of the stochastic process.
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SANs. In particular, recall that activity times are determined at activation time and may be marking

dependent. Therefore, if a new marking is reached before completion of an exponential activity, it

may be that the activity time depends on a past marking for its rate, and, hence, the model is not

Markov. A sufficient condition for the reactivation function to assure the Markov property is that

both the activation and reactivation predicate are equal to 1 (true). In that case, if an activity is acti-

vated, and if the activity remains enabled when a new marking is reached prior to completion of the

activity, the activity will always be reactivated (i.e., at the moment the new marking is reached the

activity is aborted and directly activated again).

When the state space and transition matrix is generated in UltraSAN, it is assumed that the reac-

tivation function is specified such that the Markov property holds. It is thus not necessary to specify

the activation and reactivation predicate yourself. Realize that if the specified model belongs to one

of the first two model classes above, this default procedure will not change the stochastic properties

of your model. On the other hand, if a simulation executable is built for the model, it is not assumed

that the reactivation function guarantees the Markov property (since such non-Markov models can

be solved). Therefore, take care that in simulation the activation and reactivation predicates are de-

fined correctly for the activities. For all models, defining the activation and reactivation predicate

both to be equal to 1 for all marking dependent activities guarantees the equality of the simulation

executable with the explicitly generated model.

Finally, a note is in order about the notion of state when generating the state space of the stochas-

tic process. In UltraSAN, a marking together with the impulse reward associated to the activity which

completion brings the SAN to that marking determine the state. So, two timed activities which result

in the same marking upon completion give rise to two different states if different impulse rewards

are state space size increases in this case. It is important to realize this when analyzing the size of

the generated state space in UltraSAN. For a more detailed discussion about state space generation

consult [5].
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Chapter 2

Getting Started

After UltraSAN has been installed and the environment has been set up according the directions in

Appendix A, the user should be able to build and solve models. The purpose of this chapter is to

quickly introduce the user to modeling using UltraSAN. By following this tutorial, the user will:

� Construct a model of a hypothetical system using stochastic activity networks (SANs).

� Become exposed to different components of the model-building process used in UltraSAN.

� Be able to specify and solve/simulate for different reliability and performance measures of a

model.

2.1 Description of the Model

In this example, the system that will be modeled is the faulty microprocessor discussed in Chapter

1. Briefly, recall that the faulty microprocessor is a multiprocessor computer in which jobs can be

processed either sequentially or in parallel. However, in this system, parallel processing can yield

incorrect results. The arrival of tasks to the system is a Poisson process with rate �. Arriving jobs

are placed in a fixed size queue; when the queue is full, additional jobs are rejected. The time for

processors to remove tasks from the queue is exponentially distributed with a mean of 1=
; the time

to process a job is exponential with a mean value of 1=�. Moreover, a processor always attempts to

process two tasks from the queue, but may encounter errors in processing more than one job. If a

processor processes a single task, the task is always processed correctly. However, for two jobs, the

probability that one job was processed incorrectly and must be reprocessed is p1; the probability that

both jobs were incorrectly processed is p2.

At a high level, processors take jobs from a common buffer, process the jobs, then take addi-

tional jobs when they are available. In UltraSAN terminology, the buffer and processors are modeled

as subnets. By logically joining the buffer and processor subnets through a common queue, a com-

posed model is created. After a composed model of the faulty processor has been created, reward

2-1
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variables are defined to determine measures of performance. After analytically solving the model,

graphs and/or tables of the results are created to analyze the performance of the system versus dif-

ferent parameters of interest.

To accomplish these steps, this tutorial will describe the editors and commands used in UltraSAN

to create a model. First, the SAN editor (sanedit) is used to create the buffer and processor subnets.

Next, the subnets are logically linked using the composed model editor (compedit). After the com-

posed model has been created, a reward variable to determine the system utilization is defined using

the performability variables editor (varedit). UltraSAN also provides the ability to specify multiple

values for model parameters specified in sanedit and compedit. The study editor (stdedit) is used to

assign values to model parameters for later solution of the model.

To analytically solve the model, the underlying stochastic process space is generated from the

SAN representation using reduced base Model construction (RBMC). Using the generated state

space, the iterative steady state solver (iss) is used to solve for the steady state utilization. For com-

parison, the model is also simulated using the steady state simulator (SSim). Finally, a 3-D graph is

created using the report generator (repgen) to understand the effect of the number of processors and

job arrival rate on utilization.

2.2 Starting UltraSAN

Start UltraSAN by typing usan on the command line and pressing <RETURN>.

The graphical interface, or Control Panel, appears as shown in Figure 2.1.

The first step in creating a model in UltraSAN, is to create a project . Roughly speaking, projects are

used to hold all the components needed to specify a model in UltraSAN. These components will be

discussed in the following sections of the chapter as the model is constructed.

To create a project, choose from the Control Panel menu. When the Create Projectwin-
dow appears as shown in Figure 2.2, type faulty proc and click on the OK button.

2.3 Creating a Subnet

Once the project has been created, individual subnets can be created within the project. The first

subnet that will be created is the buffer subnet. Recall that the buffer subnet models the Poisson

arrival of tasks to the multiprocessor. Once a task arrives, it is placed in a queue with a size limit.

If the queue is full, arriving jobs are discarded. One way to model this behavior is to create a timed

activity with an exponential distribution of time between completions. Upon each completion, the

activity places a token in the place to represent a job arrival. To model a limit on the number of jobs,
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Figure 2.1: UltraSAN Control Panel.

Figure 2.2: Create project window.
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Figure 2.3: Create subnet window.

an input gate is connected from the place to the timed activity. The gate compares the number of

tokens in the place with a predefined limit. If the number of tokens is less than the limit, the input

gate allows the activity to complete normally. However, if the number of tokens equals the limit, the

input gate does not allow the timed activity to complete until one or more tokens are removed from

the place. Once this happens, the input gate again allows the timed activity to complete.

To create the subnet buffer, choose Subnet->Create from the Control Panel menu. Note
that the project name faulty proc already appears in the Create Subnet Window. When
the Create Subnet window appears as shown in Figure 2.3, click in the window for the Subnet
Name: and type buffer. Click on the OK button.

After the subnet has been created, the functionality can be defined using the Edit->Subnet option.

To edit the newly created subnet buffer, choose Edit->Subnet. Note that the project name
faulty proc and the subnet name buffer appear, since they have been selected as the default
project and subnet. Click on the OK button to continue. When the sanedit drawing editor
appears, a window with the message “No subnet found, starting new model.” appears. This
is correct since a new subnet was created. Click on the OK button to continue.

2.3.1 Creating the buffer Subnet

Now the subnet buffer can be created. Figure 2.4 shows a possible layout for the objects that will be

created in this section.

To begin, click on the label Place. Click in the drawing area to put the place into the subnet.
To place an object. hold down the left mouse button, move the object to the desired location,
and release the button. At this point, a window asking for the place name will appear. Type
queue. Then click on the OK button. To create the activity arrival, first click on the Timed
Activity label and then click on the drawing area to place the activity. A window asking
for the activity name and number of case probabilities will appear. Since there are no case
probabilities, only type arrival. Click on the OK button to continue.

For more information about the definition of activities, see the background theory of SANs in Chapter

1.
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Figure 2.4: buffer subnet.

The final component of the subnet that must be created is the input gate capacity. This gate controls

the number of jobs in the buffer.

Click on the Input Gate label and then in the drawing area to create the input gate. Type
capacity in the window that appears and click on the OK button.

Once all the components have been placed in the editor, each component can be defined. To do this,

click on the Define label. Then click on each component. Depending on the SAN component, dif-

ferent windows will appear. Note that gates and activities will have a hatched outline, indicating that

they must be defined before the SAN is complete.

Defining the Input Gate capacity

The purpose of the input gate capacity is to control the number of jobs queued in the processor by

disabling arrivals when a certain number of jobs are in the queue. To do this, the gate should allow

the timed activity arrival to be enabled when the number of tokens or jobs in the place queue is less

than a certain number.

Click on the input gate capacity.
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Figure 2.5: Input gate editor - capacity.
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After clicking on capacity, the Input Gate Editor window appears as shown in Figure 2.5. The

Input Gate Editor window is used to define the input predicate and input function. The input

predicate is a C expression that describes under what conditions the activity connected to the input

gate will be allowed to complete. This is done using a true-false condition, or predicate. Recall from

the above description of the model, capacity should allow arrival to complete only when the number

of tokens in queue is less than a certain value. The statement that describes this is MARK(queue)

< GLOBAL S(size), where MARK is a C function that returns the number of tokens in a place.

GLOBAL S refers to a global variable. Global variables allow for parameters to be more easily spec-

ified in a later step of the model-building process. For a more complete description of the MARK

function, see Section 3.9.2.

To define capacity, move the mouse cursor to the Input Predicate window and type
MARK(queue) < GLOBAL S(size).

The input function is a C function that specifies how the gate changes the marking of connected places

when the associated activity completes. In this case, the capacity should only enable or disable ar-

rival and not change the marking of any connected places. In C, a semicolon is used to indicate an

identity statement.

Move the mouse cursor to the Input Function section and type a semicolon.

With both the input predicate and function for capacity defined, the definition of capacity is complete.

To save the definition, click on the Accept button.

Defining the Timed Activity arrival

To define the timed activity arrival, click on the label Define and then on the activity.

When the Timed Activity Editor appears as shown in Figure 2.6, the top of the window con-

tains the time distributions that can be chosen for a timed activity. The exponential activity is chosen

by default. To define other distributions, click on the circle next to the type desired. Depending on

the type and number of parameters needed to define the particular activity time distribution, the pa-

rameter window changes. In this example, the delay is exponentially distributed since a Poisson job

arrival process is modeled.

In the rate window, type GLOBAL S(arr rate).

The global variable represents the rate of arrival of tasks to the common queue. Since the activa-

tion and reactivation functions will not be used, click on the Accept button to complete the activity

definition. For more detailed information about the definition of activities, refer to Section 3.9.2.
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Figure 2.6: Timed activity editor - arrival.
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2.3.2 Connecting the Subnet Components

Now that all the places, gates, and activities in the subnet have been defined, they must be connected

together to complete the subnet.

To connect all the defined components, click on the curved line label on the left side of the
sanedit drawing window.

Since job arrivals enter the queue, an arc is used to connect the timed activity arrival to the place

queue.

To connect arrival to queue, place the mouse cursor on the timed activity, click the left mouse
button, and drag the arc to the place queue. Once the mouse cursor is on queue, press the
right mouse button.

If sanedit recognizes the arc, a line from the activity to the place will appear. If the arc is not correct,

a window with the message “Can’t identify the object this arc is coming from.” or “Can’t identify

the object you’re trying to connect to.” will appear, depending on whether the starting object or end

object cannot be identified by sanedit. In either case, click on the OK button, and try to redraw the

arc. Be careful to draw the arc from the timed activity arrival to the place queue. In SANs, a directed

arc from an activity to a place means that upon each completion of the activity, a token will be added

to the place. A directed arc from a place to an activity signals that if one or more tokens are in the

place, the activity will be enabled, and when the activity completes, one token will be removed from

the place. For more discussion regarding the execution of SANs, see the background for SANs in

Chapter 1.

The next arc will be from the place queue to the input gate capacity. As a convention, arcs are drawn

from places to the back side of the input gate.

Place the mouse cursor on the place queue, click the left mouse button, drag the arc to the
input gate capacity and click the right mouse button.

If the arc is correct, a line between the place and gate will appear. As with the arc from queue to

arrival, if the arc is not correct, one of two windows will appear. Click on the OK button and try

again.

In addition, drawing an arc in the incorrect direction from an input gate to a place causes a window

with the error message “Input gates must be connected to activities.” to appear. This enforces the

rule that input gates control the enabling of activities. Click on the OK button to continue.

The final arc to be drawn is from the input gate capacity to the timed activity arrival. Per convention,

arcs from input gates to activities are drawn from the left side of the gate to the left side of the activity.
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Figure 2.7: faulty proc composed model.

Place the mouse cursor on the input gate capacity. Click the left mouse button. Draw the
arc to the left side of the activity arrival. Click the right mouse button.

If the arc is not complete, a window as described above will appear. Click on the OK button and try

again. When the arc is correctly drawn, a line from capacity to arrival will appear.

At this point, all components for the buffer subnet have been defined and connected as shown in

Figure 2.4.

To save the subnet, choose File->Save.

This allows sanedit to compile and write the necessary files.

At this point, the subnet processor can be created. The steps needed to create the processor subnet

will not be described in this tutorial. Refer to the descriptions and definitions in Chapter 1 to create

the subnet in the same way as the buffer subnet was created.
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Figure 2.8: Composed model editor window.

2.4 Creating the Composed Model

Once the buffer and processor subnets have been created, the subnets can be logically combined to

form the faulty microprocessor model. Recall that multiple processors take tasks that arrive into a

common queue. To model this behavior, separate processor subnets and the buffer subnets are con-

nected, or joined in UltraSAN terminology. In UltraSAN, different subnets are joined by identifying

common places through which each subnet interacts. For the buffer and processor subnets, the place

queue is common. Furthermore, since each processor behaves in exactly the same way, it is possi-

ble to replicate the processor subnets to model multiple processors. When subnets are replicated,

each copy behaves independently, with certain places identified as common. Since each processor

processes tasks from a common queue, the place queue is also made common between the replicas.

Finally, the replicated processor is joined with the buffer subnet to create the faulty processor model.

Figure 2.7 show the composed model for the faulty microprocessor.

Choose Edit->Composed Model. As with the SAN editor, a window displaying Project

Name: faulty proc appears as shown in Figure 2.8. Click on the OK button to define the
composed model. Again, a window with the message “No Composed Model found. Starting
new Model.” appears. Click on the OK button to begin specifying the composed model.

2.4.1 Placing the Subnets into the Composed Model

To choose a subnet for the composed model, click on the Subnet label and move the mouse
cursor to the drawing area. Click with the left mouse button and a window displaying the
names of the subnets created previously with the SAN editor will appear. Choose the buffer
subnet by clicking on buffer and then clicking on the Open button. Click in the drawing area
to place the buffer. In the same way, choose and place the processor subnet.

Note that if two or more components are placed too close to each other, a window with the message

“Subnet will overlap at least 1 other object(s). Please allow more space between it and surrounding

objects.” appears. Just click on the OK button and move the component further away from other

components.
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Figure 2.9: Replicate editor.

2.4.2 Replicating the processor Subnet

To create multiple copies of processor as described above, the replicate operation is used.

Click on the Replicate label and click in the drawing area just above the processor box.

Note that although components may be placed anywhere, it will be easier to see the hierarchical na-

ture of the composed model if the components are placed as shown in Figure 2.7.

Draw an arc from the Rep node to the processor node.

Drawing an arc from the processor node to the Rep node will cause a window with the message “Sub-

net nodes cannot have any Outgoing Arcs.” to appear. This is because a composed model is a tree

structure in which the subnet nodes are the leaves. If this occurs, click on the OK button to continue.

To define the number of processor nodes that will be replicated, click on the Define label
and then click on the Rep node.

The Replicate Editor window will appear as shown in Figure 2.9. In this window, the default

number of replicas and a list of all the places in the connected subnets appear. In a logical sense,

the replicate operation creates separate copies of the same subnet which can communicate through

shared places.

Move the mouse cursor to the window for specifying the number of replicas. Highlight the
number 1 and type GLOBAL S(num processors). Then click on the circle next to Vari-
able to indicate that the number of processors in the replica is a global variable as shown in
Figure 2.9.
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This global variable is used to vary the number of processors in the model.

Click on the box next to queue.

This will ensure that the processors will process jobs from a common queue.

Choose Accept to close the Replicate Editor.

2.4.3 Joining the processor and buffer Subnets

Next, the buffer and replicated processor subnets are joined. Recall that the purpose of the subnet

buffer is to model the arrival of jobs to the multiprocessor. When tasks arrive, the subnet buffer places

the tasks into a queue from which the individual processors take tasks for processing. This can be

accomplished by the join operation.

The join operation allows different subnets to communicate by passing tokens through shared places.

In this example, the tasks that are generated by the subnet buffer are accessed by each copy of the

subnet processor subnet.

Click on the Join label and then click in the drawing area. Draw an arc from the Join node
to the subnet buffer. Then draw a separate arc from the Join node to the Rep node.

This joins buffer and the replicated processor submodels.

To define the Join, click on the Define label and click on the Join node.

The Join Editor window appears with the possible places in the buffer node and places made common

in the Rep node that can be made common.

To make the place queue common, click on the boxes next to queue in both subwindows.
Then click on the Add Set button to make the place queue common to the buffer and pro-
cessors as shown in Figure 2.10. To finish defining the composed model, click on the Accept
button to close the Join Editor. To save the composed model, choose File->Save.
Choose File->Quit to exit the Composed Model Editor.

The completed composed model is shown in Figure 2.7.

2.5 Defining Reward Variables

Once the composed model has been defined, measures can be specified to quantify the behavior of

the model. This is done through the definition of reward and activity variables. In particular, an im-

portant performance measure for multiprocessor systems is utilization. Utilization is defined as the

fraction of time the system is doing useful work. This section will illustrate how processor utilization

can be defined using reward variables.
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Figure 2.10: Join editor.

Figure 2.11: Performability variable editor window.
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Figure 2.12: Performability variable editor.

Choose Edit->Performability Variables option from the Control Panel menu. As
with the other editors, a window with the current project name faulty proc appears as
shown in Figure 2.11. Click on the OK button to continue.

The window which appears in Figure 2.12 is divided into two parts. In the top half, rate reward

variables are defined. In the bottom half, activity reward variables are defined. In this example,

only a rate reward variable is defined, but it will allow the user to get a feel of how variables and

solvers/simulators are intertwined. For a description of both variable types, see Chapter 1.
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Figure 2.13: utilization variable definition.
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Figure 2.14: utilization variable simulator statistics.

To create a reward variable for processor utilization, move the mouse cursor to the Reward
Variable Selectorwindow and click on the Add button. Type utilization and click on the
OK button. The name utilization appears in the window as shown in Figure 2.13. To define
the variable, select utilization and click on the Edit Rate button. Since the reward is deter-
mined by the status of the submodel processor, click on Next SubModel. In the Predicate
window, type (MARK(num tasks) > 0) && (MARK(ready)==1). In the Functionwin-
dow, type 1/(GLOBAL S(num processors)).

Whenever any of the replicated processors is processing one or more tasks, the condition in the

Predicatewindow is true. When the predicate is true, a reward of 1/(GLOBAL S(num processors))

is assigned since the measure is for utilization of the entire system.

Click on the Edit Stats button.

The Edit Stats option is used to define parameters related to simulation. Although the theoretical

background of statistical simulation will not be discussed, it is sufficient to note that it is important

for the confidence in the results to set the confidence interval sufficiently high. Unfortunately, more

accurate results require longer simulation times. See Chapter 4 for more details.

The important parameters in the Reward Variable Simulator Statistics window shown in

Figure 2.14 are the Confidence Level and Relative Confidence Interval. These quantities mean that

with 0.95 probability the mean (or variance) produced by the simulator is within a relative confidence

interval of 10% of the true mean (or variance). By default, the confidence level is 95% with a relative

confidence interval width of 10%. This will provide sufficient accuracy to compare the analytical and
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Figure 2.15: Study editor window.

simulation results generated later. Discussion of other parameters used for simulation can be found

in Chapter 4.

To save the simulator statistics, click on the Accept button to return to the Performability
Variable Specification window. Click on the Accept button to save the performabil-
ity variable definitions.

2.6 Creating Studies and Experiments

The next stage of the specification of an UltraSAN model is the creation of studies and experiments.

Recall that several global variables were defined in the subnets and composed model. Through the

study editor (stdedit), single or multiple values can be assigned to each global variable. Often, inter-

est is in the behavior of systems for several parameter values. The features of stdedit make it much

easier to assign these values. In this section, stdedit will be used to assign values to each global vari-

able defined in sanedit and compedit.

To access the study editor, choose Edit->Studies. A window containing the project name
faulty proc appears as shown in Figure 2.15. Click on the OK button to continue. Initially,
the stdedit window is blank. To add a new study, click on the Add button. Move the mouse
cursor to the window and type vary arr and processors and click on the OK button.
Now, the window contains the newly created study as shown in Figure 2.16.

Now that a new study with the name faulty proc has been created, different values for the global

variables can be specified.

Click on the faulty proc label.

Values for global variables can be defined using a range or set. A range allows each global variable

to be defined as either a fixed value or a number of values specified by a starting value and ending

value separated by additive or multiplicative increments. A set allows vectors of fixed values for each

global variable. In this way, a “matrix” of values for the global variables can be created using either

ranges or sets.
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Figure 2.16: Study editor selector - vary arr and processors.

In this example, the global variables are defined using the range option.

Click on the Range button. The first window that appears contains the global variable ac-
cess rate. To assign a value for the variable, click on the Edit button. An edit window for
the global variable access rate appears. Click on the circle next to the left of the Fixed

Value label. Then click in the window next to the Fixed Value label. Type 20 and click
the Accept button.

The definition for access rate is shown in Figure 2.17.

In this example, arr rate will be varied from 5 to 30 in steps of 5. The range option allows a starting

value and end value to be specified, separated by additive or multiplicative increments. For more

information on how to specify value for global variables, see Section 3.13.

To edit the next global variable, arr rate, click on the Next button. To vary arr rate from
5 to 30 using a range, click on the circle next to the Range Value label. Then click in the
window next to Initial and type 5. Next, click in the Final Window and type 30. To get
a spacing of 5 between each value, click on the circle next to the Additive label and type
5 in the Increment window. Click on the Accept button to finish defining the range.

The definition for arr rate appears in Figure 2.18.

In a similar way, define io rate as fixed value equal to 10, num reps as a fixed value equal to
3, ok prob as a fixed value equal to 0.81, one error prob as a fixed value equal to 0.18, and
proc rate as a fixed value equal to 20. num processors is varied from 1 to 6, in steps of 1.
This can be done is a similar way as arr rate was defined. Choose 1 as the initial value, 6
as the final value, and 1 as the additive increment.

Once all of the global variables have been defined, click on the Next or Previous button(s) to check

that each variable has been defined with the correct value(s).
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Figure 2.17: Range editor - access rate variable.

Figure 2.18: Range editor - arr rate variable.
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Figure 2.19: Select studies window.

To save the variable values and return to the Global Variable Assignment window,
click on the Accept button.

After all the global variables have been defined, UltraSAN creates separate experiments for each

value of the global variable defined. Since the ranges for arr rate and num processors each contain

6 values, 36 experiments for the study vary arr and processors are created.

To construct the experiments, click on the Accept button.

Once study and experiment construction has been completed, the study editor window disappears.

2.7 Selecting Studies and Experiments for Solution

After the studies and experiments have been created, results can be obtained by either analytical solu-

tion or simulation. As an illustration, the model will be solved analytically and simulated in steady

state to determine utilization the faulty microprocessor model. First, the particular study(ies) and

experiment(s) must be selected.

To select the var arr and processors study just created, choose Study->Select.

A window containing the study for the faulty proc project appears as shown in Figure 2.19.

Click on the label faulty proc and click on the OK button to complete the selection.

Recall that experiments are generated for each combination of the values of the global variables.

To choose which experiments will be solved and/or simulated, choose
Experiment->Select from the Control Panel.
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Figure 2.20: Select experiments window.

A window containing all the experiments appears as shown in Figure 2.20.

Experiments can be selected individually or all can be selected by clicking on the Select

All button. To select an experiment, click on the label of the particular experiment. Once
an experiment is selected, it is highlighted. To unselect an experiment, click on it again to
unhighlight it. After all experiments have been selected, click on the OK button.

2.8 Solving the Model

Once the study and experiments have been selected, the model can either be solved analytically

solved1 or simulated. Since all timed activities are exponential in the faulty processor model, it is

possible to generate the underlying Markov process, then solve for the steady-state system utiliza-

tion. In addition, it is possible to simulate the model in steady state. The first step in obtaining an

analytical solution is to use reduced base model construction (RBMC).

2.8.1 Analytically Solving the Model

RBMC generates the Markov process from the SAN representation.

To select RBMC, choose Solve->Reduced Base Model Generator. A window con-
taining the project name faulty proc and other options appears as shown in Figure 2.21.
Click on the OK button to continue.

The state space corresponding to each experiment is generated. Once the state space for all 36 exper-

iments has been generated, the model can be solved for the utilization variable specified in varedit.

1Although all SAN models can be simulated, analytical solutions can be obtained for certain classes of models. Such
restrictions are discussed in the chapter on analytical solvers in Chapter 4.
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Figure 2.21: Reduced based model generator.

Depending on the time scale of interest for the reward variables, different solution methods can be

used. For more detailed information about the applicability of different solvers, see Chapter 4. In

this example, iss will be used to solve for the steady-state utilization of the faulty microprocessor.

To run iss, choose Solve->Iterative Steady State Solver.

A window containing the project name and options for iss appears as shown in Figure 2.22. For a

complete description of the possible options for iss, see Chapter 4.

Click on the OK button to continue.

The results generated by iss appear in the Control Panel window and are also written to an output

file. Refer to Chapter 4 for more details.

2.8.2 Simulating the Model

As mentioned above, UltraSAN also contains tools to simulate SANs. Just as for the analytical

solvers, there are several types of simulators. See Chapter 4 for details about the different simula-

tors available in UltraSAN. The steady-state simulator (SSim) will be used to compare the utilization

values obtained analytically using (iss).

Choose Solve -> Steady State Simulator.

As with iss, a window containing the options for the simulator appears as shown in Figure 2.23. Refer

to Chapter 4 for a description of the options for SSim.

Click on the OK button to continue.
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Figure 2.22: Iterative steady state solver (iss).

Figure 2.23: Steady state simulator (SSim).
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Figure 2.24: Report generator window.

Since there are multiple experiments, a window with the message “Multiple experiments on one ma-

chine. Run in foreground?” appears. In general, the solvers and simulators in UltraSAN allow results

to be generated either in the foreground or as a background UNIX process.

Click on the OK button to run the simulator in the foreground.

Results will appear in the Control Panel window.

2.9 Report Generator

Another useful feature in UltraSAN is the ability to view the results after a model has been solved

analytically or simulated. The report generator allows the user to create graphs or tables of data

based on results generated from the solvers or simulators. In the remainder of this tutorial, the re-

port generator will be used to create a three-dimensional graph of the number of processors and

job arrival rate versus utilization. The plot will contain results from all 36 experiments in the study

vary arr and processors.

Choose General->Report Generator from the control panel menu. The report generator
window containing the project name faulty proc appears. Click on the OK button to continue.

At this point, a window containing different options to create tables and graphs using results gener-

ated from the solvers/simulators appears as shown in Figure 2.24.
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Figure 2.25: Graph window.

2.9.1 Creating the Graph

To create a 3-D graph of the number of processors (num processors) and arrival rate
(arr rate) versus processor utilization (utilization), click on the label 3-D graph under the
Report Style heading.

To display 2-D graphs, UltraSAN provides an interface to splot and gnuplot; for 3-D graphs, gnuplot

is used. In addition, either ASCII (text) or LaTeX tables of results can be generated. For a detailed

description of the options used to create graphs and tables, refer to Chapter 5.

Click on the Edit button to begin specifying the 3-D graph.

After clicking on the Edit button, the Graph window appears shown in Figure 2.25. The Graph

window allows the user to specify the graph axes and variables.

Defining the Graph Axes

For the 3-D graph, the variables corresponding to the axes must be defined. The x and y axes will

represent the global variables num processors and arr rate, while the z-axis will represent the per-

formance variable utilization.

To define the x-axis, choose Axis->x-Axis from the menu. By default, Global Variable

is selected. Click on the Accept button to continue. Now, a window containing all the global
variables defined for the faulty proc project appears as shown in Figure 2.26. To choose the
number of processors, select num processors. Click on the OK button to continue.

To define the y-axis, choose Axis->y-Axis from the menu. By default, Global Variable

is selected. Click on the Accept button to continue. As was done for num processors, select
arr rate and click on the OK button to continue.
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Figure 2.26: Global variables list for x axis.

Figure 2.27: Performance variables list for z axis.
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Figure 2.28: Data source selector window.

To define the z-axis, similarly choose Axis->z-Axis from the menu, click on the
Performance Variable label as shown in Figure 2.27, and click on the Accept button.
As with the global variables, a window containing all the reward variables defined in the
Performability Editor appears. Select utilization and click on the OK button to continue.

At this point, the graph contains the definition of both the x, y, and z axes.

Choosing the Solvers, Studies and Experiments

Recall that UltraSAN contains different solvers and simulators. As a result, it is possible to create

graphs or tables results using results generated by different solvers and simulators. As an illustration,

the results generated using iss will be used.

To select the results generated by iss, choose Default Source->Iterative Steady

State Solver (iss) from the Graph window. When the window appears as shown in
Figure 2.28, click on the Add button.

The report generator also supports selection of individual studies and experiments to be included in

a graph. The study vary arr and processors will be used.

Select the study vary arr and processors as shown in Figure 2.29. To choose different
experiments for the graph, click on the button Select Exp.

Different experiments can be included in a graph by clicking on each individual experiment label as

shown in Figure 2.30. To observe utilization values for all arrival rates and number of processors,

click on the button Select All or click on all the labels individually.
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Figure 2.29: Report generator study selector window.

Figure 2.30: Report generator experiment selector window.
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Figure 2.31: Report generator graph: number of processors and job arrival rate versus utilization

After all the experiments have been selected, click on the Accept button to continue. Click
on the Accept button in the Study Selector and Data Source Selector windows.

Notice that the Data Source Selector window contains the thirty-six experiments selected.

Click on the Accept button in the Graph window to continue.

2.9.2 Viewing the Graph

Now all the components of the graph have been defined, the graph can be viewed.

To view the graph, click on the View button.

Before the graph is displayed, a window asking for the gnuplot filename appears. This file will con-

tain the command file that can be used to view the graph using gnuplot directly. By clicking on OK,

default file view.gpd is created and stored in the int subdirectory of the model project directory.

For more information, about saving and loading graphs with the report generator, see Chapter 5.

Click on the OK button to continue.

A graph of utilization versus the number of processors and job arrival rate is shown in Figure 2.31.

Clearly, utilization decreases when the number of processors increases or the arrival rate of jobs de-

creases.
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2.10 Where to Go Next

Although this chapter has illustrated how to build and solve a simple model, it is clear UltraSAN pro-

vides much more modeling power and flexibility than is possible to demonstrate in a short tutorial.

It is important to note that for successful use of the tool, the theoretical background behind SANs,

composed models and reward variables should be well understood. We suggest the reader who is less

familiar with this to read Chapter 1 first. The user who is sufficiently comfortable with SAN model-

ing, is encouraged to start using UltraSAN for their own modeling studies. When using UltraSAN,

chapters 3 to 6 can be consulted to get information about specific UltraSAN commands and options

in the tool. In particular, Chapter 3 provides a reference guide about all UltraSAN options.
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Chapter 3

User Interface

This chapter is a reference guide containing a detailed discussion of the various options provided

by the Control Panel (CP). The CP is a unified graphical interface used for model specification and

solution. It is an X-window-system-based program which provides the user with pull-down menus

providing access to all editors and solvers in the package, as well as a set of utilities that simplify

common operations (such as documenting a project, copying projects, and many more features de-

scribed in the following subsections), and help users organize their work.

Starting UltraSAN To invoke the CP, type usan followed by a carriage return. This causes a win-

dow as shown in Figure 3.1 to appear on the user’s terminal. The CP is driven by the use of a mouse

and pop-up menus. As seen from Figure 3.1, the top portion of the window contains 8 menu items

namely: (1) General, (2) Project, (3) Subnet, (4) Study, (5) Experiment, (6) Machine, (7) Edit and

(8) Solve.

Each item has a pull-down menu that provides a variety of options. The CP menus along with

their pull-down options are shown in Figure 3.2. These menu items and their options help to specify

and solve the model on hand. The CP also contains a central portion titled “Messages” (also referred

to as the communication window), which it uses to communicate with the user (i.e., print appropriate

status and/or error messages). The full path for the project directory (which is set in the user’s .cshrc

file, see Appendix A) is printed at the bottom left hand corner. Since the user has not yet selected a

particular project in their projects directory, the “Project,” “Subnet” and “Study” portions of the CP

(at the very bottom) appear blank.

Navigating through the menu items To access the menus, position the cursor (which appears as

an arrow) on the desired menu item. Press the left mouse button on the menu item to produce a list of

options and hold it down (which highlights the particular option chosen) to walk through the menu

options. Click (release the left mouse button) on a particular option to select it.

3-1
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Figure 3.1: Control panel as it appears when first invoked.
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Figure 3.2: Control panel menu items and their pull-down options.
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Figure 3.3: Bug report editor display.

Control panel description The notation Menu Item->Option is used to denote an option within

a specific menu item. Thus the option “Create” under menu item “Project” is denoted byProject->

Create.

3.1 General Menu

The General menu contains four options as shown in Figure 3.2. The options and their respec-

tive functions are listed below.

� General->Bug Report brings up a form as in Figure 3.3 for reporting bugs. Enter the information
and click on Send to automatically forward it to usan-problem-report@crhc.uiuc.edu. A copy
of this form is also sent to the user filling out the bug information. Clicking on Cancel will not mail
the form, and the CP responds by printing the message Operation canceled on its screen.

� General->Transfer Project transfers a project from an Version 1 of UltraSAN to the current ver-
sion. The pop-up window displays a list of projects in the directory chosen. Highlight the desired
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Figure 3.4: Report generator display.

project and click on Open to transfer it. The old version will be placed under the name project old.
Clicking on Open without selecting a project or on Cancel exits this option and the CP prints the mes-
sage No name was specified on its communication window. The transfer operation is irreversible and
is performed in only one direction, namely a Version 1 UltraSAN project to the current version and not
vice-versa. Note that no conversion is needed between Version 2 and 3.

� General->Display File displays all text, postscript and splot files associated with a particular study
for a given project. A pop-up window appears asking for the project and study names. Enter the desired
names and select the type of file (postscript, splot or text) that is to be displayed. The CP pops up another
window enlisting all files of that type. Select the particular file to be viewed. In the case of a postscript
file, the CP brings up a ghostview image of the selected file. (Ghostview, as specified in local.def

should be included in the user’s path to view postscript files.) In case an invalid project and/or an invalid
study name is entered, the CP prints the message Directory does not exist or cannot access directory
on its communication window and cancels the display operation.

� General->Report Generator pops up a window as shown in Figure 3.4. This option is extremely
helpful while documenting a project and preparing graphs. See Chapter 5 for a detailed discussion of
the features within this option.

3.2 Project Menu

The Projectmenu is used to create, select, delete, copy, archive, unarchive, clean and document

a project. Each of these operations is listed as an option as shown in Figure 3.2, and is performed by

selecting the corresponding option. These options and their functions are listed below.

� Project->Create creates new UltraSAN projects. A pop-up window appears prompting the user for
a name. Project names must begin with a letter, and every other character must be a letter, number or
underscore. Also, no C keywords are allowed. Click on OK after entering a name to create the new
project. Click on Cancel to abort it, in which case the CP displays the message Empty project name
or operation canceled on its communication window. Once a project is created using this option, it
appears as the default project for subsequent commands.
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� Project->Select selects a particular project from a list of projects in the current project directory
and uses it as the default project for every other command. A pop-up window listing all projects in the
current directory appears on the user’s terminal. Highlight the desired project and click on Open to open
it and use it as the default project for further actions (such as editing subnets, performing a compedit,
or a varedit or selecting a study to conduct multiple runs). Click on Cancel to abort this operation, in
which case the message No name was specified appears on the communication window.

� Project->Copycopies one project to another. All subdirectories and files except the results directories
in the source project are copied to the destination project. To copy the results directories, check the box
to duplicate results directories in the Copy->Project pop-up window described below.

If Project->Select was not exercised earlier, the entry corresponding to the project name appears
blank. Otherwise it will carry the name of the selected project. Depending on the project names entered
the following windows appear:

– if the project to be copied from exists and the project to be copied into does not exist, click on
Yes to proceed or No or Cancel to abort

– if the project to be copied from exists and the project to be copied into also exists, click on Yes

to proceed by overwriting the existing project or either Cancel or No to abort

– if the project to be copied from does not exist, click on OK to abort

� Project->Delete deletes an entire project. A pop-up window appears displaying all projects in the
current directory. Highlight the project to be deleted and click onOpen to delete the project. This causes
another confirmation window to appear on the terminal. Click on Yes to continue with the option or No
or Cancel to abort it. (Clicking on Openwithout highlighting any project displays the message Project
does not exist and aborts the option.)

� Project->Archive is useful for taring, compressing and storing UltraSAN projects. Archiving the
project involves creating a tar file for the project, compressing it and placing the resulting compressed
tar file called proj name.tar.Z within $USAN PROJECT/archived projects, all of which is per-
formed by the CP. A pop-up window displaying all projects in the current directory appears. Highlight
the desired project and click on Open to archive it, or Cancel to abort the archive option. Upon suc-
cessful completion of the archive operation, the CP asks if the original project is to be deleted. Click on
the desired selector to complete the archive option. As with all menu options, clicking on Openwithout
highlighting a project aborts the option with an appropriate message appearing on the communication
window.

Note: If the project to be archived was archived earlier, the CP asks the user if it should overwrite the
existing archived project. Click on No to abort repeated archiving of the project.

� Project->Unarchive performs the reverse of the archive option. It uncompresses, untars and re-
trieves the project that was previously archived. A pop-up window appears listing all previously
archived projects. Highlight the desired project and click on OK to unarchive the project. Upon comple-
tion the CP asks the user if they wish to delete the archived project. Click on No to retain the archived
project or Yes to remove it.

Note: If no projects have been archived, selecting this option brings up a window with the current di-
rectory listed on the top and an empty list below. Click on Quit to exit this option. Clicking on OK will
produce no action and the window will not disappear. Hence click on Quit to get back to using the CP
for further actions.

� Project->Clean removes all files from a project that can be generated later by resaving and compiling
the project. The files removed are (see Appendix B for a discussion of the file structure of a project):
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1. All *.c, *.h, *.ssim, *.tsim and *.sub files in the project name/int directory

2. All files in the project name/subnets/subnet name/ARCHdirectory. This is done for all sub-
net names and all architectures. (The architectures currently included are: HP800, MIPSEL,
RS6000 and SUN4.)

3. All files under project name/studies/study name/exp name/bin/ARCH for:

– all architectures

– all studies defined for the current project

– all the experiments in each of the above study directory

4. The CP provides the user the option of either retaining or removing (i) the reduced base model,
(ii) the report generator files, (iii) the IS governor files, and (iv) the results files. Answering yes
to each of these options produces the following:

– Removal of the reduced base model involves removing the *.rbm, *.det, *.parm and
*.var files in the project name/studies/study name/exp name/int directory.

– Removal of the IS Governor files involves removing the is/is.h file, all files in is/lib/

ARCH/*, and all files in is/states/states subdir/* for every subdirectory in is/

states/states subdir and for every subdirectory in is/states.

– Removal of the report generator files involves removing the following files from theproject
name/int directory:

(a) *.asc : which are all the ASCII files for tables1

(b) *.aux, *.dvi, *.log: which are the intermediate files for compiling latex

(c) *.gpc : which are all the gnuplot command files

(d) *.gpd : which are all the gnuplot data files

(e) *.gps : which are all the gnuplot postscript files

(f) *.rep : which are all the output files of the report generator

(g) *.sp : which are all the splot files

(h) *.tex : which are all the tex files for LATEX
Note: Executing Project->Clean with this option (i.e., Remove Report Genera-
tor Files) turned on will remove all files generated from Project->Document and
Subnet->Document, because they generate files with the same extensions (namely,
*.ps,*.tex,*.aux, and *.log).

– Removal of the results files involves deleting all files in the results directory.

A pop-up window listing all projects in the current directory appears on selecting this option. Highlight
the project to be cleaned and click on Open to proceed or Cancel to abort. If Open is selected, the
CP pops up another communication window and asks if the reduced base model, the Report Generator
Files, the IS governor files, and/or the result files are to be removed. Make the desired selections and
click on OK to continue or Cancel to abort the option.

Note: If Open is selected without highlighting a project, the operation is aborted and the CP displays
the message Project does not exist. Furthermore, deleting a reduced base model implies no solver can
be run on its associated model. It should therefore be retained if further analytic solutions are required.
Finally, it is advisable to clean projects that are not in use and remove their reduced base models, as
this frees up disk space.

1tables is a module in UltraSAN that is used for producing *.tex files which are used with LATEX while documenting a
project.
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� Project->Document documents a selected project by producing a LATEX file of the project in the int
directory. It performs this by invoking a module called tables. The resulting document contains details
of the composed model and of the various subnets that form the model, a list of all reward variables,
set and range definitions for the global variables defined, and simulation statistics (if conducting a sim-
ulation study). A pop-up window displaying all projects in the current directory appears on selecting
this option. Highlight the particular project to be documented and click on Open to proceed with doc-
umentation. This brings up another window with more options, namely,

– tiny format, with the default being small

– generate separate LATEX files for each SAN, with the default being one file for all SANs

– generate Postscript Directly

– generate Postscript Directly, with the default suppressing postscript generation directly

Make the desired selections from above. If Document->Separate LaTeX files for each SAN

is selected, the project level information is placed in files titled project projdoc.tex and subnet
level information in project subnet.tex. If not, all information is gathered into one file titled
project.tex. When the composed model figure is copied, the Rep and Join nodes are given numeric
labels for indexing. All the above files are placed in the int directory.

Note: For this option to work, the style files USANpsfig.sty and USANieee.sty must be located in
the appropriate path so that the LATEX file can be generated.

3.3 Subnet Menu

The Subnet menu is used to create, select, copy, delete and document a subnet. The options and

functions are as listed below.

� Subnet->Createcreates a SAN. A pop-up window bearing two entry spaces, one for Project name

and another for Subnet name appears. The naming convention for subnets is similar to that for
projects, i.e., they must begin with a letter and every other character must be a letter, number or un-
derscore. Also, no C keywords may be used. Fill in the desired names and click on OK to create the
new subnet. The CP responds by printing the message Subnet “new subnet” is successfully created on
successful creation. Click on Cancel to abort this operation.

� Subnet->Select selects a particular subnet while editing or viewing a SAN. A pop-up window dis-
playing all previously created subnets appears. Highlight the desired subnet and click on Open to select
it or Cancel to abort the option. In the former case, the CP prints the message Subnet “subnet name”
is selected and in the latter Operation canceled.

� Subnet->Copy copies a subnet from one project to another. A pop-up window bearing four entry
spaces, one each for the project and subnet names to be copied from and to appears. (Recall: Some
of these spaces might already have the default names entered when the pop-up window appears.) Fill
in the names and click on Open to proceed, else on Cancel to abort the subnet copy.

Note: The copy operation will be aborted causing an error message to appear on the communication
window under the following circumstances:

– if Select->Project is not exercised prior to Subnet->Copy and an invalid project name is
entered (i.e., an empty string, or the named project does not exist). The error message Source
project does not exist appears on the communication window.



3.4. STUDY MENU 3-9

– if Select->Subnet is not exercised and an invalid subnet name is entered (i.e., the specified
subnet does not exist). The error message Specified subnet does not exist appears on the commu-
nication window.

– if the source project and subnet exist, but the project to be copied into does not. The error message
Destination project does not exist appears on the communication window.

– if all the above are valid but an invalid subnet name is entered. (Recall: A valid name must begin
with a letter, and every other character must be a letter, number or underscore, and should not
include any C keywords.) The error message Invalid string for a subnet name appears on the CP.

� Subnet->Delete deletes a particular subnet within a project. Fill in the project and subnet name on
the pop-up window that appears with this option and click on OK to proceed, or Cancel to abort. A
confirmation window appears in the former case. Click on the appropriate selector. On successful com-
pletion, the message Subnet “subnet being deleted” is successfully deleted appears on the CP.

Note: The delete operation is aborted and an appropriate error message appears on the CP if either an
invalid project name and/or an invalid subnet name is entered.

� Subnet->Documentdocuments a subnet by producing a LATEX file of the selected subnet. The resulting
file contains all subnet level information and is placed in int/project/subnet.tex. The pop-up
window asks for a project and subnet name. Enter the names and click on OK to continue or Cancel to
abort.

3.4 Study Menu

The Study menu contains two options, Study->Select and Study->Clean, which are ex-

plained below.

� Study->Select selects a particular study within a given project and makes it the default study for
subsequent operations. A pop-up window listing all studies in the specified project appears. Highlight
the desired study and click on Open to make it the default study, or Cancel to abort the option.

� Study->Clean removes all executable files associated with a study. The files removed are:

1. all files under project name/studies/study name/exp name/bin/ARCH for all the archi-
tectures (HP800, MIPSEL, RS6000 and SUN4)

2. item 1 for all experiments in the selected study

3. an optional remove of (i) the reduced base model and (ii) the results files. Option (i) removes the
*.rbm,*.parm,*.det, and *.var files in the project name/studies/study name/exp

name/int directory, while option (ii) removes all result files in the results directory.

A pop-up window listing all studies in the selected project appears. Highlight the study to be cleaned
and click on Open to proceed or Cancel to abort. In the former case, the CP provides the option of
retaining the reduced base model. Make the desired selection and click on OK to proceed. Successful
completion is indicated by displaying a corresponding message on the CP.

3.5 Experiment Menu

The Experimentmenu is used to perform operations on experiments within a selected study and

is invoked after selecting a project and study. The options and their functions are:
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Figure 3.5: Menu option Machine->edit as it appears on the terminal.

� Experiment->Select selects some or all experiments from a list of experiments defined for the se-
lected study. A pop-up menu displaying all previously defined experiments appears. Highlight the de-
sired experiment and click on OK to proceed, or Select All if all need to be executed.

Note: The order in which the experiments are selected determines the order in which they are executed.
For example, in a study consisting of five experiments, selecting exp5 first and then exp1 through exp4
will cause exp5 to be executed first followed by exp1 through exp4. Also, clicking on an experiment
twice in succession (a double click) displays the global parameters of that particular experiment. This
is a useful feature and is used to view the global parameters while choosing experiments that need to
be run in a particular order.

� Experiment->Clean is similar to Study->Clean and Project->Clean , with the difference being
that the executables related only to the particular experiment selected are removed (as opposed to those
belonging to the entire study or project). A pop-up window displaying all previously defined exper-
iments appears. Highlight the experiment to be cleaned and click on Open to proceed further, else
Cancel to abort the operation. In the former case, make the desired selection with respect to the re-
duced base model.

3.6 Machine Menu

The Machinemenu is used to specify and select available machines and allocate them for running

different experiments. The two options within this menu item and their functions are:

� Machine->Edit is used to specify the machines available on each of the following architectures:
HP800, MIPSEL, RS6000 and SUN4. A pop-up window as in Figure 3.5 appears. The architecture in
consideration appears on the top portion of this window. Click on Next Arch or Prev Arch to browse
through available architectures. Use Add and Delete to add and remove machines from a particular
architecture list, respectively. In the example shown in Figure 3.5, bobcat is a SUN4 machine.

� Machine->Select selects the particular machine on which each experiment belonging to a particular
study will be executed. A pop-up window with the experiment number and a list of the available ma-
chines appears. Highlight the particular machine on which this experiment is to be run. Walk through
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all the experiments by clicking on Next and Prev and make the desired selections by highlighting the
machine for each of these experiments. Use unselect to change machine selection for a particular
experiment, and Display to list machine-experiment mappings. Click on Accept to proceed with this
machine-experiment mapping or Abort to cancel it.

3.7 Edit Menu

The Edit menu contains the various editors that are used while specifying a SAN model. They

are:

� the subnet editor, or the SAN editor (sanedit)

� the composed model editor (compedit)

� the performability variable editor (varedit)

� the IS governor editor (isedit)

� the study editor (stdedit)

These editors are implemented as modules within UltraSAN and are discussed in Sections 3.9

through 3.13.

Before discussing these editors separately, the following comment applies to all of them. Due to

the sharing of data files between these modules, the order of execution is very important and should

be done in the order described below. Whenever a change is made to a subnet, compedit, varedit and

stdedit must be executed before attempting to execute any of the solution modules. Similarly, when

a change is made in the composed model, varedit and stdedit have to be executed before using any

of the solution modules. Likewise, after any changes are made to varedit, stdedit has to be executed

before attempting to use any of the solution modules. isedit only needs to be invoked if importance

sampling is used, as described in Chapter 6.

3.8 Solve Menu

The Solve menu contains the reduced base model generator, a list of analytic solvers and sim-

ulators as in Figure 3.2, which are used once the model is fully defined. After the model is defined

completely, the user has the option of solving it analytically or running a simulation. However, be-

fore any of the analytic solvers are executed, the reduced base model must be executed. Details of the

reduced base model generator as well as each of the analytic solvers and the simulators are explained

in Chapter 4.
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Figure 3.6: SAN editor display.

3.9 SAN editor (Edit->Subnet)

Each model is composed of one or more submodels, also referred to as subnets. Subnets

are created and edited with the SAN editor, which is called sanedit. sanedit is started by using

Edit->Subnet from the CP. A pop-up window containing entry spaces for a project and subnet

name appears. These spaces contain default names if Project->Select or Project->Create and

Subnet->Select or Subnet->Create is selected prior to Edit->Subnet. Otherwise they appear

blank, in which case, fill in the desired names. If a new project name is entered, sanedit pops up a

dialogue window with the message Project does not exist. Click on OK to continue, and a window as

shown in Figure 3.6 appears. This figure shows the resulting display when editing subnet processor

of the faulty proc example project.

The names of the selected project and subnet appear on the top left hand corner. The large gridded

area in the center is the drawing area. In the case of a new model, this gridded area is blank. The pop-

up window also has four menu items listed horizontally on the top, and a tool panel containing a host

of options listed vertically on the left. The menu items and tool panel options are used to create/draw

the subnet, and are discussed below.

3.9.1 Menu items within Edit->Subnet (sanedit)

� File Menu
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Figure 3.7: Error in compilation.

The File menu contains three options, namely (a) File->Save, (b) File->Save All and

(c) File->Quit.

File->Save saves all new information related to a subnet, namely text, objects, lines and po-

sitions. In the case of a newly created subnet, it saves the entire subnet, else it compiles any

additions or changes made with respect to a prior save of an existing subnet. Compilation

status is printed on the CP as the model is being saved, i.e., for each activity, place or gate

redefined or added, it prints a compilation status message. Upon successful compilation, the

following is printed on the CP:

– writing .h file

– writing .a file

– writing .san file

– writing .act file

– writing project global variable file

– sanedit successfully saved the model

If a compiler error occurs, a new window as seen in Figure 3.7 appears with the compiler error

messages. In this specific case, place num tasks was mistyped as numtasks.

In Figure 3.7, the window marked pcode is the actual code entered by the user. The win-

dow marked c code is the C code that the editor generates. The 7th line of C code shows
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MARK(NOTaConnectedPLACE). The string NOTaConnectedPLACE is inserted if the place

is not connected to the component or if no such place exists. The error is fixed within this

window by inserting the missing (in this case) in the p code window, followed by clicking

on Accept, after which compilation continues. Compilation is stopped with Abort, in which

case the component becomes undefined. Note that undefined components become dotted in-

stead of having a solid outline, except for a place, which always remains solid. Compiler errors

may extend beyond the screen. The rest of the error is seen by clicking on the error and drag-

ging the mouse to the right, or by positioning the cursor at the end of the visible portion of the

error message and hitting a RETURN, which causes the remainder of the error message to be

printed on the following line.

File->Save All forces a recompile of all components in the model. This is useful if the dates

on the files are corrupted, as may happen when a model is copied by hand from one place to

another, or, if editing on a different architecture than when last saved. A save may be done at

any time, but the files needed for the composed model will not be written until a save is done

successfully with all components completely defined.

File->Quit exits the SAN editor. If it is chosen before saving the model, the CP asks if the

model is to be saved before quitting. Click on either Yes or No to save before quitting or, exit

without performing a save.

� Edit Menu

Contains two options, namely: (i) Edit->Delete and (ii) Edit->Select All.

Edit->Deletedeletes an object and removes all files associated with it from the project direc-

tory. The operation is irreversible. To delete an object click on Select, pick out the particular

object to be deleted upon which its handles (small boxes around the object) become visible and

click on Delete.

Edit->Select All is useful if the entire subnet is to be selected. (e.g., when the entire SAN

needs to be repositioned, do a Select All and use the mouse to reposition the SAN.)

� Font Menu Contains a list of available fonts that can be used while constructing a subnet. The

default font is Helvetica 12. To change the font, first click on Select and then click on the

object or text whose font is to be changed. This causes the selected objects or text to have their

handles (small boxes around objects) visible. Highlight the desired font from within this menu

item to make the change.

� Option Menu

Has a few miscellaneous options which are mainly for user convenience. They are:
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Option->Grid Visible/Invisible turns the grid either on or off. Default is on. The off

and on toggle.

Option->Grid Spacing.. changes the grid spacing. The default spacing is 8 points. A

pop-up window displaying this default spacing appears on selecting this option. Enter the new

number in place of the default and click on OK to effect the change. Decreasing the number

causes the points to appear closer and increasing it causes them to appear more spread out.

Edit->View global variables prints all objects in which global variables are defined in

the following format. For every global variable defined, the internal name employed by Ultra-

SAN, the type of this variable and the names of all objects that this global variable is used in,

are printed on the CP. A dialogue box with the message The global variable list was printed

on stdout appears in the end.

Edit->Check global variable types verifies that the same global variable is not de-

fined as a short in one place and as a double in another.

3.9.2 Tool panel options

The tool panel (column on the left side of sanedit, see Figure 3.6) contains a variety of options.

Starting with the option at the very bottom, they are:

� Drawing area panner

The panner is at the bottom of the tool panel. The box within the shaded region represents the

position of the currently visible drawing area within the entire drawing area. Different sections

of the drawing area are made visible by clicking on the smaller box with the left mouse button

and dragging it to the desired destination. This can also be done with the four arrows just above

the panner. The two arrows just to their right are for zooming in and out. Once the maximum or

minimum levels of magnification are reached, selecting the corresponding arrow has no effect.

If the model to be edited is not visible, then zoom out to find the model, center it in the display

(by doing a Select All followed by a Move), and then zoom in again. The sanedit window

may be resized using whatever method is used for the user’s window manager.

Note: Some errors have been reported if the window is resized while the SAN is being loaded.

� Drawing arcs

Continuing upwards in the tool panel, the next set of options are the two arc tools that are

used for drawing straight or curved lines. They are used by first selecting one of the arc tools

with the left mouse button. Move the mouse to the desired point of origin of the line, click the

left button and release. Move the mouse to each intermediate point, click the left button and

release. When the destination is reached, click the center button. If one of the end points of
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the line cannot be identified as an appropriate object, an error message appears. This can be

avoided by placing the end points clearly within the boundaries of the desired endpoint objects.

Lines may overlap objects or other lines. While drawing an arc, if the mouse is moved to the

edge of the window, the drawing area will automatically scroll in that direction.

Note that lines may only be drawn between certain objects in a certain order as listed below:

– from place to activity

– from place to input gate

– from activity to place

– from activity to output gate

– from input gate to activity

– from output gate to place

Any other combination or order causes an error message to appear. An arrow is automatically

placed at the head of the arc when connecting a place directly to an activity, or an activity

directly to a place.

The tool does not insist that the arcs be drawn to a particular side of an object, but the following

conventions exist:

– arcs entering activities go to the left side of the activity

– arcs leaving activities come from the right side of the activity

– arcs entering gates go to the vertical side of the gate

– arcs leaving gates come from the point of the gate

� SAN model primitives

These are the next set of tools just above the drawing area and are used for placing new SAN

model primitives into the drawing area. The set contains:

– Place represented by a circle

– Instantaneous Activity represented by a solid vertical bar. If the activity has mul-

tiple cases, they appear as small circles on the right side of the vertical bar.

– Timed Activity represented by a hollow vertical bar, and has small circles on its right

side if it has multiple cases

– Input Gate represented by a triangle with its point pointing to the left

– Output Gate also represented by a triangle with its point pointing to the right
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A SAN model primitive is selected by clicking the left button while the cursor is on the name.

If the button is held down while the mouse is moved, a rectangular outline of the component

appears. Move this component to the desired location and place it by releasing the button.

A window appears requesting a name for the component. The name must be unique for that

type of component. For activities, the number of cases is given by following the name with a

space and the number of cases. If no number is given, the default is one. The name of each

object appears beneath the object. When an object is placed, small black boxes called handles

become visible around its border. The area within an object’s handles may not overlap with

any other object. This will cause an error message to be displayed.

When components are placed, their outlines are initially dotted (except for places). This im-

plies that the particular component is undefined. The method for defining objects is discussed

in the following subsection. Finally, models can be saved with undefined components, but

such models cannot be used in the composed model editor.

� Additional tools

The top part of the tool panel contains options for selecting and modifying components of the

drawing. They are selected by using the left button of the mouse, just as described with the

earlier tool options. The tool options and functions are as listed below.

– Select selects objects including arcs, within the drawing area. To select an object, place

the cursor on the object and click on the left mouse button. To select several objects,

click near the desired objects and drag the resulting box over them. Additional objects

will have their handles visible. If all the objects within the subnet have to be selected,

use Edit->Select All. Select is also wired into the right hand mouse button. Position

the cursor over an object and click the right button to select it.

– Define defines all components of the model. After selecting Define, select the desired

component that is to be defined from the drawing area. A pop-up window whose format

depends on the type of component being defined appears.

Definitions require a combination of functions and expressions except for places. A func-

tion is a series of C statements, each ending with a semicolon, that modify the mark-

ing of the model. An example statement is “++MARK(queue);”. MARK is a macro that

converts the expression to the variable holding the marking of the specified place. This

sample statement increments the marking of place queue. An expression is any valid C

expression. Examples of expressions are 10.0 (floating point), MARK(queue) (integer),

and(MARK(queue) < 5) (Boolean). It is very important to use the correct type of expres-

sion for a given definition.
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Figure 3.8: Place editor.

An expression can be given by itself, or a series of statements can be used. For instance,

a few statements may be needed to calculate a timing parameter. In this case, the final

expression must be given as the argument of a return statement. sanedit distinguishes

between these two formats by searching for a semicolon in the definition. If a semicolon

is found, the code is compiled by itself. If no semicolon is found, a return is automati-

cally inserted before the specified expression. All code is compiled using the compiler

specified in $USAN/setup/ARCH/compile.def (see Appendix A).

The following paragraphs discuss the Define procedure for the various SAN primitives.

Defining places When a place is defined, a window similar to Figure 3.8 appears. Just
the initial marking is requested. This value must be a non-negative short integer, which
implies that place markings are limited to non-negative integers less than or equal to
32,767. The initial marking however may be defined as a scalar value, or a global vari-
able. In case the initial marking needs to be a global variable, use GLOBAL S(variable)
to define it. If places are not defined, they are assumed to have an initial marking of zero.
The following points should be noted while using global initial markings:

� global variables for places MUST be of type short (i.e., they must be defined as
GLOBAL S(global var) and not GLOBAL D(global var))

� global variables for initial markings should not be any arithmetic expressions, or
functions of other initial global markings

Defining activities For timed activities, a window similar to Figure 3.9 appears. The
steps involved in defining activities are:

� Specify an activity distribution function by clicking the selector next to the desired
distribution in the box titled Time Distribution Functions. For analytic solu-
tions, only exponential and deterministic distributions may be selected.

� Next, enter the parameters for the distribution chosen in the box below Parameters.
The headings on the parameter windows change depending on the distribution cho-
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Figure 3.9: Activity editor.
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sen. For the exponential distribution, only the rate is required, which is the recip-
rocal of the mean. Table 3.1 gives a list of the distribution functions for timed ac-
tivities in UltraSAN together with their parameters. The 1st column titled “Parame-
ter(s)” displays the parameters that is needed by UltraSAN when the corresponding
distribution is chosen. The 2nd column titled “Comments” has a brief explanation
about the parameters requested. The reader is referred to [1] for details regarding
the parameters and distributions. The 3rd column titled “Range” contains the range
of values that the activity time can take.
The parameters can be expressions (double-precision numbers), global variables of
type GLOBAL D, or a series of statements. In this example, the rate is specified as
a global variable, namely, proc rate, and is of type double. If statements are used,
a return statement is needed with a double-precision value equaling the parameter.

If more than one case is specified, an additional subwindow is present for specifying the
case probabilities. Only one case is visible at a time, but the remaining cases can be
stepped through by clicking on the label of the case number.
Some points to be noted are:

� The first case probability corresponds to the top circle on the activity.
� Case probabilities can be expressions (double-precision numbers between zero and

one), or if a series of statements is used as in Figure 3.9, a return statement is needed
with the desired value.

� Case probabilities must sum to one.
� A value of ZERO should be returned for probabilities equal to exactly zero. This

keeps the state space generator from creating a zero rate path for the case. Note:
ZERO is defined internally as negative two, so be careful not to include its value in
any mathematical calculations, such as returning a sum of probabilities with one of
them equal to ZERO.

� Case probabilities may depend on the marking of places but need not be connected
to those places.

� Case probabilities can be defined to be global variables by using GLOBAL D(case
probability), or can also be functions of global variables.

� Case probabilities can be made marking dependent on another place whose marking
is a global variable, defined by using GLOBAL D(MARK(markingdependent place)).

� When defining instantaneous activities, only the case probabilities need be specified.

If reactivation of activities is desired, it is done with the activation and reactivation pred-
icates. The points to be noted here are:

� If an activity is activated in a marking where the activation predicate holds, then it is
reactivated when a stable marking is reached where the reactivation predicate holds.

� Both activation and reactivation predicates must be specified as Boolean expres-
sions.

Defining gates When defining input and output gates, windows similar to Figures 3.10
and 3.11 appear, respectively. The points to be noted while defining gates are:

� When defining input gates, a predicate and function must be given.
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Distribution Parameter(s) Comments Range

beta �1 > 0 �1 - shape parameter [0,1]
�1 > 0 �1 - shape parameter

binomial t 2 f1; 2; 3; :::g t = number of independent Bernoulli trials f0; 1; :::; tg
0 < p < 1 p = success probability for each trial

deterministic value > 0 [0, 1)
Erlang m 2 f1; 2; 3; :::g � = mean of each exponential stage [0, 1)

� > 0 m� � = mean of the m-stage Erlang
exponential rate > 0 mean = 1/rate [0, 1)
gamma � > 0 � - shape parameter [0, 1)

� > 0 � - scale parameter
geometric 0 < p < 1 p = success probability in independent f0; 1; :::g

Bernoulli trials
hyperexponential rate1 > 0 exponential service1 with mean = 1/rate1 [0, 1)

rate2 > 0 exponential service2 with mean = 1/rate2
0 < p < 1 p = branching probability

lognormal � 2 (�1;1) � - scale parameter [0, 1)
�2, � > 0 � - shape parameter

negative binomial s 2 f1; 2; 3; :::g s = number of failures before the sth success f0; 1; :::g
in independent Bernoulli trials

0 < p < 1 p = success probability for each trial
normal mean > 0 distribution is truncated and rescaled so that [0, 1)

variance > 0 only values > 0 are generated
triangular a; b; c a - location parameter [a,b]

a > 0 c - shape parameter
a < c < b (b� a) - scale parameter

uniform lowerbound : a a - location parameter [a,b]
upperbound : b (b� a) - scale parameter
0 � a < b

Weibull � > 0 � - shape parameter [0, 1)
� > 0 � - scale parameter

Table 3.1: Table of activity time distribution functions in UltraSAN.
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Figure 3.10: Input gate editor.

Figure 3.11: Output gate editor.
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� When defining output gates, only a function is needed.

� Input predicates must return a Boolean value. They may be an expression or a se-
quence of C statements.

� Input functions and output functions are a sequence of C statements.

� No return statements are needed in function specifications, since their action is to
change the marking of the SAN, not to return a value.

� If no action is desired in a function (the identity function), this is specified by a lone
semicolon.

� If predicates or functions depend on the marking of a place, the place must be con-
nected via an arc to the gate.

� Global variables may be used while defining input and output gates.

Below are a few general points about defining objects:

� Once any object is defined, its outline switches from dotted to solid lines. This
change indicates that the object is defined, and will be compiled when a save is done
on the SAN.

� All the editors that require text to be inserted have expandable, size buffers. A dialog
box appears each time the buffer size is to be increased, with each increase being a
factor of 2.

� Each editor gives an Accept and Abort selector. If Accept is chosen, files are writ-
ten to disk, making this operation irreversible.

– Move relocates selected components and all components connected to them within the
drawing area. If a single component is to be moved, it must be disconnected from the rest
of the components by deleting all connecting arcs. To move an object, first select Move,
then click on the object to be moved with the left button, drag it to its desired location
and release the button. This can also be done with the center mouse button and using
Select. A box appears while an object is being moved. If Move is used on an object
that is not currently selected, that object becomes selected and can be moved. If Move is
used on an object that is currently selected, that object and all currently selected objects
will be moved.

– Magnify enlarges objects within the drawing area. To enlarge an object, select Magnify
and click on the object to be magnified. The magnified model now becomes scaled such
that the selected object fills the drawing area. To revert back to original size, click on
the bigger arrow that points downwards just above the panner (i.e., the zoom-in arrow),
till the original size (magnification size 1, as indicated in the top right hand corner) is
reached.

– Text places text at the selected point within the drawing area and is also a useful tool
to document parts of the model. To enter text within the drawing area, first select Text
by clicking on the left mouse button. Next, place the cursor (which appears as an arrow)
by the object within the drawing area where the text is to be entered and click on the left
button again. The cursor turns into a vertical bar. Enter the desired text, using the desired
font from the Font menu item. Note: The text that is entered may also be treated as an
object, and can be selected with Select and relocated with Move.
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Figure 3.12: Composed model editor display.

3.10 Composed Model Editor (Edit->Composed model)

Once all the subnets are defined and successfully compiled, they are joined together and de-

fined with the composed model editor, also called compedit. The composed model is created or

edited with Edit->Composed Model. The pop-up window that appears will have an entry in it if

Project->Select was exercised prior to this option, else it will be blank. Fill in the project name

in the latter case and click on OK to proceed.

Figure 3.12 shows the display when editing the faulty proc composed model. In this example,

the processor submodel is replicated and joined with one copy of the buffer submodel. An error

message is displayed if the subnets are not fully defined.

The editor is similar to the SAN editor, except that the available primitives are now Subnet,

Replicate, and Join. Each is used by selecting the option with the left mouse button, moving to the

desired location, and clicking on the left mouse button again. As with sanedit objects, if the button

is held down, an outline of the component appears. This can then be moved to the desired location

and placed by releasing the button. If placing a subnet, a window listing all available subnets appears

and requests for the name of the particular subnet. Choose the desired subnet by highlighting it. An

outline of the subnet appears. Place the box within the drawing area with the mouse.

The Replicate tool is useful for creating copies or replicas of a particular subnet. This is a

very powerful tool and reduces the state space of the resulting model. The Join tool is used to join
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or connect the various subnets that form a project. Details of each of these tools is discussed after

briefly discussing the remaining tools and menu items, which are similar to those in the SAN editor.

The remaining tool options, namely, Select, Define, Move, Magnify and Text along with the

drawing arc, panner and zoom-in-and-out arrows are similar to those described in sanedit, and the

reader is referred to Section 3.9 for a discussion of their details. Also, since the menu items File,

Edit, Font and Option, parallel their counterparts in sanedit, the reader is referenced to Section

3.9 for their discussion with only the differences being mentioned here:

� File contains only the Save and Quit options, whose functions are similar to their counterparts in the
SAN editor. File->Save saves the drawing and the associated project files, while File->Quit exits
the composed model editor. If Quit is chosen before saving the model, the user is asked if the model is
to be saved before quitting. Unlike sanedit, however, if Quit is chosen before saving, all changes are
discarded including changes accepted in the Replicate and Join editors (which are discussed Section
3.10).

� Edit is similar to that in sanedit in Section 3.9

� Font is similar to that in sanedit in Section 3.9

� Option is similar to its counterpart in sanedit in Section 3.9

The structure of the composed model must be a tree with only one node at the top level, and all

the leaves of the tree must be subnets. Rep nodes can be placed above subnets, Join nodes, or other

Rep nodes. Join nodes can be connected to one or more subnets, Rep nodes, and other Join nodes.

If no Rep or Join nodes are desired, the entire composed model will be just a subnet (as is the case

if the project contains only one subnet).

The nature of each connection relates to the use of common places. The common places are

specified by defining the Rep and Join nodes using the Define tool, as explained in the following

sections. A few points to be noted here are:

� Subnet nodes cannot be defined in the composed model editor.

� A node cannot be defined until the entire subtree below the node is fully defined.

� Defining a node will also undefine all nodes above that node.

� Nodes that are not defined have a dotted line border.

The following paragraphs discuss the procedure for defining and using Replicate and Join in de-

tail.

Rep nodes When defining a Rep node, a window similar to Figure 3.13 appears. The desired num-

ber of replica must be given, and the common places must be specified. A place is marked as common

by clicking on the box to its left. This makes the place a single place shared by all replica.
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Figure 3.13: Replicate editor.

In the faulty proc model, since all processors remove tasks from the same queue, queue is marked

as common by clicking on the box next to it. This causes an x to appear in the corresponding box. If

a subnet is being replicated, the list of possible common places is all places in that subnet. If a Rep

or Join node is being replicated, the list of possible common places is the set of common places from

the node below.

Summarizing, a Rep node is defined by specifying the number of Reps to be the desired number

and checking off the common places by clicking on the tiny squares beside them.

Join nodes When defining a Join node, a window similar to Figure 3.14 appears. A list of places is

presented for each connected subtree, consisting of all common places from the top of that subtree.

A maximum of fifteen subtrees is permitted per Join node, although more can be joined by joining

Join nodes. The lists are ordered left to right, top to bottom according to the left to right ordering

of the subtrees in the composed model. In order to avoid confusion, it is recommended that the user

not cross arcs in the model. Sets of common places can then be chosen from the given lists, although

places within one set must have the same name. Places with the same name that are not chosen are

considered different places in the composed model. Even a single place can be marked as common

by itself. This is done for the purpose of making that place eligible for being common in the level

above the Join.

A few useful points while navigating through compedit are:

� The sets of common places is viewed by clicking the Prev and Next selectors.

� A common set is added by selecting the places desired in the set, and then selecting Add.

� Add Set is used to select all places with the same name after one place is selected.
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Figure 3.14: Join editor.

� Add All is used to add all possible sets, except singletons.

� When a set is defined, all places with that name become disabled, because places with the same

name cannot be in more than one set.

� To delete a set, find the set by using Prev and Next, and select Delete.

Some rules concerning common places and global variables:

� Common places must have the same initial marking.

� Places connected to the input side (through an input gate or not) of an instantaneous activity

may not be made common. Note: This rule prevents an activity completion in one subnet from

putting another subnet into an unstable marking (one or more instantaneous activities enabled).

After changing a subnet and starting compedit, one or more Rep or Join nodes may be marked

as undefined. This will happen if:

� A place is added to a subnet.

� A place is deleted from a subnet.

� An initial making is changed.

In this case, all nodes along the path from the changed subnet to the root node become undefined

and must be redefined. The composed model can be saved at any time, but the model cannot be used

with the performability variable editor (varedit) until all nodes are successfully defined.
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Figure 3.15: Performability variable editor display.

3.11 Performability variable editor (Edit->Performability Variables)

Once the composed model is defined, appropriate performability variables must be defined. This

is done with Edit->Performability Variableswhich brings up the performability variable ed-

itor, also called varedit. As with sanedit and compedit, if Project->Select is exercised prior to

invoking varedit, the entry corresponding to the project name in the pop-up window will be filled,

else it appears blank. Fill in the name in the latter case. An error message is displayed if the com-

posed model is not up-to-date. The composed model will not be up to date if a change was made to

one of the subnets in the composed model, and the user did not save the composed model. Figure

3.15 shows the display when editing the faulty proc model.

The screen in Figure 3.15 is divided into the reward variable selector and the activity variable

selector. Reward variables (as discussed in Chapter 1) can be split into different categories: instant-

of-time, interval-of-time, and time-averaged-interval-of-time. Instant-of-time variables are further

divided into steady-state (t!1 ) and terminating or transient (t <1 ). Activity variables measure

the mean and variance of times between the completion of a certain activity. They are also divided

into instant-of-time, interval-of-time, and time-averaged-interval-of-time.

The method of choosing a variable type depends on the method of solution that is used. When us-
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ing analytic solvers, the type of variable is specified by executing the appropriate solver, as described

in Chapter 4. In the case of simulation, the Edit Stats button is used to specify information spe-

cific to simulation. In either case, however, reward variables must be defined via Edit Rate and

or Edit Impulse. The following paragraphs describe the procedure for adding and deleting these

reward variables, and specifying their meaning.

Adding and deleting variables Both reward and activity variables are added and deleted using

Add and Delete. To add a reward variable, just the name of the variable is needed. Names can have

any format, including spaces, although spaces are translated to dashes for filename purposes. To add

an activity variable, enter the name of the subnet followed by a space and the name of the activity.

Any variable can be selected by clicking on it with the left mouse button. Delete will delete the

currently selected variable. No variable renaming is currently supported.

Editing rate rewards of reward variables If Edit Rate is selected, a window similar to Figure

3.16 appears. This window has a Predicate editor and a Function editor. When the predicate is true,

reward is accumulated at the rate defined in the function. Both the predicate and function are ex-

pressions in varedit. To get conditional values, multiple predicate-function pairs must be specified.

Reward is summed over all predicates that hold.

The present window is a view-only window. The set of predicate/function pairs is viewed by

clicking on Prev Rate and Next Rate, which display all the pairs for a submodel. Use Prev

SubModel and Next SubModel along with Prev Rate and Next Rate to navigate through and

view all the rate reward variables defined for all the subnets in the composed model.

The predicate and function can depend only on place markings for that submodel. (See also the

note below on frequently encountered error message with respect to this.) Use Add Rate to add a

new predicate-function pair, Edit Rate to edit a previously entered predicate and/or function, and,

Del Rate to delete a predicate-function pair from the currently defined set. A few points worth

noting in this context are:

� When multiple predicate-function pairs are defined for a particular submodel, the reward value
returned is the sum of all the individual predicate-function definitions.

� If the place for which the reward structure is being defined belongs to a subnet that has been
replicated n times (via the Rep option), the reward value returned will be multiplied by the
number of replicas that satisfy the predicate.

Note: A frequently encountered error message while defining reward variables is the following

message that might appear on a pop-up window while compiling the reward variables.

There were errors in compilation. Operation Aborted

The CP then prints a message similar to the one below:
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Figure 3.16: Rate reward specification.
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Figure 3.17: Impulse reward specification.

“path name up to project in consideration/int/project name.c”, line 14: NOTaPLACE

varedit: Exit status = 2 (failure) Performability variable editor is incomplete; can’t ac-

cess study editor.”

This means that the particular place is not present in the subnet where the reward variable is de-

fined, though it may be present in another subnet, and hence in the composed model. This is a fairly

common error and may be corrected by invoking varedit (i.e., Edit->Performability Variable

Specification) and using Prev SubModel and Next SubModel to arrive at the appropriate sub-

net (the subnet that contains the place in consideration) and then defining the reward in that particular

submodel.

Editing impulse rewards of reward variables If Edit Impulse is selected, a window similar

to Figure 3.17 appears. The list of all the timed activities in each submodel will be given. Impulse

rewards can then be specified for each activity.

For instant-of-time variables, the value of the impulse reward is the impulse reward associated

with the last activity that completed. If one activity has an impulse reward of one, the rest are zero,

and no rate reward variables are defined, this equates to the probability that this activity was the last

one to complete before the specified instant of time. For interval-of-time variables, the value of the

impulse reward is the accumulated impulse reward over the interval. Given the same scenario, this

equates to the number of times that this activity completed during the interval.
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Figure 3.18: Reward variable simulator statistics.

Editing reward variable statistics To edit parameters related to simulation, use Edit Stats. A

window similar to Figure 3.18 appears. Within the reward variable statistics editor, there are sev-

eral things to specify. The type of variable must be specified, i.e. Instant-of-time, Interval-

of-time, or Time-averaged-interval-of-time. Looking ahead, there are three simulators: the

steady-state simulator (SSim), the terminating simulator (TSim), and the Importance Sampling termi-

nating simulator (ITSim). ITSim is discussed in Chapter 4, while the other two are discussed briefly

below.

If SSim is used on an instant-of-time variable, the time instant is assumed to be infinity. If TSim

is used on an instant-of-time variable, the time instant is taken from the Start of Interval field.

If TSim is used on an interval-of-time variable, the start of the interval is taken from the Start of

Interval field, and the length of the interval is taken from the Length of Interval field.

The user may specify the mean and/or variance to be estimated. There are boxes for the confi-

dence level, relative confidence interval, initial transient, and batch size. Valid confidence levels are

0.80, 0.90, 0.95, 0.98, and 0.99. Any relative confidence interval can be chosen. These values are

used as follows.

For steady-state simulation, the simulator uses a technique called iterative batching. The simu-

lator starts by scheduling and executing events for the duration of the initial transient, which is spec-

ified in the same time units as the user’s model, i.e., if the user measures timed activities in seconds,

so are the initial transient and batch size. The next interval of time is the first batch and extends for

the length of the specified size of the batch. Successive intervals are different batches of the same

simulation. Batch sizes should be long enough that results for different batches are uncorrelated.
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Figure 3.19: Activity variable simulator statistics.

For interval-of-time and non-steady-state instant-of-time variables, the simulator uses a tech-

nique called independent replications. For each replication, the simulation starts from time zero,

and proceeds until all variables, whether instant- or interval-of-time, have been observed once. Each

replication constitutes one observation of the variables.

The simulation terminates when the maximum number of batches or replications is reached, or

when the result is within the relative confidence interval with a probability equal to the confidence

level [1].

Editing activity variable statistics Edit Stats option is used for editing parameters related to

simulation. A window similar to Figure 3.19 appears. Within the activity variable statistics editor,

there are several things to specify. The user can specify if the mean and/or variance is to be estimated.

There are boxes for the confidence level, relative confidence interval, initial transient, and batch size.

They are used in a way similar to that of reward variables, except now the initial transient and batch

size are in units of activity completions, as opposed to time. The counterparts of the start and length

of interval fields for reward variables are the first and last completion fields for activity variables.

3.12 IS editor (Edit->IS Governor)

This editor is used while using Importance Sampling if simulation is used as the method of solu-

tion. It is discussed in detail in Chapter 6. (Note that it does not need to be invoked if the importance

sampling simulator is not used.)
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Figure 3.20: Study editor display.

3.13 Study Editor (Edit->Studies)

After the performability variables are defined, multiple studies each with one or more experi-

ments may be created for the project in consideration, using the study editor stdedit. Studies may be

created to examine the effect of the various model parameters on the system performance. For each

study created, experiments are defined based on the different values that the parameters may take.

The study editor is invoked by using Edit->Study, which causes a window as in Figure 3.20 to

appear. This is called the global variable assignment editor, and it provides options to add, delete and

edit studies. It displays a list of studies that were previously defined (if any), or is blank otherwise.

To add or create a new study, select Add. A dialogue window asking for the name of the new study

appears. Enter the desired study name and select OK to create the new study. To remove an existing

study (i.e., delete all experiments and results associated with a study), select Delete, which pops up

a confirmation window. Click on OK to delete the selected study or No to abort the operation.

Once a study is added, multiple experiments may be defined using either the Range or Set selec-

tors. Range is used while defining multiple experiments which might have a range of global variables

that change in some fixed additive or multiplicative increments. Set on the other hand is useful when

the global variables do not change in an additive or multiplicative manner, but need to be specified

explicitly.

To use the Range or Set editor, a study must first be selected. Figure 3.21 shows the set edi-
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Figure 3.21: Set editor display.

tor. Experiments are added by selecting Add in Figure 3.21. A pop-up window listing all the global

variables with values initialized to 0 appears. Fill in the desired values and click on Accept to add

this newly defined experiment. To delete an experiment, use Prev and Next to display the desired

experiment, whose number is displayed on the top left hand corner, and click on Delete to remove

the experiment. To edit an existing experiment, choose the Edit selector. A pop-up window bearing

the old parameters appears. Edit the desired variables and click on Accept to reflect the change. The

Prev and Next selectors are also used to navigate through the experiments in a particular study.

The set editor also provides for reading and writing formatted files of global variables and

their assigned values via the Import and Export selectors. The following paragraphs describe the

Import and Export features in detail. In particular, Export makes it possible for the user to write

the list of global variable values to an export file outside of UltraSAN in the following format:

� The first line in the file contains all global variables defined in the subnets for the selected
project separated by blank spaces.

� The second line contains the types for these variables (i.e., short or double).

� The subsequent lines contain the values for these global variables in the order listed in line 1.
The values in each line correspond to one experiment.

Thus experiments can be added (or deleted) by editing this file via a “vi” for example, and adding

(or deleting) as many lines as the desired number of experiments. Upon editing the desired export

file, use the Import facility to generate the corresponding added experiments. The import and ex-

port files have the same format. The set editor reads the import files and generates the corresponding
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Figure 3.22: Range editor display.

experiments. Once the file has been imported (and thus the experiments generated), the added ex-

periments may be traversed by selecting Next and Prev. After reading in the global variable assign-

ments through the import file, the user can add, delete or edit any of the experiments. The original

export file can also be edited and then imported back through this import facility. Also note that that

the import files could be generated by a user program, should this prove convenient.

To use the import and export facilities, click on the appropriate selectors. A small window bear-

ing directory path information appears. If Export is selected and no export files exist, add the name

of the file to be exported in the directory path information space. If no file exists and Accept is se-

lected, a pop-up window informing that the export operation can not proceed appears. An export file

with the format mentioned earlier appears in the corresponding study directory. The user can edit

this file and import it by using the Import selector subsequently and entering the name of the partic-

ular file to be imported (full path name) in the pop-up window that appears whenImport is selected.

Finally, just as with the export facility, if the user selects Import and clicks Accept without having

created the import file, a pop-up window informing that the import operation can not proceed will

appear.

The range editor as shown in Figure 3.22. may also be used to define studies and their exper-

iments. Unlike the set editor, the range editor allows a user to specify either a range of numerical

values or a fixed value for each global variable. The range of numerical values for any global vari-

able can be specified by selecting an initial value, a final value, and an increment factor. The incre-

ment factor can be additive or multiplicative. It is necessary to assign either a fixed or a range of

numerical values to each global variable. The range editor creates the various experiments by iter-
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studies

vary_arrival_rate vary_error_prob

exp1 exp2 exp3 exp4 exp5 exp6 exp1 exp2
20.0
5.0
10.0
0.81
0.18
1.0

20.0
10.0
10.0
0.81
0.18
1.0

20.0
15.0
10.0
0.81
0.18
1.0

20.0
20.0
10.0
0.81
0.18
1.0

20.0
25.0
10.0
0.81
0.18
1.0

20.0
30.0
10.0
0.81
0.18
1.0

20.0
10.0
10.0
0.75
0.24
1.0

20.0
10.0
7.5
0.77
0.21
1.0

access_rate
arr_rate
io_rate
ok_prob
one_error_prob
proc_rate

Figure 3.23: The studies subdirectory for the faulty processor model.

ating over the specified ranges and making one experiment for each tuple of numerical values. The

iteration stops when the range value is equal to or larger than (if the last value is not an exact additive

or multiplicative factor of the increment size) the final value specified. Thus the number of experi-

ments for a study generated by assigning values through the range editor is computed by evaluating

the Cartesian product of the ranges specified for all the global variables.

In addition to generating studies and their experiments, the study editor maintains the studies sub-

directory in the project directory structure. Within this studies subdirectory, the study editor further

creates a subdirectory for each study defined. Each of the directories corresponding to a particular

study in the studies subdirectory further contains subdirectories that correspond to the various ex-

periments defined for that particular study. For an existing study, it creates or deletes experiment

subdirectories for added or deleted experiments, respectively. Figure 3.23 shows the directory struc-

ture for the studies subdirectory for the faulty proc project.
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Chapter 4

Solvers

This chapter describes the various analytic and simulation solvers that are available. The solvers

are selected through the Solve button, and must be run after the model has been fully specified by

applying the various editors under the item Edit (see Chapter 3). General suggestions about which

solvers to apply for specific model and measures are presented preceding the detailed description

of the specific solvers. This chapter uses the classification of measures and models as introduced in

Section 1.4 of Chapter 1.

4.1 Choosing an Appropriate Solver

Applicability of both the analytic solvers and simulators depends on the type of performability

measure and model class considered. All measures and model classes are described in detail in Chap-

ter 1. Given a model and measure, a choice between analytic solution and simulation has to be made.

There are some basic rules when analytic solvers and simulators can be applied:

� Analytic solvers only can be applied to the two model types in Section 1.4 of Chapter 1, i.e.,

to models with all exponential activities or with at most one enabled deterministic activity at

the time. Simulation can be applied to all model classes.

� Models must have a finite state space for analytic solution.

� If activity variables are used, only simulation can be applied.

Table 4.1 gives the measure and model classes for which analytic solvers can be applied, and

Table 4.2 gives this information for the simulators. Use the tables as follows. First, identify which

model class a model belongs to and which measure type is to be derived. The solver that can be

applied can then be found in the right-side column. So, for instance, the ars solver gives the mean

of transient interval-of-time measures for models where all timed activities are exponentially dis-

tributed. The abbreviations used in Table 4.1 for the analytic solvers have the following meaning

(we give the names as they appear in the menu items of the control panel):

4-1
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Analytic Solvers (for reward variables only)

Steady-state Instant-of-time Mean, Applicable
or or Variance or Analytic

Model Class Transient Interval-of-time Distribution Solver

All activities Steady-state Instant-of-timea Mean, Variance dss and iss
exponential and Distribution

Transient Instant-of-time Mean, Variance trs
and Distribution

Interval-of-time Mean ars
Distribution pdf

Exponential and Steady-state Instant-of-timeb Mean, diss
deterministic Variance

activities and Distribution

aif only rate rewards are used, the time-averaged interval-of-time steady-state measure is identical to the instant-of-time
steady-state measure (if both exist).

bprovided the instant-of-time steady-state distribution is well-defined. Otherwise, the time-averaged interval-of-time
steady-state variable is computed and only results for rate rewards should be derived.

Table 4.1: Models and measures versus the applicable analytic solver.

Simulators (for all models)

Steady-state Instant-of-time Mean,
or or Variance or Applicable

Transient Interval-of-time Distribution Variable Simulator

Transient Instant-of-time Mean Reward variable TSim
and and and ITSim

Interval-of-time Variance Activity Variable TSim
Steady-state Instant-of-time Mean and Reward Variable SSim

Variance and Activity Variable

Table 4.2: Measures obtainable with different simulation solvers.
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� dss: Solve -> Direct Steady-State Solver

� iss: Solve -> Iterative Steady-State Solver

� diss: Solve -> Deterministic Iterative Steady-State Solver

� trs: Solve -> Transient Solver

� ars: Solve -> Accumulated Reward Solver

� pdf: Solve -> Probability Distribution Solver

For the simulators in Table 4.2 we use the following abbreviations:

� SSim: Solve -> Steady-State Simulator

� TSim: Solve -> Terminating Simulator

� ITSim: Solve -> IS Terminating Simulator (Importance Sampling).

An important difference between how the analytic solvers are applied and how the simulators

are applied is the precise specification of the performability measure. For analytic solutions, the

choice of the solver determines the specific performability measure which will be computed. In other

words, given a specified reward structure, the performability measure (including aspects as mean

or variance, transient or steady-state, etc.) is specified by the choice of the solver. For simulation,

on the other hand, the precise specification of the performability variable is carried out separately

under Edit->Performability Variables, by selecting Edit Stats in the Performability

Variable Specificationwindow. Only whether transient or steady-state results will be obtained

is determined by the choice of the simulator.

It must be understood that the Tables 4.1 and 4.2 give the potential use of the solvers; it is not to

say that the results will always be derived in a reasonable time span or can be fit into standard size

memory. These considerations are of primary importance for the practical application of the solvers

and are therefore discussed in some more detail. Advantages and disadvantages of the use of the

different solvers provided by UltraSAN are presented in four lists: advantages and disadvantages of

analytic solutions and advantages and disadvantages of simulation. The lists are not claimed to be

exhaustive, but try to capture the problems most likely to be encountered in the practical application

of the UltraSAN solvers.

Advantages of analytic solution

� Exact computation of a solution is carried out, i.e., opposed to simulation the outcome does not depend
on a generated stream of pseudo-random numbers.

� For the instant-of-time performability variables, distributions can be obtained without extra cost in ad-
dition to their mean and variance.
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� Accuracy of the solution can, for most solvers, be increased without excessive increase in the compu-
tation time, except for the limitations stemming from machine accuracy. This does not hold for the
performability distribution solver pdf but it typically does for dss, iss, diss, trs and ars.

Disadvantages of analytic solution

� Analytic solvers are not available for all models. The models must belong to the two model classes
presented in Section 1.4 of Chapter 1.

� Results for activity variables cannot be obtained.

� The state space size of the generated model must be finite. Moreover, it cannot be too large relative to
the memory of the used computer. The iterative solvers iss, trs and ars can usually deal with models of
up to several hundred thousand states. The other solvers demand additional memory besides the storage
of the transition matrix. See the discussion in the sections dedicated to the different solvers for more
details.

� It is a challenge to create models from which all the desired performability results can be derived, but
which have a small enough state space to allow for analytic solution. Considerable pay-off can be ex-
pected from exploring state space reduction approaches. In this respect the use of the Rep construct in
the composed model can be a very helpful tool.

� The analytic solution is time consuming if one deals with stiff models. A prominent class of stiff models
is those with large differences in the expected activity completion time. An example is a dependability
model in which there are long periods until component failures and relatively fast repairs.

Advantages of simulation

� Simulation can be applied to any SAN model and is thus not restricted to the types of stochastic pro-
cesses presented in Section 1.4 of Chapter 1. The most prominent difference, compared with analytic
solvers, is that generally distributed activities can be used.

� Simulation does not require the generation of a state space and therefore does not require a finite state
space. So, much more detailed models can be solved.

� Results for activity variables can be obtained in addition to those for reward variables.

Disadvantages of simulation

� Simulation provides an estimate of the performability measure. An approximate confidence interval is
constructed which contains the actual result with some user-specified probability. However, it always
is possible that the true result is not within the confidence interval. Furthermore, the confidence interval
is based on an estimator itself and thus may be incorrect.

� Higher desired accuracy dramatically increases the necessary simulation time. As a rule, to make the
confidence interval n times narrower, the simulation has to be run n2 times as long. Compare this with
the much more attractive result to be reported in the specific sections for the analytic solvers.

� Full distributions cannot be obtained by the UltraSAN simulators. However, it is often possible to derive
percentiles of certain distributions by specifying rewards 1 and 0 in the appropriate way.
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� The rare event problem may arise. If simulation is used to estimate a small probability, such as the reli-
ability of a highly-reliable system, extremely long simulations may have to be performed to encounter
the particular event often enough. A reliable estimate cannot be obtained with standard simulation ap-
proaches such as SSim and TSim. For transient measures UltraSAN therefore is equipped with an im-
portance sampling simulator ITSim (see Chapter 6).

� Complicated models can demand long simulation times, even if the rare event problem does not come
up. The simulators in UltraSAN perform the necessary event scheduling very efficiently but it should
be realized that simulation is not a panacea.

4.2 Analytic Solvers

All the analytic solvers require the explicit generation of the state space and the state transi-

tions of the stochastic process. Therefore, before being able to apply any of the analytic solvers,

the state space generator (under Solve -> Reduced Base Model Generator) must be executed.

The output of the generator is an ASCII file which the solvers subsequently use as input file. The for-

mat of this file is given in Appendix C. If desired, this file can be the input of other solvers than those

provided by UltraSAN.

Throughout the coming sections the abbreviation Gen will be used for calling Solve-> Reduced

Base Model Generator, while the abbreviations in Section 4.1 will be used for the solvers. These

abbreviations correspond to the commands executed when clicking OK in the various solver menu’s

and can also be used for calling the generator and solvers from the command line or in a shell script.

Furthermore, man-pages exist for these commands. These pages contain part of the information also

available in the coming sections and can be read by typing man commandname on the command line.

4.2.1 Reduced Base Model Generator

Before running any of the analytic solvers, the state space must be generated, following the

reduced base model construction approach in [3]. This is done with the Solve->Reduced Base

Model Generator menu option of the control panel, which executes Gen. When this is done, the

window in Figure 4.1 appears with the following available options.

� The Project Name must be specified. No default is assumed. However, if a project has previously
been selected in Project->Select, it will show up in the Project Name field.

� If an Output File Name is given, the results are put in the file expi.Gen.filename in the study’s re-
sults directory projects/projectname/studies/studyname/results. If no output file is given,
the output goes to the control panel as well as to the file expi.Gen.out.

� If Run in the Background is selected, other control panel options can be used while the state space
is being generated. An output file must be given in this mode.

� If Verbose is selected, each generated state and its associated reward for each variable are displayed
during generation.
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Figure 4.1: Control panel Gen options.

� If Flag Absorbing States is selected, all markings in which no activities are enabled will be dis-
played. Detection of these “absorbing states” is useful for debugging the model.

� If Don't Print Place Names is selected, Gen turns off the printing of place names next to their
markings. The markings are still printed in the lexicographic order of the associated place names.

� If Wide Output Screen is selected, Gen assumes a wider output screen. The default screen width is
80 columns. This option adds 30 columns to that width.

� If Build Only (Do Not Execute) is selected, an executable for the generation of the state space is
created. The state space is not generated in that case. To generate the state space, select the desired
experiments and apply Solve->Reduced Base Model Generator again.

As states are generated, a dot is printed after every 1,000 states, and a message is printed after

every 5,000 states. For large state spaces, there will be a delay after the final state count is reported

as the state space is being written to disk.

Throughout this section example results for the faulty multi-processor are presented. These re-

sults will be given in separate boxes. For the description of the model see Section 1.1.3 of Chapter

1.

Pitfalls and Hints

� Make sure the model has a finite state space by putting limits on the number of tokens in the places.
In the faulty-proc example the global variable GLOBAL S(size) in the input gate capacity limits the
number of jobs in the system.

� Realize that the state space size in reduced base model construction depends on the introduced impulse
rewards. The reported state space size may therefore be higher than in a case without or with less im-
pulse reward variables. See Section 1.4 of Chapter 1.
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) Construct the faulty proc state space by selecting Solve->Reduced Base Model

Generator within the control panel. Choose experiment exp2 of the study
vary arrival rate. This experiment has the following parameters, which will be dis-
played for Gen and for every solver applied to this experiment:

Global variable settings for this run:

access rate = 20
arr rate = 10
io rate = 10
num processors = 3
ok prob = 0.81
one error prob = 0.18
proc rate = 1
size = 5

The size of the state space with the processor submodel replicated three times is 1,920
states. On a SUN4, it will take a few seconds to generate the state space for this ex-
ample.

� Explore all possibilities to reduce the state space size, as a smaller state space size speeds up all analytic
solvers. Especially, try to model the system with the help of replicate in the composed model. Using
the replicate option an automatic state space reduction will be performed.

4.2.2 Common Features of All Analytic Solvers

Each solver is executed by selecting its entry in the Solve menu of the control panel. After

which, a window will appear with more options. The following options are common to all the solvers:

� The Accuracy is an integer representing the number of digits to the right of the decimal point that are
desired to be accurate. Usually nine digits is the default. If the number of specified digits exceeds the
machine accuracy, then the machine accuracy becomes the default. Note that it depends on the solver
what the accuracy setting precisely means. We will state the precise meaning of the Accuracy when
we discuss the individual solvers.

� The Project Name must be specified. No default is assumed, but if a project has been selected this
project name appears in the Project Name field.

� If an Output File Name is given, the results are put in the file expi.solver.filename,where solver
is the name of the solver being executed and i is the experiment number. This file is put in the study’s re-
sults directory projects/projectname/studies/studyname/results. If no output file is given,
the output goes to the control panel window as well as to the file expi.solver.out.

� If a Debug File Name is given, debug information is written in the file expi.solver.filename. This
file is put in the study’s results directory projects/projectname/studies/studyname/results.
If no debug file is given, no debug information is generated. The debug information is essentially a
file with detailed information regarding the solver. It can be useful for determining whether a solution
converges, but usually this information can more naturally be obtained by setting the Verbosity. The
Verbosity option will be discussed with each individual solver.



4-8 CHAPTER 4. SOLVERS

The following marking is the marking printout for the third generated marking in the example model that would
be given in verbose mode with place names being printed.

MARKING #3

Variable Name Rate Reward Impulse Reward

probability non-blocking 1:000000 0:000000
utilization 0:333333 0:000000
number of tasks in queue 0:000000 0:000000
number of tasks in system 1:000000 0:000000
fraction of time in I O 0:000000 0:000000
number of tasks processed 0:000000 0:000000

Subnet Name # Marking

processor 2 f done: 0, num tasks: 0, queue: 0, ready: 1 g
processor 1 f done: 0, num tasks: 1, queue: 0, ready: 1 g
buffer 1 f queue: 0 g

The top section lists the rate and impulse rewards corresponding to the present marking. The bottom section
gives the marking. It is given as the number of subnets in a particular marking. In this example, two of the
three processor submodels are in one marking, and the other one is in a different marking.

� If Plot Complementary Distribution is set, the complementary distribution function is written in
splot format to the file projects/projectname/studies/studyname/results (the complemen-
tary distribution gives the probability the performance variable is greater than some value x). The
complementary distribution can be displayed by choosing the General->Display option in the Con-
trol Panel. They can also be created by hand by executing splot -x expi.solver.variable.PDF.
splot. Besides the (complementary) PDF also the density function (pdf) can be plotted. See the man-
ual pages of splot for details about its operation.

� If Run in the Background is selected, other control panel options can still be used while the solver
is running. If no output file is specified, output automatically goes to the file expi.solver.out in
the results directory projects/projectname/studies/studyname/results, where solver is the
name of the solver being executed.

The output file of each solver will contain various information. It will first itemize the options

that were used, including defaults, and will contain the results of the solution process. It will also

contain the following information:

� The project, study and experiment for which the results are derived.

� The Global variable settings, which are the values assigned to all the global variables in the chosen
experiment.

� The Number of states in process, which is the number of states that were generated by Gen.

� The Number of non-zero elements, which is the number of non-zero elements in the transition matrix.

� The Computation Time, which is the total execution time, equal to the sum of user time and system
time.
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Figure 4.2: Control panel dss options.

� The User Time, which is the total amount of time spent executing in user mode.

� The System Time, which is the total amount of time spent executing in system mode.

4.2.3 Direct Steady-State Solver

The direct steady-state solver (dss) solves for instant of time variables with t!1, using a nu-

merically stable version of L-U decomposition [6]. This is done by solving the system of equations

given by pA = 0, with the additional constraint that the sum of all elements in the vector p sum to

one. p is the state occupancy probability matrix, and A is the generator matrix. The generator ma-

trix is obtained from the SAN by using the reduced base model generator (see Section 4.2.1). The

solver uses two methods to reduce the fill-in (non-zero elements) of the matrix during solution: the

improved generalized Markowitz strategy, which selects a next pivot element based on a heuristic

that can reduce fill-in, and a technique that sets elements that are less than some value (tunable, see

the options below) to zero during the execution of the solution algorithm [6]. If the problem is not

too large, the solver then uses iterative refinement to reach a correct final solution. The solver calcu-

lates the mean, variance, probability density function, and probability distribution function of each

performability variable. The means and variances are given in textual form in an output file, and the

probability density and distribution functions are given in splot format. When selected in the control

panel, a window like Figure 4.2 appears with the available options. The options are as follows:

� The Accuracy is an integer representing the number of digits to the right of the decimal point that are
desired to be accurate for the steady-state probabilities. The accuracy is approximated analytically [6].
Note that the accuracy of the obtained performability measure depends on the number of states in the
model as well as the value of the rate rewards.

� The Tolerance is a double which, when multiplied by the smallest matrix element, is the threshold
at which elements will be dropped in the LU decomposition. 0.0 is the default, which implies that no
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dropping takes place. In general, it is recommended [6] to choose the drop tolerance to be two to five
orders of magnitude smaller than the smallest matrix element, i.e., choose the Tolerance between
10�2 and 10�5.

� The Stability is a short integer representing the “grace” factor by which elements may become can-
didates for pivots. 0 is the default, meaning pivoting is turned off. A stability factor between 4 and 16
is recommended in literature, see [6].

� The Rows is an integer representing the number of rows to search for a pivot. 0L is the default, meaning
pivoting is turned off by default. A value of 2 or 3 is recommended [6]. (0L is a notation convention
taken over from the C programming language and can be replaced by 0 as well.)

� TheVerbosity (n) sets the trace level for intermediate output. The default is no intermediate output. If
n > 0, then the message completed column number n is printed after everyn iterations while computing
LU decomposition, forward substitution, backward substitution, and iterative refinement.

) Obtain the steady-state solution for the instant-of-time variables of the faulty proc
model by selecting Solve->Direct Steady State Solver within the control
panel. Specify the Project Name and an Output File Name. You should also select
Run in the Background, since it should take on the order of an hour to solve this model
with dss. The results should be as follows:

Performability variable Mean Variance
probability non-blocking 4:522711e� 01 2:477220e� 01
utilization 8:438868e� 01 4:404171e� 02
number of tasks in queue 4:068240e+ 00 1:694523e+ 00
number of tasks in system 1:036334e+ 01 1:885128e+ 00
fraction of time in I O 1:507570e� 01 4:267070e� 02
number of tasks processed 3:119777e� 01 2:146476e� 01

Note that the number of tasks processed variable does not make sense for any of the instant-
of-time solvers, since it is an interval-of-time variable.

) Try viewing one or more of the .splot files that were generated, using the
General->Display option in the Control Panel.

The output file will contain the means and variances of the performability variables. It will also

contain the following information:

� whether iterative refinement was used or not,

� the drop tolerance,

� the number of non-zero elements in the original matrix,

� the number of non-zero elements in the factorized matrix,

� if iterative refinement was used, it gives the maximum difference between the cells in the pA and zero
matrices; if iterative refinement was not used, the relative error is given,

� the number of correct decimal digits in the state probabilities,

� the number of zeros in the factorized matrix,
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Figure 4.3: Control panel iss options.

� the number of elements dropped,

� the number of new pivots selected.

Pitfalls and Hints

� dss can be used if the steady-state distribution of the Markov model exists of a single class of recurrent
non-null states. For instance, dss can not be applied to a model with multiple absorbing states. In that
case the message invmnorm: zero diagonal element will appear and the performance variable will take
the NaN (Not a Number) value. To find out whether the model has absorbing states apply the Flag

Absorbing Statesoption in the state space generatorSolve->Reduced Base Model Generator.

� dss is useful when relatively small models are considered because in the process of computing the
steady-state probabilities the original transition matrix is transformed into a matrix with many non-zero
elements. Sparse matrix methods, which use the fact that elements equal to 0 do not have to be stored,
can then no longer be profitably applied. This is known as the fill-in problem. Especially when large
models are considered fill in will become a serious bottle neck because the order of non-zero element is
in general quadratic in the size of the state space. For the running example the state space size of 1920
states will result in storage of about 4,000,000 doubles (compare this with the 11,182 non-zero elements
in the sparse original transition matrix). Consequently, dss can not be applied for models larger than
several thousand states. Note that the setting of the drop tolerance might be used to partially overcome
fill-in of the matrix.

� The CPU time required by dss also increases in the number of states (with power of 3). The iterative
solver iss often becomes faster than the direct solver dss when the state space size increases.

4.2.4 Iterative Steady-State Solver

The iterative steady-state solver (iss) solves for instant of time variables with t!1, using suc-

cessive over relaxation (SOR). This is done by solving the system of equations given by pA = 0,



4-12 CHAPTER 4. SOLVERS

where p is the state occupancy probability matrix, and A is the generator matrix. The algorithm

guesses at p, calculates pA, and then comes up with a new guess related to the difference between

the answer and the zero matrix. This continues until the maximum difference between the cells in

the two matrices is within error bounds. The initial guess for p is equal probability for all states. The

acceleration factor used must be selected by the user. Because of its more modest space require-

ments, this solver can be applied to larger systems than dss, but it is not guaranteed to converge for

all reduced base models and initial conditions. It calculates the mean, variance, probability density

function, and probability distribution function of each performability variable. The means and vari-

ances are given in textual form in an output file, and the probability density and distribution functions

are given in splot format. When selected in the control panel, a window like Figure 4.3 appears with

the available options. The options are as follows:

� The Weight is a double representing the acceleration factor. 1.0 is the default. A value of 1.0 reduces
the SOR method to Gauss-Seidel. Values between 1.0 and 2.0 may accelerate convergence. Values
between 0.0 and 1.0 are less subject to divergence.

� The Max Iterations is an integer representing the maximum number of iterations that will be performed
before terminating the solver. 300,000 is the default.

� The Verbosity (n) sets a trace level of intermediate output. The default is no intermediate output. If
n > 0, then the accuracy is printed after every n iterations.

) Obtain the steady-state solution for the instant-of-time variables of the faulty proc
model by selecting Solve->Iterative Steady State Solver within the con-
trol panel. Specify the Project Name and an Output File Name. It should only take
a few seconds to solve this model with iss. The results should be the same as was
given for dss.

The output file will contain the mean and variance of the performability variables. It will also

contain the following information:

� the number of iterations required for convergence,

� the maximum difference, which is the maximum difference (over all the states) between the solution in
the last two iterations.

Pitfalls and Hints

� The iss solver can be used for many models that arise in practice. A sufficient condition is the so-called
ergodicity of a Markov model. If the model contains one or more absorbing states iss cannot be applied.
It will give the message iss solver: zero on the diagonal and quit. To find out whether the
model has absorbing states apply the Flag Absorbing States option in the state space generator
Gen.

� The iss algorithm stops when the largest difference of the state probabilities between two iterations (at
that moment not yet normalized to sum to 1) is less than the specified error. This stopping criterion does
not directly relate to the error between the derived and the real state probabilities, let alone between
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the derived and the real performability variables. A value of 10�9 for the Accuracy will usually be
sufficient.

� As a rule of thumb, the additional time to get an n times as accurate result is of the order log
10
n. Hence,

increased accuracy tends to be not too costly. Of course, the machine accuracy can never be exceeded.

� first try iss with Weight equal to 1. This usually leads to quick solutions. A higher weight may de-
crease the number of iterations, however, an (even slightly) too high weight can dramatically increase
the necessary number of iterations. If iss does not converge for Weight equal to 1, try values lower than
1. Typically, taking Weight < 1 improves convergence while Weight > 1 decreases the number of
iterations if convergence is already assured. Note that the value of Weight should be chosen between
0 and 2.

� The iss solver usually derives results in a reasonable time. If the state space is large, more computation
is necessary per iteration, but the number of iterations is often relatively low. Therefore, in the begin-
ning, leave the default for the number of iterations as high as given. If iss does not converge within a
reasonable number of iterations, the accuracy may have been chosen too high for the machine. Be care-
ful with choosing an accuracy smaller than 10�10 (i.e., a value of 10 in the box Solve->Iterative

steady state solver->Accuracy). The progress in convergence of iss can be checked by using
the Verbosity option.

� Some models may require very many iterations. These are called stiff models, and important in the case
of iss is the class of nearly-decomposable models. They, for instance, occur when the performance of
a system quickly reaches steady-state for any system configuration, but in which changes in system
configurations take place very infrequently.

4.2.5 Deterministic Iterative Steady-State Solver

The deterministic iterative steady-state solver (diss) solves for instant of time variables with

t ! 1, using uniformization and successive over relaxation (SOR) [5]. diss should be used for

the steady-state solution when there is at least one deterministic activity in the model. Solution is re-

stricted to models in which there is at most one deterministic activity enabled in each process state.

Gen will detect states in which more than one deterministic activity is enabled. The solution algo-

rithm is similar to that used by iss, but uniformization is used to compensate for the deterministic

activities. The acceleration factor used must be selected by the user. diss calculates the mean, vari-

ance, probability density function, and probability distribution function of of each performability

variable. The means and variances are given in textual form in an output file, and the probability

density and distribution functions are given in splot format. When selected in the control panel, a

window like Figure 4.4 appears with the available options. The options are as follows:

� The Weight is a double precision float representing the acceleration factor. 1.0 is the default. A value of
1.0 reduces the SOR method to Gauss-Seidel. Values between 1.0 and 2.0 may accelerate convergence.
Values between 0.0 and 1.0 are less subject to divergence.

� The Max Iterations is an unsigned long representing the maximum number of iterations that will be
performed before terminating the solver. 300,000 is the default.



4-14 CHAPTER 4. SOLVERS

Figure 4.4: Control panel diss options.

� The Error Tolerance is a short integer representing a negative power of 10 (i.e. error tolerance) for
truncation of infinite series while calculating Poisson probabilities. 11 is the default value. Increasing
the error tolerance may increase the solution time. The solution time can be reduced if more error can
be tolerated.

� If Detect Steady State is selected, the solver detects the steady-state earlier than the right trunca-
tion point, if possible [5]. It can reduce the solution time, but the user should make sure that steady-state
is not falsely detected by comparing the results obtained with and without this option.

� If Save C matrix in file is selected, the solver saves rows of the C matrix in a file rather than
keeping them in memory. Saved rows are read back at appropriate times. This option should be used
when the solver complains about a shortage of memory while solving a big state-space.

� If Save P matrix in file is selected, the solver saves rows of the P matrix in a file rather than
keeping them in memory. Saved rows are read back at appropriate times. This option should be used
when the solver complains about a shortage of memory while solving a big state-space.

� The Verbosity (n) sets a trace level of intermediate output. The default is no intermediate output. If
n > 0, then the accuracy is printed after every n iterations.

The output file will contain the means and variances of the performability variables. It will also

contain the following information:

� The index of deterministic activity considered, which is an index into an internal data structure of the
deterministic activity that is being processed. The number itself is not useful, only the fact that progress
is being made.

� The left truncation point, which is the number of iterations below which uniformization does not collect
results.
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� The right truncation point is the number of iterations above which uniformization does not collect re-
sults.

� The number of iterations required for convergence.

� The maximum difference is the maximum difference between the cells in the pA and zero matrices,
which represents the error. The truncation error is not reported, but is bounded by the specified error
tolerance.

) Copy the faulty proc model to a model called faulty determ. Within the buffer sub-
model, change activity arrival to deterministic, and set its value to 0.01. Save the
submodel, and save the model in compedit and varedit, and regenerate the state space.

) Obtain the steady-state solution for the instant-of-time variables
of the faulty determ model by selecting Solve->Deterministic Iterative

Steady State Solver within the control panel. Specify the Project Name and an
Output File Name. You should also select Run in the Background, since it should
take around thirty minutes to solve this model with diss. The results should be as
follows:

Performability variable Mean Variance
probability non-blocking 4:535857e� 02 4:330117e� 02
utilization 8:448689e� 01 4:368852e� 02
number of tasks in queue 4:951837e+ 00 5:160808e� 02
number of tasks in system 1:127829e+ 01 6:320603e� 01
fraction of time in I O 1:511952e� 01 4:277844e� 02
number of tasks processed 5:322693e� 01 2:489587e� 01

Pitfalls and Hints

� The diss solver suffers from the fill-in problem, albeit to a lesser extent than the dss solver. For every
marking in which a deterministic activity is enabled, the transition probability to all the markings that
can be reached during the deterministic time are computed. Depending on the model, this gives con-
siderable fill in if a high percentage of the markings enable a deterministic activity. One example that
leads to high fill in is a single buffer with a deterministic server; the deterministic activity is enabled in
all markings which represent at least one job in the buffer. Consequently, considerable fill in will occur
in this case.

� The instant-of-time steady-state measure is not necessarily defined for models with deterministic ac-
tivities because periodic behavior may exist. The outcome of diss can in that case be interpreted as
the time-averaged interval-of-time steady-state measure. However, this is only valid when only rate re-
wards are considered (i.e., no measures with impulse reward are defined). Furthermore, the variance
and distribution which are derived do not have any meaning for the interval-of-time variables.

� diss can not solve for deterministic activities with a value for the delay that is marking dependent. If
the specified model contains a marking dependent deterministic activity, the obtained results should be
discarded.
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Figure 4.5: Control panel trs options.

4.2.6 Transient Solver

The transient solver (trs) solves for instant of time variables with t < 1, using randomiza-

tion (also known as uniformization). It calculates the mean, variance, probability density function,

and probability distribution function of each performability variable at particular time points. This

method is based on the idea of subordinating a Markov chain to a Poisson process. It is computation-

ally efficient, preserves matrix sparsity, and solves to user specified tolerances. Furthermore, both

computing state probabilities in the uniformized Markov chain and computing Poisson probabilities

can be done in a numerically stable manner. The means and variances are given in textual form in an

output file, and the probability density and distribution functions are given in splot format. When se-

lected in the control panel, a window like Figure 4.5 appears with the available options. The options

are as follows:

� The Time is a double precision float representing a time point of interest. There may be multiple times
separated by spaces, but at least one must be specified.

� The Verbosity (n) sets a trace level of intermediate output. The default is no intermediate output. If
n > 0, then an intermediate statement is printed after computation of every n columns of the power
transition matrix.

The output file will contain the means and variances of the performability variables. It will also

contain the following information:

� The rate of the Poisson process used to do the uniformization.

� The number of state with positive rewards.

� The number of time points.



4.2. ANALYTIC SOLVERS 4-17

� For each time point, the left truncation point, number of iterations and error. The probability that more
jumps occur in the Poisson process than number of iteration plus the probability that less jumps
occur than left truncation point is less than or equal to error.

) Obtain the transient solution for the instant-of-time variables of the faulty proc model
by selecting Solve->Transient Solver within the control panel. Specify the
Project Name and an Output File Name, and give the Time as “1 10 100”. It should
take around one minute to solve this model with trs. The results for time equal to 10
should be as follows:

Performability variable Mean Variance
probability non-blocking 4:522712e� 01 2:477220e� 01
utilization 8:438868e� 01 4:404171e� 02
number of tasks in queue 4:068240e+ 00 1:694523e+ 00
number of tasks in system 1:036334e+ 01 1:885129e+ 00
fraction of time in I O 1:507570e� 01 4:267070e� 02
number of tasks processed 3:119777e� 01 2:146476e� 01

The results for t = 100 are equal to the steady-state results, so steady- state behavior is
observed in this model within 100 time units.

Pitfalls and Hints

� The computation time of trs is primarily determined by the number of iterations. A simple rule of thumb
to estimate the number of iterations is to multiply the required time instant by the rate of the Poisson
process. The rate of the Poisson process is equal to the highest outgoing rate over all the states of the
Markov process (the outgoing rate of a state is given by the sum of all the exponential rates of transitions
out of the state). As a consequence the time-complexity of the algorithm increases linearly with t.

� From the previous item, it follows that trs will be more time consuming for models with high rates of
the exponential distribution relative to the time point of interest. A class of models having this kind of
stiffness can be found in reliability evaluation if repairs occur relatively fast and failures occur rarely.
The rate of the Poisson process will then be dictated by the fast repairs, but the time points of interest
are often of the order of the time between failures. For instance, for a system in which component
failures occur on the average ones every ten days and repairs take on the order of an hour, the interest
will typically be in the transient behavior over relatively long periods (e.g., the probability the system
is up at the end of the year).

� For large values of t the result becomes identical to the steady-state result, and will not change any
longer if t increases. Use the iss solver to detect when this occurs.

� At time t = 0 the SAN model is in the initial marking with probability 1. In UltraSAN it is not possible
to specify another initial distribution. To change the state at t = 0 alter the initial marking of places in
the SANs by applying Edit-> Subnet->Define to the different places.

4.2.7 Accumulated Reward Solver

The accumulated reward solver (ars) solves for transient interval of time variables, i.e., for inter-

vals [t0; t1] where both t0 and t1 are finite. It gives the expected accumulated reward, as well as the
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Figure 4.6: Control panel ars options.

expected time-averaged accumulated reward over the interval. The results are derived by uniformiza-

tion. When selected in the control panel, a window like Figure 4.6 appears with the available options.

The options are similar to the trs options, except that now an interval instead of an instant of time

must be specified.

� The Time Intervals denote couples of double precision floats separated by a colon representing a
time interval of interest. So, t0 : t1 would denote the interval [t0; t1]. There may be multiple intervals
separated by spaces, but at least one must be specified. Furthermore, if one desires an interval starting
from t0 = 0:0, one can either specify this as 0 : t1 or as t1.

The output file will contain the means, both time-averaged and accumulated, of the performabil-

ity variables. It will also contain the additional information similar to that given for the trs solver.

Pitfalls and Hints

� The ars solver is an extension of the trs solver and the remarks for trs apply here as well.

4.2.8 Probability Distribution Solver

The probability distribution solver (pdf) solves for interval of time and time averaged interval of

time variables with t < 1, using randomization (also known as uniformization). It calculates the

probability distribution function of each performability variable. The probability distribution func-

tion is given in splot format. When selected in the control panel, a window like Figure 4.7 appears

with the available options. The options are as follows:

� The Time is a double precision float representing the desired interval of observation. An interval must
be specified. No default is assumed.



4.2. ANALYTIC SOLVERS 4-19

) Obtain the accumulated reward solution for the interval-of-time variables of the
faulty proc model by selecting Solve->Accumulated Reward Solverwithin the
control panel. Specify the Project Name and an Output File Name, and give the
Time as “10 100 10:100”. It then computes the accumulated reward for the inter-
vals [0; 10]; [0; 100] and [10 : 100]. Note that the results for the interval [0; 100] has
to be the same as the sum of the results for the other two intervals. It takes around
two minutes to solve this model with ars. The results for time interval [0; 100], ac-
cumulated and time-averaged should be as follows:

Performability variable Accumulated Time-averaged
probability non-blocking 4:600592e+ 01 4:600592e� 01
utilization 8:414133e+ 01 8:414133e� 01
number of tasks in queue 4:021994e+ 02 4:021994e+ 00
number of tasks in system 1:028515e+ 03 1:028515e+ 01
fraction of time in I O 1:498986e+ 01 1:498986e� 01
number of tasks processed 4:496959e+ 02 4:496959e+ 00

Note that opposed to trs the time-averaged accumulated reward has not yet converged to the
steady-state results at t = 100. In other words, the time-averaged accumulated converges
slower to steady-state than the instant-of-time measures.

� Weight is a variable to instruct the solver to discard paths with conditional probabilities less than the
specified weight (e.g., if the weight equals 4, paths are discarded if the conditional probability is less
than 10�4). The default does not discard any paths.

� Lower Range is a double, which specifies the lower value for which the probability distribution is eval-
uated. No default is assumed.

� Upper Range is a double, which specifies the upper value for which the probability distribution is eval-
uated. No default is assumed.

� Points is an integer and specifies the number of points within the range. If the number is one, then the
probability distribution is evaluated only at the upper value. The default considers only two points, the
lower and upper values.

� Verbosity (n) sets a trace level of intermediate output. The default is no intermediate output. Ifn > 0,
then an intermediate statement is printed for every performance variable after every n transitions of the
subordinated Poisson process.

The output file will contain the values of the distribution at the selected points. It also contains

the following information:

� The number of expanded states is the number of states, including the added states needed to preserve
self-loops.

� The path truncation error is the error due to path truncation. This value can be changed by varying the
weight.

� The depth truncation error is the error due to depth truncation. This value can be changed by varying
the accuracy.

� The total error bound is the sum of the path truncation and depth truncation errors. The weight and
accuracy should be set, such that the two error sources are of the same order of magnitude.
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Figure 4.7: Control panel pdf options.

Pitfalls and Hints

� The pdf solver is hard to apply as it is both very time intensive and memory consuming. To apply the
pdf solver with reasonable success limit the use to small models or small time points. For more details,
see the paper of Qureshi and Sanders [2].

4.3 Simulators

Three simulators are provided in UltraSAN:

� Steady-state simulator (SSim) – for t!1.

� Terminating simulator (TSim) – for t <1.

� Importance-sampling terminating simulator (ITSim) – for importance sampling if t <1.

The programs perform discrete event simulation using a method that makes use of a dynamically

varying number of future events lists [4]. Confidence intervals are generated for the requested vari-

ables using the batch means method for steady-state simulation and the replication method for ter-

minating simulation [1].

Each simulator is executed by selecting its entry in the Solve menu of the control panel. When

this is done windows like Figure 4.8 and Figure 4.9 appear with the available options. The following

options are applicable to both simulators, although their actions may vary depending on which is

used.

� The Project Name must be specified. No default is assumed.



4.3. SIMULATORS 4-21

) We will now modify the faulty proc model, so that it can be used easily with pdf.
Copy the faulty proc model to a model called faulty forpdf. Within the processor
submodel, delete components done, I O, check done, and ready. Also take the line
changing place done out of gate correct. This just removes the I/O component of the
model. Resave the model in compedit, but this time specify the Number of replica-
tions as one. In varedit, specify just one variable called number of arriving tasks, and
give it an impulse reward of 1.0 on activity arrival.

) Obtain the transient solution for the interval-of-time variable by selecting Solve->

ProbabilityDistributionSolverwithin the control panel. Specify the Project
Name and an Output File Name. Specify the time as 0.1, the accuracy as 4, the weight
as 6, the upper range as 5, and the points as 6. It should only take a few seconds to
solve this model with pdf. The results should be as follows:

y = 0:000000e+ 00 perf = 3:678786e� 01
y = 1:000000e+ 00 perf = 7:357531e� 01
y = 2:000000e+ 00 perf = 9:196777e� 01
y = 3:000000e+ 00 perf = 9:809654e� 01
y = 4:000000e+ 00 perf = 9:962667e� 01
y = 5:000000e+ 00 perf = 9:994597e� 01

� If an Output File Name is given, the results are put in a file with the name expi.solver.filename,
for SSim and TSim respectively. This file is put in the project’s results directory. If no output file is given,
the output goes to standard out.

� If a Trace Level is given, the markings of the submodels and the lists of future events will be traced
during simulation. There are three trace levels. A trace level of one prints only the markings of each
submodel after activity completion. A trace level of two will also show the earliest event time for each
future events list plus the activities scheduled to complete in each list. A trace level of three will, fur-
thermore, show the potential completion times for each compound event in each future events list.

� If Batch/Rep Trace (n) is given, the current estimates for all variables are printed out everyn batches
or replications.

� If Variance Calc (n) is given, the confidence interval of a variance estimator is only calculated at
every n batches or replications. Jackknifing is used to calculate confidence intervals about variance
estimators, which can be quite computationally expensive.

� The Max Batch/Rep is the maximum number of batches or replications. The partial results will be
printed out if this number is reached. The default is 1000 batches in steady-state simulation and 100,000
replications in terminating simulation. Specifying 0 causes the number of batches/replications to be un-
limited. The simulators will run until all variables have been estimated within specified relative errors,
no matter how long it takes.

� The min Batch/Rep is the minimum number of batches or replications that should be executed. Confi-
dence intervals are compared to the requested relative width only after the minimum number of batches
or replications are executed. The default value is 4.

� If Run in the Background is selected, other control panel options can be used while the simulator
is running. An output file must be given in this mode.

� If Don't Print Place Names is selected, the simulator turns off the printing of place names next to
their markings. The markings are still printed in the ASCII order of the associated place names.
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Figure 4.8: Control panel SSim options.

Figure 4.9: Control panel TSim options.
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� If Wide Output Screen is selected, the simulator assumes a wider output screen. The default screen
width is 80 columns. This option adds 30 columns to that width.

) Obtain the steady-state simulation results for the variables of the faulty proc model
by selecting Solve->Steady State Simulatorwithin the control panel. Specify
the Project Name and an Output File Name. Also specify Batch/Rep Trace as 10 and
Variance Calc as 10. It should only take around a minute to solve this model with
SSim. The results should be as follows:

Performability variable Mean Variance
probability non-blocking 4:551306e� 01 2:479906e� 01
utilization 8:447065e� 01 4:417886e� 02
number of tasks in queue 4:060285e+ 00 1:714063e+ 00
number of tasks in system 1:034938e+ 01 1:905456e+ 00
fraction of time in I O 1:498543e� 01 4:274883e� 02
number of tasks processed 3:075447e� 01 2:129670e� 01

processor : I O 2:214705e� 01 8:278872e� 02
processor : processing 3:956595e� 01 1:231333e� 01

The following is a typical batch output:

Variable Name : utilization
Batch Number : 10
Simulation Time : 1:100000e + 04
Time (CPU seconds) : 41
Batch Mean : 8:467695e � 01
Mean : 8:447065e � 01 + =� 1:516121e � 03
Variance : 4:417886e � 02 + =� 5:035103e � 04

The Batch Mean is the mean for this batch. The Mean and Variance are the current mean and variance

estimates. You can track the progress of the simulation by comparing the values of the Mean and

Variance to their half-width, which is given after the +=�. When every half-width is less than the

relative confidence interval (specified in varedit) multiplied by the Mean/Variance for each variable,

the simulation is done.

The output file will contain the means and variances of the performability variables. It will also

contain the system, user, and total computation time, which were described in the solver section. It

will also contain the final simulation time, indicating the simulation time at which all batches were

complete.

The following is a typical replication output:

Variable Name : utilization
Replication Number : 2400
Simulation Time : 1:000000e + 02
Time (CPU seconds) : 1498
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) Consider the number of tasks in system at time 50.0 and 100.0, by adding two vari-
ables called number of tasks in system t50 and number of tasks in system t100. Define
them the same way as before, but give the Instant of time the corresponding value.
This is a way to look at multiple times within one simulation run.

) Obtain the transient simulation results for the variables of the faulty proc model by
selecting Solve->Terminating Simulator within the control panel. Specify the
Project Name and an Output File Name. Also specify Batch/Rep Trace as 100 and
Variance Calc as 100. You should also select Run in the Background, since it should
take around thirty minutes to solve this model with TSim. The results should be as
follows:

Performability variable Mean Variance
probability non-blocking 4:629167e� 01 2:487285e� 01
utilization 8:466667e� 01 4:196934e� 02
number of tasks in queue 4:051250e+ 00 1:724342e+ 00
number of tasks in system t50 1:036792e+ 01 1:864164e+ 00
number of tasks in system t100 1:034125e+ 01 1:864742e+ 00
fraction of time in I O 1:473611e� 01 4:121854e� 02
number of tasks processed 4:500079e+ 02 6:003021e+ 02

processor : I O 2:274973e+ 01 6:544460e+ 00
processor : processing 3:978761e+ 01 1:159418e+ 01

Current Value : 1:000000e + 00
Mean : 8:466667e � 01 + =� 8:196275e � 03
Sample Variance : 4:196934e � 02
Variance : 4:196934e � 02 + =� 2:588252e � 03

The Current Value is the value of the variable at the end of the replication. The Sample Variance is

the variance for all replications performed thus far. The Mean and Variance are the current mean and

variance estimations. You can track the progress of the simulation by comparing the values of the

mean and variance to their half-width, which is given after the +=�. When each half-width is less

than the relative confidence interval (specified in varedit) multiplied by the mean/variance for each

variable, the simulation is done.

The output file will contain the means and variances of the performability variables. It will also

contain the system, user, and total computation time, which were described in the solver section.

It will also contain the number of replications, indicating how many replications were needed to

achieve the requested confidence intervals.

Pitfalls and Hints

� The batch size in SSim has to be large enough to assure sufficient independence of the batches. Further-
more, the number of batches should not be too low in order to compute the confidence interval correctly.
Simulate for at least 30 batches, and compare the confidence intervals for different batch sizes. For in-
stance, compare the confidence interval of 100 batches with a certain length with 50 batches of twice
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that length. Notice that the size and the number of batches never influences the results of the simulation,
only the confidence interval.

� To get a feeling for how long the simulation will take, monitor the width of the confidence interval
by setting the Trace option. As a rule of thumb, if the confidence interval width is monitored after k
batches or replications, the simulation will take kn2 additional batches or replications to decrease the
width of the confidence interval with a factor n.

� If the terminating simulator TSim is used for estimating small probabilities the simulation might take
excessively long. Investigate in that case the applicability of the importance sampling simulator ITSim.
ITSim is discussed separately in Chapter 6.
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Chapter 5

Graphs and Tables with the Report
Generator

UltraSAN is equipped with a module called report generator which is used to generate graphs and

tables of the results obtained. Both 2-D (using splot and gnuplot) and 3-D graphs (using gnuplot)

as well as tables (LATEX and ASCII) can be generated with the report generator, displaying perfor-

mance variables computed with the solvers as functions of the global variables. The report generator

therefore provides a very flexible way of documenting output results.

UltraSAN also provides other documentation possibilities besides the report generator. The

Project->Documentoption is used to document all the SAN models, the composed model, the per-

formance variables and the range and set definitions for all the studies and experiments defined for

a given project. The output of the solvers is provided in the form of ASCII files and the distribution

of performance variables are provided in the form of splot-files. Further, the General->Display

option can be used to view and print the above files. See Chapter 3 for a detailed discussion of the

other documenting features.

This chapter explains how to use the report generator. It is organized as sections, with each sec-

tion describing the following: (1) Creating a graph using output from one solver, (2) Creating a table

using output from one solver, (3) Using data from different solvers and creating a graph or table, and

(4) Saving and loading graphs and tables.

5.1 Creating a Graph

This section describes how to create a single graph using the faulty multi-processor as an exam-

ple. Invoke the Report Generator of Figure 5.1 by selecting General->Report Generator and

follow these steps:

1. Choose the Report Style 3-D, 3-D projection on 2-D, or 2-D. For our example, select 3-D

Graph.

5-1
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Figure 5.1: Report generator.

Figure 5.2: Graph definition window.

2. Choose the Package gnuplot or splot for graphs. Click on gnuplot and Edit to create the

first graph. This causes the Graph window as in Figure 5.2 to appear. Note that 3-D plots can

be generated only with gnuplot.

3. Enter the global and performance variables on the Axis by selecting Axis. This produces

the window Axis Type. Note that this window will be blank when opened for the first time.

Select the axis of your choice. Next choose the desired global variable or performance variable

from the list in the Global Variable Selector or Performance Variable Selector,

respectively. In Figure 5.2, the global variables num processors and arr rate form the X

and Y-axis and the performance variable number of tasks in queue is plotted on the Z-

axis.

4. Determine the Default Source, i.e., the solver for which the results are to be plotted. Select

Default Source in the Graph window, and choose Iterative Steady State Solver
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Figure 5.3: Solver selection window.

(iss) for the current example. The Data Source Selector of Figure 5.3 pops up, and ap-

pears blank when invoked for the first time.

5. Choose the study and experiments to be incorporated in the plot. Select Add in the Data

Source Selector window followed by selecting the desired study. In our example, we se-

lect vary arr and processors. Next select Select Exp., which pops up the Experiment

Selector window. Select All will use all the available data in the plots. Return to the

Report generator window by selecting a series of Accepts. In the process the Data

Source Selector and the Graphwindow will display the chosen experiments and variables,

as depicted in Figure 5.2 and 5.3. Finally, select View followed by OK to view the resulting fig-

ure as in Figure 5.4.

5.2 Creating a Table

The following procedure should be used to create a table with data collected by the solvers. Se-

lect Report Style Table from the Report Generator window and Package LATEX or ASCII

Table. A LATEX table will be created in this example. The ASCII table is especially useful as input

for a user’s own preferred plot or spreadsheet program. Choose Edit to start the table specification.

The Table window in Figure 5.5 appears. The table presents sources (solvers) versus variables.

The sources can be chosen to be either on the top (Source on column) or on the left side (Source

on row) of the table. We choose Source on column. Choose Select Source to pick the de-

sired solver from the Table Sourcewindow of Figure 5.6. Upon selecting the Iterative Steady

State Solver and clicking Accept, the Data Source Selector window of Figure 5.3 appears

in our example. The procedure after this step is identical to that described in Section 5.1.
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Figure 5.4: A 3D graph.

Figure 5.5: Table definition window.
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Figure 5.6: Selection of the solver.

Figure 5.7: The selected variables.
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Figure 5.8: Selection of variables.

Source vary arr and processors-Exp1
G-num processors 1.000000
G-arr rate 5.000000
P-number of tasks in queue 4.490981

Table 5.1: Table for Experiment 1

Having chosen the desired experiments and solvers, a series of Accept results in the Table

window of Figure 5.5. Choose Select Variable to select the desired global and performance

variables. Next, select Add in the Table Variable Selection window of Figure 5.7. Then,

choose Global Variable or Performance Variable and Select Var in the Table Specifier

Selector. Highlight the desired variable in the Table Variable Selector window of Figure

5.8. In the example, results for the performance variable number of tasks in queuewill appear in

the table. Note that the selection of a variable results in the removal of the variable from the list in the

Table Variable Selector. To delete a chosen variable select Delete in the Time Variable

Selection window.

Finally, select Accept in the Table Variable Selection window if the displayed variables

are correct. The global variables num processors and arr rate and the performance variable

number of tasks in queue appear in the table, as shown in Figure 5.7. The table can be viewed

by selecting View in the Report Generator window of Figure 5.1. Table 5.1 shows the table cre-

ated for the first experiment in this example.
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Figure 5.9: Change the solver.

5.3 Different Solvers in a Single Graph or Table

The report generator also makes it possible to plot in a single graph data obtained from different

solvers. This will be important if simulation and analytic methods both have been used for different

experiments.

In the report generator one solver is considered the default source. For newly selected experi-

ments, the results will be taken from the output of the default solver. In the Data Source Selector

(Figure 5.3) the default source can be substituted by another source. To do this, select the experiment

which has to be changed and choose Change, leading to the Change Source window of Figure 5.9.

Choose a new source from the highlighted solvers. Notice that steady-state and transient solvers can

only substitute a solver within their own category. If Change Previous is chosen, the previously

selected experiments will take their results from the chosen solver. If Change Default is chosen,

all the future sources will assume the new default solver.

There is a second way to combine results from different solvers in one graph or table. Change the

default source, either in the Change Sourcewindow of Figure 5.9 or in the Graphwindow in Figure

5.2. Then Delete the experiments to be changed in the Data Source Selector. Select Add and

add the experiments, automatically taking data from the new default source. Use Info which high-

lights the parameters associated with an experiment, to check which experiments have been chosen.

Finally, note that the tool does not allow for displaying results from two different solvers for the

same experiment. To have these results in a single graph separate experiments have to be defined. On

the other hand, it is possible to have results from different studies in a single table or graph by choos-

ing Add in the Data Source Selector and choosing the desired study in the Study Selector.
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5.4 Save and Load Graphs and Tables

The Import and Export buttons can be used to open and save plots created in the report gener-

ator. To save the graph or table in a file, click Export in the Report Generator window in Figure

5.1 and define a file name. The graph or table as well as all the editing information from the report

generator is loaded in the specified file. To load the graph or table click Import and Open the desired

file. Because all the report generator information is now available the graph or table can easily be

adjusted in the report generator.

There is a second way to save graphs or tables. IfAccept is chosen from the Report Generator

window it acts as if Export is chosen. The saved graph or table can be opened again by the Import

option as described above.

5.5 Hints

� For 3-D plots it is usually best to put global variables on the X- and Y-axis and a performance
variable on the Z-axis. However, it is possible to take other settings in the report generator.

� To start a new graph or table with a clean report generator, click Abort in the Report

Generator window and restart the report generator by General->Report Generator. Of
course, it is also possible to create a new graph without exiting the report generator. However,
earlier selected study, experiments, and solvers will then remain valid which implies that these
have to be deleted separately from the Data Source Selectorwindow if they are no longer
required.

� Note that graphs and tables from transient results for different time points cannot be generated
directly in the current report generator if these results are all generated as the output of a single
experiment. For the transient solvers the report generator will take the data belonging with
the first specified time point or interval. Note that these results can be incorporated in a single
graph or table if they are obtained in different experiments.

� Intermediate files and generated postscript plot representations can be found in the directory
projects/faulty proc/int. These files can be used for advanced use of gnuplot and LATEX
or for use of one’s own plot or spreadsheet program. Especially useful in this regard is the
ASCII table output which can serve as input for most spreadsheets.



Chapter 6

Importance Sampling

In this chapter we discuss importance sampling (IS), a technique that in some cases can increase the

speed of a simulation. Because the application of IS in UltraSAN demands particular actions not

necessary if you use the other solvers, IS is discussed in much more detail in this chapter. To apply

IS UltraSAN is equipped with an IS Governor editor to be found under Edit->IS Governor. An

informal description of IS will be followed by instructions on how to use the IS governor. A more

rigorous treatment of the technique can be found in Obal and Sanders [1, 2].

6.1 Introduction to Importance Sampling

Direct simulation of a model can in some cases lead to excessively long simulation times. Al-

though in general the UltraSAN simulators will turn out to be particularly efficient (using efficient

event scheduling mechanisms as reported in [3]) some problems inherently take much CPU time.

The most prominent case one is likely to encounter when evaluating the performance of a system

is the problem of rare events. This problem occurs when one tries to obtain a reliable estimate of a

very small probability. For example, think of a system’s unreliability if it is of the order 10�6, or the

blocking probability of a buffer if it is of the order 10�9.

The basic problem in rare event simulation is that the event of interest occurs so rarely that it takes

many runs before the event passes by and to obtain a reliable estimate many of these events must have

taken place, thus asking for long simulations. To illustrate the potential problem compute the unreli-

ability U of a system at instant of time t (reliability at time t is the probability the system has not been

down in the interval [0; t]). Model the system in UltraSAN and apply the Terminating Simulator.

This would result in creating N independent simulation runs (replications) of the model, every run

keeping track whether the system is down or up at moment t. Some straightforward mathematics

will then reveal that it will take on the order of 100

U
runs to be 95% percent certain that the actual

answer is within 10% of the simulation outcome. So, if U = 10�6, it demands for 100; 000; 000

replications, and if U = 10�9, it grows to 100; 000; 000; 000 replications.

6-1
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The idea behind IS is to increase the number of times the rare event occurs in the simulation. For

instance, one might increase the failure rate of components in a model of a highly-reliable system.

IS creates a biased model, and in UltraSAN an IS Governor is used to specify the biasing scheme.

Of course, when simulating the biased model, one introduces an error in the outcome. Therefore

part of IS is to correct for this introduced error by computing the so-called likelihood ratio, which is

the ratio of the probability that a certain system evolution occurs in the new model and the probabil-

ity that the same evolution would have taken place in the old model. The IS component in UltraSAN

automatically computes this likelihood ratio for the specified biasing scheme and corrects the IS sim-

ulation result accordingly. In other words, after the user has specified the IS Governor, the tool takes

care to obtain the correct answer.

In successful biasing schemes, often the introduced bias is dependent on the evolution of the

simulation run. In the IS Governor it therefore is not only possible to specify bias on activities and

cases, but also to let the bias change depending on the evolution of the simulation run. In other words,

there is interaction between the simulation execution of the SAN model and the IS Governor. In this

way a highly flexible mechanism is created for specifying IS biasing schemes.

6.2 IS Governor

The IS governor supplies the following basic features:

� the definition of governor states,1

– for every governor state, one can define a bias for any activity (provided the activity time

distribution is either exponential, uniform, Weibull, triangular, or hyper-exponential) and

for any case probability.

� the definition of governor-transitions between governor-states,

– for every governor-transition one can define a predicate determining when the transition

between governor states will take place.

Furthermore, new global variables can be introduced in the IS governor (and earlier introduced ones

can of course still be used).

We will discuss the mechanics of the IS governor by adapting the example of the multi-processor

in the paper on UltraSAN Version 3.0 [4]. In Figure 6.1 we show one submodel, the model of the

CPU for which activities will be biased in the following discussion. We use the multi-processor ex-

ample because the “rare event” problem is not present in the running example of the faulty micropro-

cessor. However, a detailed discussion of the complete multi-processor model would consume too

1On purpose we use in this place the adjective governor for states and transitions to distinguish it from states and tran-
sitions in a stochastic process. In the rest of this chapter, however, we will simply use the short terms state and transition.



6.2. IS GOVERNOR 6-3

Figure 6.1: SAN model of the CPU in a multi-processor model.

much space, so we refer to [4] for details. Basically, the rare event problem in the multi-processor

model is caused by the high reliability of the system, and the biasing strategies aim at speeding up

the occurrences of failures, similar to the ideas discussed above.

Building the IS Governor

Open the IS governor editor by opening Edit -> IS Governor. The Importance

Sampling Governor Editor window that then appears is given in Figure 6.2. In this window one

can Add and Delete states in the governor, specify the states by Edit State, and specify transitions

between governor states by Edit Trans. Funct.

After Add-ing a state, do Edit State, resulting in the IS Governor State Specification

window as given in Figure 6.3 and then highlight the activity to be biased. It is important to ver-

ify in which submodel the activity is located which one wants to bias. If the desired activity is not

listed, go to another submodel by Next or Prev Submodel. Select Add/Edit Bias for an activity,

and the Timed Activity Editor window pops up, as in Figure 6.4. There the parameters of the

distributions can be biased, as well as the case probabilities. One can choose any of the displayed

distributions. If the Timed Activity Editor is opened for the first time, the parameter definitions

of the original model will appear.

Figure 6.4 shows part of a relatively complicated expression for the rate of an exponential dis-
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Figure 6.2: IS Governor Editor

Figure 6.3: IS Governor state specification editor.
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Figure 6.4: IS Governor timed activity biasing editor.

tribution. For the full expression see [4]. The idea behind it is to speed up the failures in such a way

that all different failures in this complicated model become equally likely (a strategy called balanced

failure biasing). To that end the case probabilities are all made equal. Figure 6.4 shows the biased

probability 1=3 for case 1, out of the three belonging with activity cpu failure in Figure 6.1. Note

that the next case can be selected by clicking the rotating arrows. Click Accept to let the new bias

take effect.

In the IS Governor State Specificationwindow reached after doing Accept in the Timed

Activity Editor window another activity to bias can be chosen, possibly in another submodel.

Clicking Accept in the IS Governor State Specification returns to the Importance

Sampling Governor Editor, where the previously defined bias belongs with the highlighted gov-

ernor state (Approximate Forcing in Figure 6.2). For the other states follow the same procedure.

The state Unbiased for instance would correspond to no biasing at all (see [4]).

During the simulation, changes in the SAN markings can trigger transitions between the governor-

states. It is important to note that the biasing scheme selected to start with (i.e., at time t = 0) is

the upper state in the window IS Governor State Specification. To define when the state

changes in the governor take place, highlight one of the states and do Edit Trans. Funct. The

IS Governor Transition Function Specificationwindow pops up (see Figure 6.5) denot-

ing which governor state is chosen. First, select a next state, then define a Predicate

Specification for the given Submodel. Choose the submodel belonging with the places the gov-

ernor transition depends on. Repeat the procedure for all desired submodels. The total predicate

specification is only true if the predicates for all submodels are true. Because it is important to pre-
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Figure 6.5: IS governor transitions editor

cisely understand the working of the governor transitions, the following rules are listed:

1. Transition predicates must be expressions. No semicolons or return statements are allowed.

2. Global variables may be used in transition predicates.

3. If a predicate is defined on a SAN that is replicated in the composed model, then the predicate is true
if it holds for at least one replicate.

4. All predicates must hold for a transition to be taken. When the transition is taken, the governor changes
to the specified state. If predicates are only defined for a subset of the SANs in the composed model,
the nil (unspecified) predicates are treated as always true.

5. If there are several transitions from one state to another governor-state, the new state will be reached if
for any of the transitions all predicates hold.

6. A governor is not well-specified if there is more than one transition that holds and they do not all point to
the same next state. (An ill-specified governor is not detected by the tool. Basically, the implementation
follows an “if-then-else” construction; the first transition that holds will be chosen, with the transitions
ordered in the order they are specified by the user.)

To add or change transitions in the IS Governor Transition Function Specification

window, take some extra care. There is no separate Edit window and consequently the method for

adding or changing transitions is slightly different from most other editors.

To add transitions between states, you should follow these steps:

1. Click on the destination state in the top window.
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2. Click in the bottom window.

3. Type the predicate for the displayed SAN.

4. Push the Next Submodel button.

5. Repeat last two steps for each SAN you want to define a predicate on.

6. Press Add Trans button.

7. Browse your transitions from the current state using the Next Trans and Prev Trans buttons.

8. Press the Accept button to save your changes, or Abort to exit with no changes.

To change transitions, the steps are a bit different:

1. Scroll to the transition you want to change using the Prev Trans and Next Trans buttons.

2. Scroll to the predicate you want to change using the Prev and Next Submodel buttons.

3. Edit the predicate like you would a gate predicate.

4. Press the Next Submodel button.

5. Press the Add Trans button.

6. Scroll through the transitions. The transition you changed is visible in both the old and new form. If
the new form is preferred, scroll to the old one and press the Del Trans button.

7. Press Accept to save your changes, press Abort to abandon the changes.

6.3 Starting the IS Terminating Simulator

Having specified the governor, and assigned parameter values to the global variables in the Study

editor, the final step is to run Solve->IS Terminating Simulator. The pop-up window is

identical as the other simulators, as is the output on the Control Panel or output file.

6.4 Pitfalls and Hints

Successful application of importance sampling is, in general, a difficult matter. One can only

expect to be able to define a working governor if one has a thorough understanding of the original

model and its dynamics. Creating a successful governor is an art in itself. The following remarks

should be considered when using the IS governor.

� Although IS can result in dramatic variance reduction, it can result in exploding variance if an incor-
rect biasing scheme is defined. This is especially important since the tool might not catch the variance
increase, simply because the confidence interval is also based on an estimator (obtained from the sim-
ulation), and can therefore be incorrect. Always check the strategy for simple models with analytic
results.
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� Study the available literature in detail before applying importance sampling. The literature provides
biasing schemes with proven variance reduction properties and, equally important, provides useful
heuristics for the definition of a governor. See [2] for a literature overview.

� In the scientific literature, importance sampling has been applied to solve the rare event problem and
success is most likely when dealing with this problem. The application of importance sampling to speed
up other time consuming simulations has not been developed.

� Activities in IS simulations are reactivated according to the activation and reactivation predicates in the
original model. However, an activity will also be reactivated when a governor state transition results in
a different activity time distribution or in the same distribution with different parameters.

� Make sure all possible evolutions of the original model are still possible in the biased model and vice
versa, otherwise the biasing scheme might be incorrect2. The tool will only be able to detect an in-
correctly specified governor if the IS simulation reveals a path that has likelihood 0 of occurring in the
original model.

� Note that the definition of the desired accuracy and the time point of interest still has to be carried out in
Edit Stats in Edit->Performability Variables, while the limits on the number of replications,
etc, is done in Solve ->IS Terminating Simulator.
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Appendix A

Installation

This appendix gives the installation steps of UltraSAN for the system administrator and the environ-

ment setup for users of the tool.

A.1 Installation

The received package consists of a set of compressed tar files. These files and their approximate

sizes are:

� usan.v3.0.demos.tar.Z – demo files (approximately 3 MB)

� usan.v3.0.execs.HP800.tar.Z – executables for the HP800 architecture (approximately
6.5 MB)

� usan.v3.0.execs.MIPSEL.tar.Z – executables for the DECstation architecture (approxi-
mately 6.5 MB)

� usan.v3.0.execs.RS6000.tar.Z – executables for the RS/6000 architecture (approxi-
mately 6.5 MB)

� usan.v3.0.execs.SUN4.tar.Z – executables for the SUN/4 architecture (approximately
6.5 MB)

� usan.v3.0.general.tar.Z – general files (approximately 66 K)

� usan.v3.0.tar.Z – entire package for all architectures (approximately 29.5 MB)

The last file is the combination of the rest of the files. You can either install using this file, or if you

will only be using one architecture, and disk space is short, you can install using the general, the

demos, and the appropriate execs tar files. The present release of UltraSAN supports the HP, DEC-

station, RS/6000, and SUN/4 architectures. All software components related to these architectures

are labeled HP800, MIPSEL, RS6000 and SUN4, respectively.

Given just one requested architecture, the compressed tar files will take approximately 6.5 MB of

disk space, but an additional 16 MB should be available for the expanded UltraSAN tree. UltraSAN

A-1
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will run on many different system configurations, although a minimum of 16 MB of RAM is needed.

The graphical interfaces run within the X Window System1.

Follow these steps to install UltraSAN:

1. Choose a directory in which to install the UltraSAN tree, and make sure there is no entry called

usan.v3.0. This directory will hereafter be called the installation directory. Change the cur-

rent directory to the installation directory.

2. Uncompress and untar the UltraSAN tree as follows. If you are using the file usan.v3.0.

tar.Z, execute the command:

zcat usan.v3.0.tar.Z j tar xvf –

and skip to step 5. If you have the separated files, execute the command:

zcat usan.v3.0.general.tar.Z j tar xvf –

Details of the zcat and tar commands can be found in their respective man pages. This will

create a usan.v3.0 directory with more directories beneath it and some general files. Files

and directories are created relative to the current working directory, so it is imperative that all

tars be done from the installation directory.

3. If you only want to install UltraSAN for a specific architecture, uncompress and untar usan.

v3.0.execs.ARCH.tar.Z the same way, where ARCH is the desired architecture. This will

put the executables into the appropriate directories.

4. Uncompress and untar usan.v3.0.demos.tar.Z the same way. This installs a set of demo

projects. Demo installation is optional but is recommended for new users.

5. Make a symbolic link in the installation directory called usan with the following command:

ln -s usan.v3.0 usan

This will allow new versions to be installed without the users having to change their environ-

ment variables.

After installation, the file structure seen in Figure A.1 should be present. The directory usan.v3.0

was created along with six subdirectories. The purpose for each of these directories is as follows:

� The bin/ARCH directories contain the executables for each of the modules.

� The demo directory contains a set of sample projects, which will be explained later in this ap-

pendix.

� The include and lib/ARCH directories contain header files and libraries respectively, used

by the performability variable editor when generating the model executables.

1X Window System is a trademark of the Massachusetts Institute of Technology.
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Figure A.1: File structure of the UltraSAN tree.

� The man directory contains the manual pages for the different modules of UltraSAN.

� The setup/ARCH directory contains four subdirectories for the four architectures (HP800,

MIPSEL, RS6000 and SUN4). Each of the these subdirectories contain two files: compile.

def and local.def. The compile.def file specifies the compiler to be used and contains

the flags used by UltraSAN when compiling. These flags and the specified compiler should be

checked for compatibility with your system, although no changes will probably be required.

The local.def file has information about the shell variable, the documenting, viewing and

plotting packages used.

To use the automatic documentation and viewing facility in UltraSAN, LATEX ghostview and

gnuplot and/or splot are required. If you do not have them, they can be obtained by anony-

mous FTP. Next, even if you do have LATEX you will need to obtain two style files needed by

UltraSAN: USANieee.sty and USANpsfig.sty. These files must be put somewhere where

LATEX can find them. This can be either the directory where LATEX will be executed, or some-

where public, such as /usr/local/tex/macros. Ghostview is used to preview documents before

printing while gnuplot and splot may be used to generate graphs.

A.2 Environment Setup for UltraSAN users

Before running UltraSAN, a few changes must be made to your UNIX environment. All Ultra-

SAN executables are located in usan/bin/ARCH, where usan is the symbolic link to the UltraSAN

tree that was created during installation, and ARCH is the architecture that you are using. This direc-

tory should be added to your path. Also, usan/man should be added to your manpath, so that the

manual pages can be consulted. Three additional environment variables must be set. CPU must be

set to either HP800, MIPSEL, RS6000, or SUN4. USAN must be set to the path of the top of the

UltraSAN tree (installation directory). Also, a directory must be created within the user’s file space,
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where all project files will be put. This directory can have any name, although projects is a com-

mon choice. USAN PROJECT must then be set to the full path of this directory. Different project

directories may be created, but UltraSAN will only search for projects in the directory specified by

the USAN PROJECT environment variable.

All of these assignments can be done in your .cshrc file (assuming use of C shell). This is a

file in your home directory that is executed for every shell that is started. Here is an example of lines

that could be added to someone’s .cshrc.

setenv PATH “$PATH :/tools/usan/bin/SUN4”

setenv MANPATH “$MANPATH :/tools/usan/man”

setenv CPU SUN4

setenv USAN /tools/usan

setenv USAN PROJECT /usr/jack/projects

After changing the .cshrc, it must be executed so that the new variables are set for the current shell.

The command to do this is:

source $HOME/.cshrc

This is done automatically for all new shells.

A.3 Demo projects

There are a set of sample projects within the UltraSAN tree with which the user can and should

experiment. They are in the $USAN/demo directory. To use a demo, the entire project tree should be

copied into the user’s own project directory. This can be done with:

cp -rp $USAN/demo/proj name $USAN PROJECT

The copied project can then be used with the tool the same way as a user’s own projects. Sub-

sequent chapters will step through the description and solution of the faulty proc demo. You can

either build the project from scratch or copy this demo into your project directory.

Below is a list of the currently available demos with the references to the papers in which they

are mentioned.

� database a – database availability model [1]

� faulty proc – faulty microprocessor model [2] (also used as the running example in this man-
ual)

� lan – local area network model [3]

� multi proc – multi-processor model [1]
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Appendix B

Tool Organization and File Structure

This appendix gives the internal organization of UltraSAN and its file structure. A knowledge of the

organization and file structure can be helpful in understanding error messages and can also provide

insight about the operation of the tool.

The components of UltraSAN can be divided into four categories: model specification, global

variable assignment, study construction and study solution. Figure B.1 shows all the components

and their interdependencies.

The rectangles in this figure represent executable programs that are accessed from the CP, per-

forming specific modeling functions. They can be run directly from the command line prompt or

from the CP. The ovals represent data files used as intermediate communication between the pro-

grams. Both rectangles and ovals are dotted if they are created during modeling, and solid if they are

static, i.e., used but not created or destroyed during modeling.

Figure B.2 gives the directory structure for a typical modeling project. The int subdirec-

tory holds a description of the composed model in the files proj.h, Gen.c,SSim.c,TSim.c and

ITSim.c. The file proj.h specifies the structure of the composed model, and the various .c files

comprise the initial routines of the resulting model construction and solution programs. The internal

description of the specified performability variables is contained in the files proj.ve, projvar.c,

projvar.h, proj.ssim, and proj.tsim.

The graphical description of the composed model is stored in the file proj at the top level.

The subnets subdirectory contains a subdirectory for each subnet in the composed model labeled

subnet1 through subnetN. The .h, .c and communication files for the SAN associated with each

subnet are placed in the corresponding subnet subdirectory.

Information regarding studies is stored in the studies subdirectory, which has a subdirectory

for each study. Each study subdirectory in turn has a subdirectory for every experiment associ-

ated with it. The particular values assigned to each global variable in an experiment are stored in

experiment.h in the int subdirectory for the experiment in consideration. The ARCH (HP800,

MIPSEL, RS6000 or SUN4) subdirectory within bin for each experiment contains the executables

B-1



B-2 APPENDIX B. TOOL ORGANIZATION AND FILE STRUCTURE

SAN
Editor

Composed
Model
Editor

IS
Governor

Editor

Composed Model
Description Variable

Description

Performability
SAN

Description
SAN

Description. . . .SAN
Description

Reduced
Base Model
Generator

Reduced Base
      Model

Study
Editor

. . . .

. . . .

. . . .

. . . .

Reduced Base Generation
                  by
         Control Panel

Model Specification

Global Variable Assignment

Study Construction

Study Solution

Terminating
Simulator

Reduced Base Model
           Library

Simulator Generation
             by
      Control Panel

Study 1 Study 2 Study N

Experiment 1 Experiment 2

Simulator
Steady−State

Direct

Solver
Steady−State

Iterative

Solver
Steady−State

Deterministic Iterative

Solver
Steady−State

Solver

Transient
Instant−of−time Interval−of−time

Solver

Simulation
Libraries

IS Terminating
Simulator

Performability
Variable

Editor

Governor
Description

IS

Experiment M

Interval−of−time
Solver

ExpectedPDF

Figure B.1: Organization and data flow of UltraSAN version three



B-3

proj
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associated with it, namely Gen, SSim or TSim, depending on the solution method employed. If

the method of solution is analysis, the following additional files, namely, exp.rbm, exp.var and

exp.det are created and stored in the int subdirectory for each experiment, and the model is solved

by executing a particular analytic solver on it. Results of the solution are stored in a separate results

directory for each study.



Appendix C

Output File Formats of the Reduced
Base Model Generator

This appendix gives the format of the exp.rbm,exp.var and exp.detfiles that are generated while

using analytic solvers. An understanding of these files may prove helpful while debugging SAN

models, and can also be used to link to one’s own solvers.

If the intended solution method is analysis, a state-level representation known as reduced base

model must be generated using the reduced base model constructor for each experiment, before an

analytic solver is used. The reduced base model is held in the files exp.rbm, exp.var and exp.det

which are stored in the int subdirectory for each experiment.

The exp.rbm file contains details about the total number of states, the connectivity between

states and their rates (if all activities are exponential) or probabilities (if deterministic activities are

used). The format and contents of this file are as follows, with each enumerated item appearing on

a new line starting from line No. 1 in the exp.rbm file:

1. A 1 in line 1.

2. The total number of states in the model under consideration.

3. State number of current state.

4. The next possible state.

5. The rate from the current state to the state specified in item 4, if the associated activity is ex-

ponential. If it is deterministic, a minus sign precedes the number in this line and should be

interpreted as follows: The absolute value of the number in this line now gives the conditional

probability given that the deterministic activity completes, of going from the current state to

the state specified in item 4. The time of the deterministic activity is stored the exp.det file

(see below).
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6. Items 4 and 5 (each on a separate line) for all possible next states and rates from the state in

item 3.

7. A 0 to mark the end of the possibilities from the state in item 3.

8. Items 3 through 7 for all states in the model.

The exp.varfile contains information about the performance variables and the rewards (rate and

impulse) for all the states. The format and contents of this file are as follows, with each enumerated

item appearing on a separate line, beginning from line No.1.

1. Name of performance variable as it appears in varedit, one per line for each performance vari-

able defined in the model.

2. State number.

3. Impulse reward for performance variable when in the state specified in item 2.

4. Rate reward for performance variable when in the state specified in item 2.

5. Items 3 and 4 for each of the performance variables defined, beginning with the first perfor-

mance variable.

6. Items 2 through 5 for all states in the model.

The format of the exp.det file is as follows: If the model does not contain any deterministic

activity, this file contains a single 0. If the model has one or more deterministic activities the format

is as follows, with each enumerated item appearing on a new line starting from line No.1.

1. A 1 to denote that the model has deterministic activities.

2. The time for the deterministic activity.

3. All states in which a deterministic activity can complete with the time value in item 2.

4. A 0 to mark the end of the possible states with time value in item 2.

5. If more than one deterministic activity exists, items 2 through 4 for each deterministic activity.
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Index
absorbing states

flagging of, in model generator, 4-6
in dss, 4-11
in iss, 4-12

accuracy, 4-7, 4-9
activation, 3-20
activation predicate, see also reactivation

function, 1-3
activity, 1-2

completion, 1-2, 1-4
enabling, 1-2, 1-4
instantaneous, see instantaneous activity
specification, 3-18
timed, see timed activity

activity time distribution, 1-2
specification, 1-7

activity variables, 1-12, 1-13, 3-28, 3-29, 3-33
specification, 1-16

analytic solvers, 4-5, 4-7
applicability for different measures and

models, 4-2
basic rules, 4-1
steady-state, direct, see dss
steady-state, iterative, see iss
steady-state, with deterministic activity, see

diss
transient, see trs
transient interval-of-time, distribution, see pdf
transient interval-of-time, mean, see ars
versus simulation, see simulation vs analytic

solution
arc, 3-15

directed, 1-3, 1-4
ars, 4-3, 4-17

pitfalls and hints, 4-18

batch means method, 4-20
bug report, see problem report

case, 1-3
probability, 1-3
probability specification, 1-7, 3-20
ZERO specification, 1-7, 3-20

common places
in join, 1-10
in rep, 1-10

compedit, 2-2, 3-11, 3-24

tutorial, 2-11
compilation error, 3-13
complexity

time, see system time, user time
composed model, 1-10

automatic state space reduction, 1-12
creation of, see compedit
efficient simulation execution, 1-12
running example, 1-10

confidence intervals, 2-17, 4-23, 4-25
batch means in SSim, see batch means method
independent replica in TSim, see independent

replica
control panel (CP), 2-2, 3-1

debug file, 4-7
demo projects, A-4
deterministic activities

analytic solution, see diss
diss, 4-3, 4-13

for interval-of-time measures, 4-15
marking dependent deterministic times, 4-15
pitfalls and hints, 4-15

distributed computation, see Machine
distribution of reward measures, 1-13

mean, 1-13
percentiles, 1-13
variance, 1-13

documenting results
by Project->Document, 3-8
with report generator, see report generator

drop tolerance
in dss, 4-10

dss, 4-3, 4-9
pitfalls and hints, 4-11

Edit

Composed Model, see also compedit, 3-24
IS Governor, see also IS governor, 3-33
Performability Variables, see also

varedit, 3-28
Studies, see also stdedit, 3-34
Subnet, see also sanedit, 2-4, 3-12

environment setup, A-3
experiment, 1-9
Experiment

Clean, 3-10
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Select, 3-10

faulty microprocessor example, 1-2, 1-6, 2-1
file format analytic models

deterministic activity (exp.det), C-2
Markov model (exp.rbm), C-1
reward variables (exp.var), C-2

fill-in
in diss, 4-15
in dss, 4-11

gate
input gate, see input gate
output gate, see output gate

Gen, see reduced base model generator
General, 3-4

Bug Report, 3-4
Display File, 3-5
Report Generator, see also report

generator, 3-5
Transfer Project, 3-4

global variables, 1-7, 3-15, 3-18
in compedit, 1-10, 2-7
in IS governor, 6-2
in sanedit, 1-9, 2-7
reported in solvers, 4-8
value assignment, see stdedit

gnuplot, see report generator
governor, see IS governor
graphs, see report generator

importance sampling, 3-33, 4-3, 6-1
biased model, 6-2
governor, see IS governor
tool, see ITSim

impulse reward, 1-12, 1-13, 3-31
and state space generation, 1-18
specification, 1-14, 1-15

independent replica, 4-20
initial marking

for transient solution, 4-17
input gate, 1-2, 1-3, 3-16, 3-20

enabling predicate, 1-3
function, 1-3
specification, 1-8, 3-20

installation, A-1
steps, A-2

instantaneous activity, 1-2, 1-6, 3-16, 3-20
interval-of-time measures, 1-13

analytic solution for transient distribution, see
pdf

analytic solution for transient mean, see ars
for impulse rewards, 1-13
time-averaged, 1-13

IS governor, 3-11, 6-2
activity biasing, 6-2, 6-3
case biasing, 6-2, 6-5
example, 6-2
pitfalls and hints, 6-7
specification, 6-3
states, 6-2

specification, 6-5
transitions, 6-2

specification, 6-5
isedit, see also IS governor, 3-11
iss, 4-3, 4-11

pitfalls and hints, 4-12
tutorial, 2-23

ITSim, see also IS governor, 4-3, 4-20

jackknifing, 4-21
join, 1-10, 3-24–3-26

tutorial, 2-13

likelihood ratio
in importance sampling, 6-2

LU decomposition
in dss, 4-9

Machine

Edit, 3-10
Select, 3-10

MARK, 1-9, 2-7, 3-14, 3-17
marking, see also stable marking, unstable

marking, reachable marking, 1-2
Markov model, 1-16

file format generator matrix, see file format
analytic models

multi-processor example, 6-2

NaN, 4-11
new users, see environment setup, installation

output gate, 1-2, 1-3, 3-16, 3-20
function, 1-4
specification, 1-8, 3-20

pdf, 4-3, 4-18
pitfalls and hints, 4-20

performability variables, 1-12
definition, see varedit
running example, 1-14

place, 1-2, 3-16, 3-18, 3-25, 3-26
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plots, see report generator, splot, gnuplot
problem report, 3-4
project, 2-2
Project

Archive, 3-6
Clean, 3-6, 3-7, 3-10
Copy, 3-6
Create, 2-2, 3-5, 3-12
Delete, 3-6
directory structure, B-1
Document, 3-7, 3-8, 5-1
Select, 3-6, 3-8, 3-12, 3-24
Unarchive, 3-6

rare events, 6-1
example, 6-3

rate reward, 1-12, 3-29
specification, 1-14

reachable marking, 1-6
reactivation, 1-3, 1-6, 3-20

for Markov models, 1-17, 1-18
reactivation function, see also activation

predicate, reactivation predicate, 1-3
reactivation predicate, 1-3
reduced base model generator, 4-5

pitfalls and hints, 4-6
tutorial, 2-22

rep, 1-10, 3-24–3-26
tutorial, 2-12

replicate, see rep
report generator, 3-5, 5-1

3-D plot, 5-1
Export, 5-8
Gnuplot, 5-2
Graph, 5-1, 5-7
Import, 5-8
Splot, 5-2
Table, 5-3, 5-7
tutorial, 2-25

reward variables, see also impulse reward, rate
reward, 1-12, 2-13, 3-28, 3-29, 3-32

definition, see varedit
tutorial, 2-17

run in the background, 4-8
running example, see faulty microprocessor

SAN, 1-1
composed model, see composed model
creation of, see sanedit
execution of, 1-4
primitives, 1-2

running example, 1-6
stabilizing, see stabilizing
theory, 1-1
well-specified, see well-specified

sanedit, 2-2, 3-11, 3-12
Delete, 3-14
Font, 3-14
Grid, 3-15
Quit, 3-13, 3-14
Save, 3-13
Save All, 3-13, 3-14
Select All, 3-14
tutorial, 2-2

simulation, see also simulators
applicability for different measures and

models, 4-2
basic rules, 4-1

simulation vs analytic solution, 1-18, 4-1
advantages analytic solvers, 4-3
advantages simulation, 4-4
basic rules, 4-1
disadvantages analytic solvers, 4-4
disadvantages simulation, 4-4
practical hints, 4-3

simulators, see also simulation, 4-20
importance sampling, see ITSim
pitfalls and hints, 4-24
statistics, 1-14, 2-17
steady-state, see SSim
trace level, 4-21
transient/terminating, see TSim
variance computation, 4-21

Solve

Accumulated Reward Solver, see also
ars, 4-17

Deterministic Iterative Steady

State Solver, see also diss, 4-13
Direct Steady State Solver, see also

dss, 4-9
IS Terminating Simulator, see also

ITSim, 4-20
Iterative Steady State Solver, see

also iss, 4-11
Probability Distribution Solver, see

also pdf, 4-18
Reduced Base Model Generator, see also

reduced base model generator, 4-5
Steady State Simulator, see also SSim,

4-20
Terminating Simulator, see also TSim,

4-20
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Transient Solver, see also trs, 4-16
tutorial, 2-22

solvers, see also analytic solvers, simulators, 4-1
tutorial, 2-22

splot
for distributions, see also documenting

results, 4-8
in report generator, see report generator

SSim, 4-3, 4-20
confidence interval, see confidence intervals
pitfalls and hints, 4-24
tutorial, 2-23

stabilizing, 1-6
stable marking, 1-4
state

in underlying stochastic process, 1-18
including impulse rewards, 1-18

state space generation, 1-16, 1-18
stdedit, 2-2, 3-11, 3-34

Add, 3-34
Delete, 3-34
Export, 3-35
Import, 3-35
Range, 3-34, 3-36
Set, 3-34
tutorial, 2-18

steady-state detection
in diss, 4-14

steady-state measures, 1-13
direct analytic solution, see dss
for models with deterministic activity, see diss
iterative analytic solution, see iss
simulation, see SSim

stiff models
in iss, 4-13
in trs, 4-17

stochastic activity network, see SAN
stochastic process, 1-16

for analytic solution, 1-16
with deterministic and exponential activities,

1-17
with only exponential activities, 1-16
with only exponential activities but not

Markov, 1-17
Study

Clean, 3-9, 3-10
Select, 2-21, 3-9

study, 1-9
editor, see stedit

subnet, 2-2
Subnet

Copy, 3-8
Create, 2-4, 3-8, 3-12
Delete, 3-9
Document, 3-7, 3-9
Select, 3-8, 3-9, 3-12

successive over relaxation (SOR)
in diss, 4-13
in iss, 4-11

system time, 4-9

terminating simulation, see TSim
timed activity, 1-2, 3-16, 3-18
tokens, 1-2
trace level

in simulators, 4-21
transient measures, 1-13

analytic solution instant-of-time, see trs
analytic solution interval-of-time,

distribution, see pdf
analytic solution interval-of-time, mean, see

ars
simulation, see TSim

trs, 4-3, 4-16
pitfalls and hints, 4-17

TSim, 4-3, 4-20
confidence interval, see confidence intervals
pitfalls and hints, 4-24

UltraSAN organization, B-1
uniformization

in ars, 4-18
in diss, 4-13
in pdf, 4-18
in trs, 4-16
steady-state detection, see steady-state

detection
unstable marking, 1-4, 1-6
user time, 4-9

varedit, 1-12, 2-2, 3-11, 3-28
running example, 1-14
tutorial, 2-13

verbosity, 4-7

well-specified, 1-6

zero on the diagonal
in iss, 4-12

ZERO specification, see case, ZERO specification


